summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2007-03-19 15:49:21 +0000
committerDoug Goldstein <cardoe@gentoo.org>2007-03-19 15:49:21 +0000
commit73d93c7ca785f384964b968547706de98b4ec4d4 (patch)
tree992804de5da124b2d6489196cdac633bad9c629a /media-tv
parentremove unused media-video/mplayer use flags (diff)
downloadgentoo-2-73d93c7ca785f384964b968547706de98b4ec4d4.tar.gz
gentoo-2-73d93c7ca785f384964b968547706de98b4ec4d4.tar.bz2
gentoo-2-73d93c7ca785f384964b968547706de98b4ec4d4.zip
Patch mcpu to march, since mcpu is deprecated and their usage of mcpu should be march
(Portage version: 2.1.2.2)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythtv/ChangeLog4
-rw-r--r--media-tv/mythtv/files/mythtv-trunk-mcpu-march.patch79
-rw-r--r--media-tv/mythtv/mythtv-0.21_pre12945.ebuild14
3 files changed, 94 insertions, 3 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index 690937d03c2e..47835aa39b1d 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,11 +1,11 @@
# ChangeLog for media-tv/mythtv
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.144 2007/03/19 07:30:29 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.145 2007/03/19 15:49:21 cardoe Exp $
19 Mar 2007; Doug Goldstein <cardoe@gentoo.org>
mythtv-0.21_pre12945.ebuild:
Upstream removed building backend and frontend only support to spite Gentoo
- users. Remove options that were consolidated into 'iptv'.
+ users. Remove options that were consolidated into 'iptv'. Patch mcpu to march.
19 Mar 2007; Doug Goldstein <cardoe@gentoo.org> mythtv-0.20_p12963.ebuild,
mythtv-0.20_p13053.ebuild, mythtv-0.21_pre12945.ebuild:
diff --git a/media-tv/mythtv/files/mythtv-trunk-mcpu-march.patch b/media-tv/mythtv/files/mythtv-trunk-mcpu-march.patch
new file mode 100644
index 000000000000..8d3cb198cab3
--- /dev/null
+++ b/media-tv/mythtv/files/mythtv-trunk-mcpu-march.patch
@@ -0,0 +1,79 @@
+--- configure 2007-03-19 03:03:48.000000000 -0400
++++ /home/cardoe/configure.mythtv 2007-03-19 03:19:37.000000000 -0400
+@@ -1766,50 +1766,50 @@
+ if test $tune != "generic"; then
+ case $tune in
+ 601|ppc601|PowerPC601)
+- ARCHFLAGS="-mcpu=601"
++ ARCHFLAGS="-march=601"
+ if test $altivec = "yes"; then
+ echo "WARNING: Tuning for PPC601 but AltiVec enabled!";
+ fi
+ ;;
+ 603*|ppc603*|PowerPC603*)
+- ARCHFLAGS="-mcpu=603"
++ ARCHFLAGS="-march=603"
+ if test $altivec = "yes"; then
+ echo "WARNING: Tuning for PPC603 but AltiVec enabled!";
+ fi
+ ;;
+ 604*|ppc604*|PowerPC604*)
+- ARCHFLAGS="-mcpu=604"
++ ARCHFLAGS="-march=604"
+ if test $altivec = "yes"; then
+ echo "WARNING: Tuning for PPC604 but AltiVec enabled!";
+ fi
+ ;;
+ G3|g3|75*|ppc75*|PowerPC75*)
+- ARCHFLAGS="-mcpu=750 -mtune=750 -mpowerpc-gfxopt"
++ ARCHFLAGS="-march=750 -mtune=750 -mpowerpc-gfxopt"
+ if test $altivec = "yes"; then
+ echo "WARNING: Tuning for PPC75x but AltiVec enabled!";
+ fi
+ ;;
+ G4|g4|745*|ppc745*|PowerPC745*)
+- ARCHFLAGS="-mcpu=7450 -mtune=7450 -mpowerpc-gfxopt"
++ ARCHFLAGS="-march=7450 -mtune=7450 -mpowerpc-gfxopt"
+ if test $altivec = "no"; then
+ echo "WARNING: Tuning for PPC745x but AltiVec disabled!";
+ fi
+ ;;
+ 74*|ppc74*|PowerPC74*)
+- ARCHFLAGS="-mcpu=7400 -mtune=7400 -mpowerpc-gfxopt"
++ ARCHFLAGS="-march=7400 -mtune=7400 -mpowerpc-gfxopt"
+ if test $altivec = "no"; then
+ echo "WARNING: Tuning for PPC74xx but AltiVec disabled!";
+ fi
+ ;;
+ G5|g5|970|ppc970|PowerPC970|power4*|Power4*)
+- ARCHFLAGS="-mcpu=970 -mtune=970 -mpowerpc-gfxopt -mpowerpc64"
++ ARCHFLAGS="-march=970 -mtune=970 -mpowerpc-gfxopt -mpowerpc64"
+ if test $altivec = "no"; then
+ echo "WARNING: Tuning for PPC970 but AltiVec disabled!";
+ fi
+ POWERPCMODE="64bits"
+ ;;
+ sparc64)
+- ARCHFLAGS="-mcpu=v9 -mtune=v9"
++ ARCHFLAGS="-march=v9 -mtune=v9"
+ ;;
+ *)
+ ARCHFLAGS="-mtune=$tune"
+@@ -1818,7 +1818,7 @@
+ fi
+
+ if test x"$cpu_overide" = x"yes"; then
+- ARCHFLAGS="-mcpu=$arch_raw $ARCHFLAGS"
++ ARCHFLAGS="-march=$arch_raw $ARCHFLAGS"
+ fi
+
+ # make sure we can execute files in $TMPDIR
+@@ -2045,7 +2045,7 @@
+ if test x"$tune" = x"generic" -a x"$arch" = x"x86_64" -a x"$cpu_overide" != x"yes"; then
+ ARCHFLAGS="-march=k8"
+ elif test x"$tune" = x"generic" -a x"$arch" = x"sparc64" -a x"$cpu_overide" != x"yes"; then
+- ARCHFLAGS="-mcpu=ultrasparc -mvis"
++ ARCHFLAGS="-march=ultrasparc -mvis"
+ fi
+
+ if test x"$proc_error_msg" = x"yes"; then
diff --git a/media-tv/mythtv/mythtv-0.21_pre12945.ebuild b/media-tv/mythtv/mythtv-0.21_pre12945.ebuild
index b30266c19ef2..c4fcbdb6c606 100644
--- a/media-tv/mythtv/mythtv-0.21_pre12945.ebuild
+++ b/media-tv/mythtv/mythtv-0.21_pre12945.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_pre12945.ebuild,v 1.3 2007/03/19 07:30:29 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_pre12945.ebuild,v 1.4 2007/03/19 15:49:21 cardoe Exp $
inherit flag-o-matic multilib eutils qt3 mythtv subversion
@@ -95,6 +95,18 @@ pkg_setup() {
echo
}
+src_unpack() {
+ subversion_src_unpack
+
+ # mcpu to march
+ epatch "${FILESDIR}"/${PN}-trunk-mcpu-march.patch
+
+ # As needed fix since they don't know how to write qmake let alone a real
+ # make system. And they won't accept this upstream since it comes from
+ # Gentoo
+ #epatch "${FILESDIR}"/${PN}-0.20-as-needed.patch
+}
+
src_compile() {
local myconf="--prefix=/usr
--mandir=/usr/share/man