summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-10-28 16:15:16 +0000
committerMax Kalika <max@gentoo.org>2003-10-28 16:15:16 +0000
commite159677133d0412e6242c543eaa4d93bd90f8591 (patch)
tree257a5bfb69027a40811b4b5b19f5dff21e8fdb00 /media-tv
parentDisable DVB for now. Extend CPU detection. Fix potential portage bug in pkg_s... (diff)
downloadgentoo-2-e159677133d0412e6242c543eaa4d93bd90f8591.tar.gz
gentoo-2-e159677133d0412e6242c543eaa4d93bd90f8591.tar.bz2
gentoo-2-e159677133d0412e6242c543eaa4d93bd90f8591.zip
Remove DVB depend. Extend CPU detection. Fix potential portage bug in pkg_setup().
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythfrontend/ChangeLog6
-rw-r--r--media-tv/mythfrontend/Manifest4
-rw-r--r--media-tv/mythfrontend/mythfrontend-0.12.ebuild7
3 files changed, 11 insertions, 6 deletions
diff --git a/media-tv/mythfrontend/ChangeLog b/media-tv/mythfrontend/ChangeLog
index 69a2119f4418..e8a3e8e28346 100644
--- a/media-tv/mythfrontend/ChangeLog
+++ b/media-tv/mythfrontend/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/mythfrontend
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/ChangeLog,v 1.6 2003/10/20 03:07:33 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/ChangeLog,v 1.7 2003/10/28 16:15:15 max Exp $
+
+ 28 Oct 2003; Max Kalika <max@gentoo.org> mythfrontend-0.12.ebuild:
+ Remove DVB depend. Extend CPU detection. Fix potential portage bug in
+ pkg_setup().
*mythfrontend-0.12 (19 Oct 2003)
diff --git a/media-tv/mythfrontend/Manifest b/media-tv/mythfrontend/Manifest
index a7657dd24969..5c16b83c1246 100644
--- a/media-tv/mythfrontend/Manifest
+++ b/media-tv/mythfrontend/Manifest
@@ -1,7 +1,7 @@
MD5 c3f67cc91781e0b6358a0a1cf9971157 mythfrontend-0.11.ebuild 1415
MD5 aed36892462269a8080b52fa26962f65 mythfrontend-0.10.ebuild 1479
-MD5 83af631723886f8d0812eae35c194c27 ChangeLog 1043
-MD5 23d181c2e32ce6f7256faa894d5e2d36 mythfrontend-0.12.ebuild 2816
+MD5 40f65a16415626a2f9299afa96a4233c ChangeLog 1200
+MD5 1b083ee6bfff0d9a00025757e9462061 mythfrontend-0.12.ebuild 2816
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 e14a28e72b9ac693884dc418dbeef119 files/digest-mythfrontend-0.10 65
MD5 5234ae53ed7b1bb9ed541d47207430f8 files/digest-mythfrontend-0.11 65
diff --git a/media-tv/mythfrontend/mythfrontend-0.12.ebuild b/media-tv/mythfrontend/mythfrontend-0.12.ebuild
index 287a4be74df6..e8fc6e888665 100644
--- a/media-tv/mythfrontend/mythfrontend-0.12.ebuild
+++ b/media-tv/mythfrontend/mythfrontend-0.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.12.ebuild,v 1.1 2003/10/20 03:07:33 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.12.ebuild,v 1.2 2003/10/28 16:15:15 max Exp $
inherit flag-o-matic
@@ -19,7 +19,6 @@ DEPEND="virtual/x11
>=media-libs/freetype-2.0
>=sys-apps/sed-4
alsa? ( media-libs/alsa-lib )
- dvb? ( media-libs/libdvb )
lcd? ( app-misc/lcdproc )
lirc? ( app-misc/lirc )
nvidia? ( media-video/nvidia-glx )"
@@ -36,6 +35,8 @@ pkg_setup() {
eerror "'mysql' to your USE flags, and re-emerge Qt."
die "Qt needs mysql support"
fi
+
+ return 0
}
src_unpack() {
@@ -47,7 +48,7 @@ src_unpack() {
}
src_compile() {
- local cpu="`get-flag march`"
+ local cpu="`get-flag march || get-flag mcpu`"
if [ "${cpu}" ] ; then
sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
fi