summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomás Touceda <chiiph@gentoo.org>2011-05-08 01:51:38 +0000
committerTomás Touceda <chiiph@gentoo.org>2011-05-08 01:51:38 +0000
commita8ae3ccc0bcbc1dc910e0b3d69da9ce64f57689a (patch)
tree90b919fec4d717675a2f647344ae757a845b928a /media-video/2mandvd
parentUpdate SRC_URI wrt bug 363615 (diff)
downloadgentoo-2-a8ae3ccc0bcbc1dc910e0b3d69da9ce64f57689a.tar.gz
gentoo-2-a8ae3ccc0bcbc1dc910e0b3d69da9ce64f57689a.tar.bz2
gentoo-2-a8ae3ccc0bcbc1dc910e0b3d69da9ce64f57689a.zip
Fix patch and unpack output wrt bug 364553
(Portage version: 2.2.0_alpha29/cvs/Linux i686)
Diffstat (limited to 'media-video/2mandvd')
-rw-r--r--media-video/2mandvd/2mandvd-1.5.5.ebuild9
-rw-r--r--media-video/2mandvd/ChangeLog6
-rw-r--r--media-video/2mandvd/files/2mandvd-fix-const-char-concatenation.patch15
3 files changed, 19 insertions, 11 deletions
diff --git a/media-video/2mandvd/2mandvd-1.5.5.ebuild b/media-video/2mandvd/2mandvd-1.5.5.ebuild
index 62b45d28110c..a70414e75a9d 100644
--- a/media-video/2mandvd/2mandvd-1.5.5.ebuild
+++ b/media-video/2mandvd/2mandvd-1.5.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/2mandvd-1.5.5.ebuild,v 1.1 2011/04/22 16:00:01 chiiph Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/2mandvd-1.5.5.ebuild,v 1.2 2011/05/08 01:51:38 chiiph Exp $
EAPI="2"
LANGS="cs de en it"
@@ -37,9 +37,14 @@ RDEPEND="${DEPEND}
media-video/mjpegtools
media-video/mplayer[encode]"
+S="${WORKDIR}/${MY_PN}"
+
PATCHES=( "${FILESDIR}/2mandvd-fix-const-char-concatenation.patch" )
-S="${WORKDIR}/${MY_PN}"
+src_unpack() {
+ # Filter alot of noisy messages (differences between bsd tar and gnu one):
+ unpack ${A} 2> "/dev/null"
+}
src_prepare() {
# Cleaning old backup files:
diff --git a/media-video/2mandvd/ChangeLog b/media-video/2mandvd/ChangeLog
index fb4d4d9390f4..19abe577aad2 100644
--- a/media-video/2mandvd/ChangeLog
+++ b/media-video/2mandvd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/2mandvd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/ChangeLog,v 1.16 2011/04/22 16:00:01 chiiph Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/ChangeLog,v 1.17 2011/05/08 01:51:38 chiiph Exp $
+
+ 08 May 2011; Tomas Touceda <chiiph@gentoo.org>
+ files/2mandvd-fix-const-char-concatenation.patch, 2mandvd-1.5.5.ebuild:
+ Fix patch and unpack output wrt bug 364553
*2mandvd-1.5.5 (22 Apr 2011)
diff --git a/media-video/2mandvd/files/2mandvd-fix-const-char-concatenation.patch b/media-video/2mandvd/files/2mandvd-fix-const-char-concatenation.patch
index b8d01e50a280..8d5177c0eaa7 100644
--- a/media-video/2mandvd/files/2mandvd-fix-const-char-concatenation.patch
+++ b/media-video/2mandvd/files/2mandvd-fix-const-char-concatenation.patch
@@ -1,15 +1,14 @@
-Index: 2ManDVD/mainfrm.cpp
-===================================================================
---- 2ManDVD.orig/mainfrm.cpp
-+++ 2ManDVD/mainfrm.cpp
-@@ -1045,8 +1045,8 @@ mainfrm::mainfrm(QWidget *parent) : QMai
+diff -Naur 2ManDVD.orig/mainfrm.cpp 2ManDVD/mainfrm.cpp
+--- 2ManDVD.orig/mainfrm.cpp 2011-05-07 22:29:20.049000080 -0300
++++ 2ManDVD/mainfrm.cpp 2011-05-07 22:30:30.055000081 -0300
+@@ -1403,8 +1403,8 @@
outext << "growisofs" << endl;
outext << "mpeg2enc" << endl;
outext << "jpegtopnm /dev/null" << endl;
-- outext << "cat " + "/usr/share/2mandvd//fake.pl" << endl;
+- outext << "cat " + "/usr/share/2mandvd/fake.pl" << endl;
- outext << "rm -f " + homeDir.path() + "/.mdvdep.sh" << endl;
-+ outext << "cat " << "/usr/share/2mandvd//fake.pl" << endl;
-+ outext << "rm -f " << homeDir.path()<<"/.mdvdep.sh" << endl;
++ outext << "cat " << "/usr/share/2mandvd/fake.pl" << endl;
++ outext << "rm -f " << homeDir.path() << "/.mdvdep.sh" << endl;
outext << "exit" << endl;
wmyficext.close();
QString programf = "bash";