summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2003-01-15 05:32:13 +0000
committerLuca Barbato <lu_zero@gentoo.org>2003-01-15 05:32:13 +0000
commitcbdaf0a6bddfc78ecfa6fb384390780d2392054d (patch)
tree8fc2c728d81a67c199ca35c54b902c6e85d8a713 /media-video/ati-drivers/ati-drivers-2.5.1-r1.ebuild
parentadded ppc to keywords (diff)
downloadgentoo-2-cbdaf0a6bddfc78ecfa6fb384390780d2392054d.tar.gz
gentoo-2-cbdaf0a6bddfc78ecfa6fb384390780d2392054d.tar.bz2
gentoo-2-cbdaf0a6bddfc78ecfa6fb384390780d2392054d.zip
fix
Diffstat (limited to 'media-video/ati-drivers/ati-drivers-2.5.1-r1.ebuild')
-rw-r--r--media-video/ati-drivers/ati-drivers-2.5.1-r1.ebuild137
1 files changed, 137 insertions, 0 deletions
diff --git a/media-video/ati-drivers/ati-drivers-2.5.1-r1.ebuild b/media-video/ati-drivers/ati-drivers-2.5.1-r1.ebuild
new file mode 100644
index 000000000000..b35e7cbb7d3d
--- /dev/null
+++ b/media-video/ati-drivers/ati-drivers-2.5.1-r1.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ati-drivers/ati-drivers-2.5.1-r1.ebuild,v 1.1 2003/01/15 05:32:13 lu_zero Exp $
+
+IUSE="qt kde gnome"
+
+SRC_URI="http://pdownload.mii.instacontent.net/ati/drivers/fglrx-glc22-4.2.0-${PV}.i586.rpm"
+HOMEPAGE="http://www.ati.com"
+DESCRIPTION="Ati precompiled drivers for r300, r250 and r200 chipsets"
+
+LICENSE="ATI GPL QPL"
+SLOT="${KV}"
+KEYWORDS="~x86 -ppc -sparc -sparc64"
+
+DEPEND=">=virtual/linux-sources-2.4
+ >=sys-libs/glibc-2.2.2
+ sys-apps/cpio
+ app-arch/rpm
+ qt? ( >=x11-libs/qt-3.0 )"
+
+ATIBIN="${D}/opt/ati/bin"
+RESTRICT="nostrip"
+
+src_unpack() {
+ cd ${WORKDIR}
+ rpm2cpio ${DISTDIR}/${A} | cpio --extract --make-directories --unconditional
+}
+
+src_compile() {
+
+ einfo "building the glx module"
+
+ cd ${WORKDIR}/lib/modules/fglrx/build_mod
+ ./make.sh || ewarn "glx module not built"
+
+
+ einfo "building the fgl_glxgears sample"
+
+ mkdir ${WORKDIR}/fglrxgears
+ cd ${WORKDIR}/fglrxgears
+ tar -xzvf ${WORKDIR}/usr/src/fglrx_sample_source.tgz
+ mv xc/programs/fgl_glxgears/* .
+ make -f Makefile.Linux || die
+
+ if [ "`use qt`" ]
+ then
+ einfo "building the qt fglx panel"
+ cd ${WORKDIR}
+ local OLDBIN="/usr/X11R6/bin"
+ local ATIBIN="${D}/opt/ati/bin"
+ mkdir fglrx_panel
+ cd fglrx_panel
+ tar -xzvf ${WORKDIR}/usr/src/fglrx_panel_sources.tgz
+ sed -e "s:"${OLDBIN}":"${ATIBIN}":"\
+ Makefile >Makefile.new
+ mv Makefile.new Makefile
+ emake || die
+ fi
+
+#removing stuff
+ einfo "cleaning"
+ cd ${WORKDIR}
+ rm -fR usr/share
+ cd usr/X11R6/
+ rm -fR bin/firegl*.bz2 bin/LICENSE.* bin/fgl_glxgears src
+}
+
+pkg_preinst() {
+# clean the dinamic libGL stuff's home to ensure
+# we dont have stale libs floating around
+ if [ -d ${ROOT}/usr/lib/opengl/ati ]
+ then
+ rm -rf ${ROOT}/usr/lib/opengl/ati/*
+ fi
+}
+
+src_install() {
+ local ATI_ROOT="/usr/lib/opengl/ati"
+
+ cd ${WORKDIR}
+
+#drm module
+ insinto /lib/modules/${KV}/video
+ doins lib/modules/fglrx/build_mod/fglrx.o
+
+#dri driver
+ exeinto ${ATI_ROOT}/lib
+ doexe usr/X11R6/lib/libGL.so.1.2
+ dosym libGL.so.1.2 ${ATI_ROOT}/lib/libGL.so.1
+ dosym libGL.so.1.2 ${ATI_ROOT}/lib/libGL.so
+ dosym libGL.so.1.2 ${ATI_ROOT}/lib/libMesaGL.so
+ #that is the same as in the xfree
+ dosym ../../xfree/lib/libGL.la ${ATI_ROOT}/lib/libGL.la
+
+#same as in xfree
+ exeinto ${ATI_ROOT}/
+ dosym ../xfree/include ${ATI_ROOT}/include
+ dosym ../xfree/extensions ${ATI_ROOT}/extensions
+ rm usr/X11R6/lib/libGL.so.1.2
+
+#apps
+ insinto /etc/env.d
+ doins ${FILESDIR}/09ati
+ exeinto /opt/ati/bin
+ doexe fglrxgears/fgl_glxgears
+ doexe usr/X11R6/bin/*
+ rm usr/X11R6/bin/*
+
+ if [ "`use qt`" ]
+ then
+ doexe fglrx_panel/fireglcontrol
+ fi
+
+ #if ["`use kde`"] then
+
+
+ #if ["`use gnome`"]
+ cp -R usr ${D}
+}
+
+pkg_postinst() {
+#switch to the ati implementation
+ if [ "${ROOT}" = "/" ]
+ then
+ /usr/sbin/opengl-update ati
+ fi
+
+ einfo
+ einfo "To use the xfree GLX, run \"opengl-update xfree\""
+ einfo
+ einfo
+ einfo "To chance your XF86Config you can use the bundled \"fglrxconfig\""
+ einfo
+
+#drm-module
+ update-modules
+}