summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2002-12-26 22:56:00 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2002-12-26 22:56:00 +0000
commit9e51c292b833d0c6df0ee6158521ac0416ed41da (patch)
tree65016c4857c68d716e8af1300e130075cb42b36d /media-video/ati-drivers
parentChanged "~x86" to "x86" in KEYWORDS. (diff)
downloadgentoo-2-9e51c292b833d0c6df0ee6158521ac0416ed41da.tar.gz
gentoo-2-9e51c292b833d0c6df0ee6158521ac0416ed41da.tar.bz2
gentoo-2-9e51c292b833d0c6df0ee6158521ac0416ed41da.zip
Initial import, thanks to lu_zero from bug # 11322
Diffstat (limited to 'media-video/ati-drivers')
-rw-r--r--media-video/ati-drivers/ChangeLog16
-rw-r--r--media-video/ati-drivers/ati-drivers-2.5.1.ebuild135
-rw-r--r--media-video/ati-drivers/files/09ati2
-rw-r--r--media-video/ati-drivers/files/digest-ati-drivers-2.5.11
4 files changed, 154 insertions, 0 deletions
diff --git a/media-video/ati-drivers/ChangeLog b/media-video/ati-drivers/ChangeLog
new file mode 100644
index 000000000000..8f7c277e71e7
--- /dev/null
+++ b/media-video/ati-drivers/ChangeLog
@@ -0,0 +1,16 @@
+# ChangeLog for media-video/ati-drivers
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/media-video/ati-drivers/ChangeLog,v 1.1 2002/12/26 22:56:00 bcowan Exp $
+
+*ati-drivers-2.5.1 (26 Dec 2002)
+
+ 26 Dec 2002; Brad Cowan <bcowan@gentoo.org> ati-drivers-2.5.1.ebuild,
+ ChangeLog, files/digest-ati-drivers-2.5.1:
+ Initial import.
+
+ 29 Nov 2002; Luca Barbato <lu_zero@psxfanatics.com> ati-drivers-2.5.1.ebuild,
+ ChangeLog, files/digest-ati-drivers-2.5.1:
+ Initial ebuild for the ati precompiled drivers.
+ The idea of using cpio is from the icc ebuilds, the rest is from the nvidia-*
+ ebuilds.
+
diff --git a/media-video/ati-drivers/ati-drivers-2.5.1.ebuild b/media-video/ati-drivers/ati-drivers-2.5.1.ebuild
new file mode 100644
index 000000000000..d3bfbbf5fe60
--- /dev/null
+++ b/media-video/ati-drivers/ati-drivers-2.5.1.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ati-drivers/ati-drivers-2.5.1.ebuild,v 1.1 2002/12/26 22:56:00 bcowan Exp $
+
+IUSE="qt kde gnome"
+
+SRC_URI="http://pdownload.mii.instacontent.net/ati/drivers/fglrx-glc22-4.2.0-${PV}.i586.rpm"
+HOMEPAGE="http://www.ati.com"
+DESCRIPTION="Ati precompiled drivers for r300, r250 and r200 chipsets"
+
+LICENSE="ATI GPL QPL"
+SLOT="${KV}"
+KEYWORDS="~x86 -ppc -sparc -sparc64"
+
+DEPEND=">=virtual/linux-sources-2.4
+ >=sys-libs/glibc-2.2.2
+ sys-apps/cpio
+ app-arch/rpm
+ qt? ( >=x11-libs/qt-3.0 )"
+
+ATIBIN="${D}/opt/ati/bin"
+RESTRICT="nostrip"
+
+src_unpack() {
+ cd ${WORKDIR}
+ rpm2cpio ${DISTDIR}/${A} | cpio --extract --make-directories --unconditional
+}
+
+src_compile() {
+ einfo "building the glx module"
+
+ cd ${WORKDIR}/lib/modules/fglrx/build_mod
+ ./make.sh
+
+ einfo "building the fgl_glxgears sample"
+
+ mkdir ${WORKDIR}/fglrxgears
+ cd ${WORKDIR}/fglrxgears
+ tar -xzvf ${WORKDIR}/usr/src/fglrx_sample_source.tgz
+ mv xc/programs/fgl_glxgears/* .
+ make -f Makefile.Linux || die
+
+ if [ "`use qt`" ]
+ then
+ einfo "building the qt fglx panel"
+ cd ${WORKDIR}
+ local OLDBIN="/usr/X11R6/bin"
+ local ATIBIN="${D}/opt/ati/bin"
+ mkdir fglrx_panel
+ cd fglrx_panel
+ tar -xzvf ${WORKDIR}/usr/src/fglrx_panel_sources.tgz
+ sed -e "s:"${OLDBIN}":"${ATIBIN}":"\
+ Makefile >Makefile.new
+ mv Makefile.new Makefile
+ emake || die
+ fi
+
+#removing stuff
+ einfo "cleaning"
+ cd ${WORKDIR}
+ rm -fR usr/share
+ cd usr/X11R6/
+ rm -fR bin/firegl*.bz2 bin/LICENSE.* bin/fgl_glxgears src
+}
+
+pkg_preinst() {
+# clean the dinamic libGL stuff's home to ensure
+# we dont have stale libs floating around
+ if [ -d ${ROOT}/usr/lib/opengl/ati ]
+ then
+ rm -rf ${ROOT}/usr/lib/opengl/ati/*
+ fi
+}
+
+src_install() {
+ local ATI_ROOT="/usr/lib/opengl/ati"
+
+ cd ${WORKDIR}
+
+#drm module
+ insinto /lib/modules/${KV}/video
+ doins lib/modules/fglrx/build_mod/fglrx.o
+
+#dri driver
+ exeinto ${ATI_ROOT}/lib
+ doexe usr/X11R6/lib/libGL.so.1.2
+ dosym libGL.so.1.2 ${ATI_ROOT}/lib/libGL.so.1
+ dosym libGL.so.1.2 ${ATI_ROOT}/lib/libGL.so
+ dosym libGL.so.1.2 ${ATI_ROOT}/lib/libMesaGL.so
+ #that is the same as in the xfree
+ dosym ../xfree/libGL.la ${ATI_ROOT}/lib/libGL.la
+
+#same as in xfree
+ exeinto ${ATI_ROOT}/
+ dosym ../xfree/include ${ATI_ROOT}/include
+ dosym ../xfree/extensions ${ATI_ROOT}/extensions
+ rm usr/X11R6/lib/libGL.so.1.2
+
+#apps
+ insinto /etc/env.d
+ doins ${FILESDIR}/09ati
+ exeinto /opt/ati/bin
+ doexe fglrxgears/fgl_glxgears
+ doexe usr/X11R6/bin/*
+ rm usr/X11R6/bin/*
+
+ if [ "`use qt`" ]
+ then
+ doexe fglrx_panel/fireglcontrol
+ fi
+
+ #if ["`use kde`"] then
+
+
+ #if ["`use gnome`"]
+ cp -R usr ${D}
+}
+
+pkg_postinst() {
+#switch to the ati implementation
+ if [ "${ROOT}" = "/" ]
+ then
+ /usr/sbin/opengl-update ati
+ fi
+
+ einfo
+ einfo "To use the xfree GLX, run \"opengl-update xfree\""
+ einfo
+ einfo
+ einfo "To chance your XF86Config you can use the bundled \"fglrxconfig\""
+ einfo
+
+#drm-module
+ update-modules
+}
diff --git a/media-video/ati-drivers/files/09ati b/media-video/ati-drivers/files/09ati
new file mode 100644
index 000000000000..4b0639956072
--- /dev/null
+++ b/media-video/ati-drivers/files/09ati
@@ -0,0 +1,2 @@
+PATH=/opt/ati/bin
+ROOTPATH=/opt/ati/bin \ No newline at end of file
diff --git a/media-video/ati-drivers/files/digest-ati-drivers-2.5.1 b/media-video/ati-drivers/files/digest-ati-drivers-2.5.1
new file mode 100644
index 000000000000..872b99adf142
--- /dev/null
+++ b/media-video/ati-drivers/files/digest-ati-drivers-2.5.1
@@ -0,0 +1 @@
+MD5 eef0d547931f8aefd3a19cf1ec09001a fglrx-glc22-4.2.0-2.5.1.i586.rpm 5118135