summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-04-04 17:01:52 +0000
committerSamuli Suominen <drac@gentoo.org>2007-04-04 17:01:52 +0000
commit0c7fbeef564bbd1369e97bb52d79d587f6c5ed0a (patch)
treefe6fffc4d878d37e8bf227cd5375efdcc954a85c /media-video/camsource
parentVersion bump (diff)
downloadgentoo-2-0c7fbeef564bbd1369e97bb52d79d587f6c5ed0a.tar.gz
gentoo-2-0c7fbeef564bbd1369e97bb52d79d587f6c5ed0a.tar.bz2
gentoo-2-0c7fbeef564bbd1369e97bb52d79d587f6c5ed0a.zip
Version bump to unofficial release since upstream CVS has been quiet for three years. Thanks to Conrad Kostecki in bug 170349.
(Portage version: 2.1.2.3)
Diffstat (limited to 'media-video/camsource')
-rw-r--r--media-video/camsource/ChangeLog10
-rw-r--r--media-video/camsource/camsource-0.7.1.ebuild40
-rw-r--r--media-video/camsource/files/camsource-0.7.1-example.patch12
-rw-r--r--media-video/camsource/files/camsource.initd22
-rw-r--r--media-video/camsource/files/digest-camsource-0.7.13
5 files changed, 86 insertions, 1 deletions
diff --git a/media-video/camsource/ChangeLog b/media-video/camsource/ChangeLog
index bce4d8bb891c..db93f0ad6ce2 100644
--- a/media-video/camsource/ChangeLog
+++ b/media-video/camsource/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-video/camsource
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/camsource/ChangeLog,v 1.16 2007/02/22 01:44:10 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/camsource/ChangeLog,v 1.17 2007/04/04 17:01:52 drac Exp $
+
+*camsource-0.7.1 (04 Apr 2007)
+
+ 04 Apr 2007; Samuli Suominen <drac@gentoo.org>
+ +files/camsource-0.7.1-example.patch, +files/camsource.initd,
+ +camsource-0.7.1.ebuild:
+ Version bump to unofficial release since upstream CVS has been quiet for
+ three years. Thanks to Conrad Kostecki in bug 170349.
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/media-video/camsource/camsource-0.7.1.ebuild b/media-video/camsource/camsource-0.7.1.ebuild
new file mode 100644
index 000000000000..0b7b9ecbcd29
--- /dev/null
+++ b/media-video/camsource/camsource-0.7.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/camsource/camsource-0.7.1.ebuild,v 1.1 2007/04/04 17:01:52 drac Exp $
+
+inherit eutils
+
+DESCRIPTION="Unofficial release of Camsource, grabs images from a v4l and v4l2 webcam devices."
+HOMEPAGE="http://koti.mbnet.fi/~turja/vino"
+SRC_URI="http://koti.mbnet.fi/~turja/vino/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/libxml2-2.4.22
+ >=media-libs/jpeg-6b"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-example.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog README
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ insinto /etc
+ doins ${PN}.conf.example
+ exeinto /usr/share/${PN}
+ doexe scripts/camsource2bmp.pl
+}
+
+pkg_postinst() {
+ elog
+ elog "Edit /etc/camsource.conf.example config to your liking."
+ elog
+}
diff --git a/media-video/camsource/files/camsource-0.7.1-example.patch b/media-video/camsource/files/camsource-0.7.1-example.patch
new file mode 100644
index 000000000000..34ed1a16d1fa
--- /dev/null
+++ b/media-video/camsource/files/camsource-0.7.1-example.patch
@@ -0,0 +1,12 @@
+diff -ur camsource-0.7.1.orig/camsource.conf.example camsource-0.7.1/camsource.conf.example
+--- camsource-0.7.1.orig/camsource.conf.example 2006-03-05 13:48:09.000000000 +0200
++++ camsource-0.7.1/camsource.conf.example 2007-04-04 19:54:45.000000000 +0300
+@@ -142,7 +142,7 @@
+ using the input_v4l2-plugin.
+ -->
+ <camdev name="third" active="no">
+- <--
++ <!--
+ Video4Linux2 input plugin
+
+ Most of the settings are the same as with
diff --git a/media-video/camsource/files/camsource.initd b/media-video/camsource/files/camsource.initd
new file mode 100644
index 000000000000..84571897e2c1
--- /dev/null
+++ b/media-video/camsource/files/camsource.initd
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+opts="start stop status"
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting Camsource"
+ start-stop-daemon --start --exec /usr/bin/camsource >/dev/null 2>&1
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Camsource"
+ start-stop-daemon --stop --name camsource
+ eend $?
+}
+
diff --git a/media-video/camsource/files/digest-camsource-0.7.1 b/media-video/camsource/files/digest-camsource-0.7.1
new file mode 100644
index 000000000000..a01af3a76a50
--- /dev/null
+++ b/media-video/camsource/files/digest-camsource-0.7.1
@@ -0,0 +1,3 @@
+MD5 164f7b1abf0289e66f1aaa4228afa325 camsource-0.7.1.tar.gz 360053
+RMD160 0a4ed23adaefb61716ee131f7213d8d1788ba57a camsource-0.7.1.tar.gz 360053
+SHA256 ca464e8ee3300690828072eee4953ae9ff6d81d69c9b7c99d9bcf2419be02cbe camsource-0.7.1.tar.gz 360053