summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-10-10 00:42:05 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-10-10 00:42:05 +0000
commit5d2b2932449280ac8db6d4ccb8ac965cdbac67a7 (patch)
tree1635a214b3ccf358724d126f2f6a031c199fac60 /media-video/cclive
parentFixing Homepage, other half of #285068 (diff)
downloadgentoo-2-5d2b2932449280ac8db6d4ccb8ac965cdbac67a7.tar.gz
gentoo-2-5d2b2932449280ac8db6d4ccb8ac965cdbac67a7.tar.bz2
gentoo-2-5d2b2932449280ac8db6d4ccb8ac965cdbac67a7.zip
Bump to 0.5.2. Fixes #288211. Ebuild improvements by Tomas Chvatal.
(Portage version: 2.2_rc44/cvs/Linux x86_64)
Diffstat (limited to 'media-video/cclive')
-rw-r--r--media-video/cclive/ChangeLog7
-rw-r--r--media-video/cclive/cclive-0.5.2.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/media-video/cclive/ChangeLog b/media-video/cclive/ChangeLog
index 87fcb60fb15f..9cd2b53ba5c4 100644
--- a/media-video/cclive/ChangeLog
+++ b/media-video/cclive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/cclive
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cclive/ChangeLog,v 1.5 2009/09/18 09:35:33 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cclive/ChangeLog,v 1.6 2009/10/10 00:42:05 patrick Exp $
+
+*cclive-0.5.2 (10 Oct 2009)
+
+ 10 Oct 2009; Patrick Lauer <patrick@gentoo.org> +cclive-0.5.2.ebuild:
+ Bump to 0.5.2. Fixes #288211. Ebuild improvements by Tomas Chvatal.
*cclive-0.5.1 (18 Sep 2009)
diff --git a/media-video/cclive/cclive-0.5.2.ebuild b/media-video/cclive/cclive-0.5.2.ebuild
new file mode 100644
index 000000000000..980117e490e3
--- /dev/null
+++ b/media-video/cclive/cclive-0.5.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/cclive/cclive-0.5.2.ebuild,v 1.1 2009/10/10 00:42:05 patrick Exp $
+
+EAPI=2
+
+DESCRIPTION="Command line tool for extracting videos from various websites"
+HOMEPAGE="http://code.google.com/p/cclive/"
+SRC_URI="http://cclive.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND=">=net-misc/curl-7.18.0
+ >=dev-libs/libpcre-7.9[cxx]"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --with-man \
+ $(use_enable test tests)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+}
+
+src_test() {
+ einfo "Tests require internet connection in order to work."
+ ADULT_OK="true" emake check || die "emake test failed"
+}