summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-04-15 14:13:11 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-04-15 14:13:11 +0000
commit1d2a1c701aac2dc0ae23bfa679d0b56374e271a8 (patch)
treefeb4a95a42c8056c1ca8e409dd472d169ec3361b /media-video/cinepaint
parentStable on ppc wrt bug 174216 (diff)
downloadgentoo-2-1d2a1c701aac2dc0ae23bfa679d0b56374e271a8.tar.gz
gentoo-2-1d2a1c701aac2dc0ae23bfa679d0b56374e271a8.tar.bz2
gentoo-2-1d2a1c701aac2dc0ae23bfa679d0b56374e271a8.zip
Version bump
(Portage version: 2.1.2.3)
Diffstat (limited to 'media-video/cinepaint')
-rw-r--r--media-video/cinepaint/ChangeLog10
-rw-r--r--media-video/cinepaint/cinepaint-0.22.0.ebuild41
-rw-r--r--media-video/cinepaint/files/cinepaint-0.22.0-as-needed.patch12
-rw-r--r--media-video/cinepaint/files/digest-cinepaint-0.22.03
4 files changed, 64 insertions, 2 deletions
diff --git a/media-video/cinepaint/ChangeLog b/media-video/cinepaint/ChangeLog
index 080bcb4d251c..a73911af1b47 100644
--- a/media-video/cinepaint/ChangeLog
+++ b/media-video/cinepaint/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/cinepaint
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cinepaint/ChangeLog,v 1.15 2006/11/26 18:56:11 aballier Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/cinepaint/ChangeLog,v 1.16 2007/04/15 14:13:11 aballier Exp $
+
+*cinepaint-0.22.0 (15 Apr 2007)
+
+ 15 Apr 2007; Alexis Ballier <aballier@gentoo.org>
+ +files/cinepaint-0.22.0-as-needed.patch, +cinepaint-0.22.0.ebuild:
+ Version bump
26 Nov 2006; Alexis Ballier <aballier@gentoo.org>
-files/cinepaint-0.18.3-gcc34.patch, -cinepaint-0.18.ebuild,
diff --git a/media-video/cinepaint/cinepaint-0.22.0.ebuild b/media-video/cinepaint/cinepaint-0.22.0.ebuild
new file mode 100644
index 000000000000..fc472ef3afdf
--- /dev/null
+++ b/media-video/cinepaint/cinepaint-0.22.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/cinepaint/cinepaint-0.22.0.ebuild,v 1.1 2007/04/15 14:13:11 aballier Exp $
+
+inherit eutils versionator flag-o-matic
+
+MY_PV=$(replace_version_separator 2 '-')
+S=${WORKDIR}/${PN}-${MY_PV}
+DESCRIPTION="motion picture editing tool used for painting and retouching of movies"
+SRC_URI="mirror://sourceforge/cinepaint/${PN}-${MY_PV}.tar.gz"
+HOMEPAGE="http://cinepaint.sourceforge.net/"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="GPL-2"
+IUSE="png zlib"
+
+DEPEND=">=x11-libs/gtk+-2.0
+ png? ( >=media-libs/libpng-1.2 )
+ zlib? ( sys-libs/zlib )
+ media-libs/openexr
+ >=media-libs/lcms-1.16
+ media-libs/tiff
+ media-libs/jpeg
+ x11-libs/fltk"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+}
+
+src_compile(){
+ # gutenprint is not in portage
+ econf --disable-print --enable-gtk2 || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README NEWS
+}
diff --git a/media-video/cinepaint/files/cinepaint-0.22.0-as-needed.patch b/media-video/cinepaint/files/cinepaint-0.22.0-as-needed.patch
new file mode 100644
index 000000000000..6dbbdd5cb719
--- /dev/null
+++ b/media-video/cinepaint/files/cinepaint-0.22.0-as-needed.patch
@@ -0,0 +1,12 @@
+Index: cinepaint-0.22-0/lib/Makefile.in
+===================================================================
+--- cinepaint-0.22-0.orig/lib/Makefile.in
++++ cinepaint-0.22-0/lib/Makefile.in
+@@ -299,6 +299,7 @@ EXTRA_DIST = version.h.in
+ lib_LTLIBRARIES = libcinepaint.la
+ libcinepaint_la_LIBADD = \
+ ./wire/libwire.la \
++ $(GTK_LIBS) \
+ $(top_builddir)/libhalf/libcinepaintHalf.la
+
+ libcinepaint_la_SOURCES = \
diff --git a/media-video/cinepaint/files/digest-cinepaint-0.22.0 b/media-video/cinepaint/files/digest-cinepaint-0.22.0
new file mode 100644
index 000000000000..71b092556609
--- /dev/null
+++ b/media-video/cinepaint/files/digest-cinepaint-0.22.0
@@ -0,0 +1,3 @@
+MD5 f7b0110da38e86d00ec5f4e459cf8fbb cinepaint-0.22-0.tar.gz 12361580
+RMD160 3376e7033f8854c321bf5cf5c2b7ed351d6db86f cinepaint-0.22-0.tar.gz 12361580
+SHA256 911296c2e10cd24bf6c685ef55ab07079a18ebbbd8dceb13dffb2d4e8b612981 cinepaint-0.22-0.tar.gz 12361580