summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2009-03-03 10:52:32 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2009-03-03 10:52:32 +0000
commit4e4df1139f245dddb09687cb1bf041935a0ccdb3 (patch)
treef431e2c03821ef487eb9cf4a220add79d82c2ef7 /media-video/em8300-libraries
parentVersion bumped due to bug #239208. (diff)
downloadgentoo-2-4e4df1139f245dddb09687cb1bf041935a0ccdb3.tar.gz
gentoo-2-4e4df1139f245dddb09687cb1bf041935a0ccdb3.tar.bz2
gentoo-2-4e4df1139f245dddb09687cb1bf041935a0ccdb3.zip
Version bumped.
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'media-video/em8300-libraries')
-rw-r--r--media-video/em8300-libraries/ChangeLog10
-rw-r--r--media-video/em8300-libraries/em8300-libraries-0.17.2.ebuild67
2 files changed, 75 insertions, 2 deletions
diff --git a/media-video/em8300-libraries/ChangeLog b/media-video/em8300-libraries/ChangeLog
index be055ee62a45..abfb4f7ee71d 100644
--- a/media-video/em8300-libraries/ChangeLog
+++ b/media-video/em8300-libraries/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/em8300-libraries
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-libraries/ChangeLog,v 1.37 2008/10/30 20:13:34 dertobi123 Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-libraries/ChangeLog,v 1.38 2009/03/03 10:52:32 zzam Exp $
+
+*em8300-libraries-0.17.2 (03 Mar 2009)
+
+ 03 Mar 2009; Matthias Schwarzott <zzam@gentoo.org>
+ +em8300-libraries-0.17.2.ebuild:
+ Version bumped.
30 Oct 2008; Tobias Scherbaum <dertobi123@gentoo.org>
em8300-libraries-0.16.0.ebuild:
diff --git a/media-video/em8300-libraries/em8300-libraries-0.17.2.ebuild b/media-video/em8300-libraries/em8300-libraries-0.17.2.ebuild
new file mode 100644
index 000000000000..86d8a43040bd
--- /dev/null
+++ b/media-video/em8300-libraries/em8300-libraries-0.17.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-libraries/em8300-libraries-0.17.2.ebuild,v 1.1 2009/03/03 10:52:32 zzam Exp $
+
+WANT_AUTOMAKE=1.9
+WANT_AUTOCONF=2.5
+
+inherit flag-o-matic autotools
+
+MY_P="${P/-libraries/}"
+
+DESCRIPTION="em8300 (RealMagic Hollywood+/Creative DXR3) video decoder card libraries"
+HOMEPAGE="http://dxr3.sourceforge.net"
+SRC_URI="mirror://sourceforge/dxr3/${MY_P}.tar.gz"
+
+RDEPEND="~media-video/em8300-modules-${PV}
+ gtk? ( >=x11-libs/gtk+-2.0 )"
+
+DEPEND="dev-util/pkgconfig
+ gtk? ( >=x11-libs/gtk+-2.0 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Separate kernel modules.
+ sed -i -e 's:modules/\ ::g' Makefile.am
+
+ # Fix Makefile bug.
+ sed -i -e "s:test -z \"\$(firmwaredir)\":test -z\"\$(DESTDIR)(firmwaredir)\":g" Makefile.am
+
+ eautomake
+}
+
+src_compile () {
+ use amd64 && append-flags -fPIC
+
+ econf \
+ $(use_enable gtk gtktest) || die "econf failed."
+
+ emake || die "emake failed."
+}
+
+src_install () {
+ dodir /lib/firmware
+ emake DESTDIR="${D}" em8300incdir=/usr/include/linux install \
+ || die "emake install failed."
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ elog "The em8300 libraries and modules have now been installed,"
+ elog "you will probably want to add /usr/bin/em8300setup to your"
+ elog "/etc/conf.d/local.start so that your em8300 card is "
+ elog "properly initialized on boot."
+ elog
+ elog "If you still need a microcode other than the one included"
+ elog "with the package, you can simply use em8300setup <microcode.ux>"
+}