summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-10-11 05:31:14 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-10-11 05:31:14 +0000
commit0583b1249867421df382051cd0c6c8c34061a64a (patch)
tree0fa91e00a6153f185064fa1fd81777ca61cfd4ab /media-video/ffmpeg
parentbump yasm dep (diff)
downloadgentoo-2-0583b1249867421df382051cd0c6c8c34061a64a.tar.gz
gentoo-2-0583b1249867421df382051cd0c6c8c34061a64a.tar.bz2
gentoo-2-0583b1249867421df382051cd0c6c8c34061a64a.zip
there is now a libfdk-aac decoder, move it to the decoder section
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ChangeLog5
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild11
2 files changed, 10 insertions, 6 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index 7557c31dfbdc..e7e5aec65c43 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.681 2013/10/11 05:27:49 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.682 2013/10/11 05:31:14 aballier Exp $
+
+ 11 Oct 2013; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild:
+ there is now a libfdk-aac decoder, move it to the decoder section
11 Oct 2013; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild:
bump yasm dep
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 2e1aef3074e4..adb30f8db22a 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.137 2013/10/11 05:27:49 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.138 2013/10/11 05:31:14 aballier Exp $
EAPI="5"
@@ -75,7 +75,6 @@ RDEPEND="
aacplus? ( media-libs/libaacplus )
amrenc? ( media-libs/vo-amrwbenc )
faac? ( media-libs/faac )
- fdk? ( media-libs/fdk-aac )
mp3? ( >=media-sound/lame-3.98.3 )
theora? ( >=media-libs/libtheora-1.1.1[encode] media-libs/libogg )
twolame? ( media-sound/twolame )
@@ -83,6 +82,7 @@ RDEPEND="
x264? ( >=media-libs/x264-0.0.20111017:= )
xvid? ( >=media-libs/xvid-1.1.0 )
)
+ fdk? ( media-libs/fdk-aac )
flite? ( app-accessibility/flite )
fontconfig? ( media-libs/fontconfig )
frei0r? ( media-plugins/frei0r-plugins )
@@ -165,7 +165,7 @@ src_configure() {
# Encoders
if use encode
then
- ffuse="${ffuse} aac:libvo-aacenc amrenc:libvo-amrwbenc mp3:libmp3lame fdk:libfdk-aac"
+ ffuse="${ffuse} aac:libvo-aacenc amrenc:libvo-amrwbenc mp3:libmp3lame"
for i in aacplus faac theora twolame wavpack x264 xvid; do
ffuse="${ffuse} ${i}:lib${i}"
done
@@ -174,7 +174,7 @@ src_configure() {
if use aac || use amrenc ; then
myconf="${myconf} --enable-version3"
fi
- if use aacplus || use faac || use fdk ; then
+ if use aacplus || use faac ; then
myconf="${myconf} --enable-nonfree"
fi
else
@@ -206,11 +206,12 @@ src_configure() {
ffuse="${ffuse} threads:pthreads"
# Decoders
- ffuse="${ffuse} amr:libopencore-amrwb amr:libopencore-amrnb jpeg2k:libopenjpeg"
+ ffuse="${ffuse} amr:libopencore-amrwb amr:libopencore-amrnb fdk:libfdk-aac jpeg2k:libopenjpeg"
use amr && myconf="${myconf} --enable-version3"
for i in bluray celt gme gsm modplug opus quvi rtmp schroedinger speex vorbis vpx; do
ffuse="${ffuse} ${i}:lib${i}"
done
+ use fdk && myconf="${myconf} --enable-nonfree"
for i in ${ffuse} ; do
myconf="${myconf} $(use_enable ${i%:*} ${i#*:})"