summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-09-29 15:34:17 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-09-29 15:34:17 +0000
commitafe53864f2f67f4355f5725024f42838503eaa70 (patch)
treea90be9db440e19df504816f099e414d1e12de47c /media-video/ffmpeg
parentkeyword ~ppc64, bug #436566 (diff)
downloadgentoo-2-afe53864f2f67f4355f5725024f42838503eaa70.tar.gz
gentoo-2-afe53864f2f67f4355f5725024f42838503eaa70.tar.bz2
gentoo-2-afe53864f2f67f4355f5725024f42838503eaa70.zip
add fdk useflag
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ChangeLog6
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild8
-rw-r--r--media-video/ffmpeg/metadata.xml1
3 files changed, 11 insertions, 4 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index f8bba5c7f50d..781d3da71ac9 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.583 2012/09/29 15:17:30 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.584 2012/09/29 15:34:17 aballier Exp $
+
+ 29 Sep 2012; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild,
+ metadata.xml:
+ add fdk useflag
29 Sep 2012; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild:
tests now work without zlib
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index f6372998dc5c..9559f9f1f577 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.106 2012/09/29 15:17:30 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.107 2012/09/29 15:34:17 aballier Exp $
EAPI="4"
@@ -30,8 +30,8 @@ if [ "${PV#9999}" = "${PV}" ] ; then
fi
IUSE="
aac aacplus alsa amr avresample bindist bluray +bzip2 cdio celt
- cpudetection debug doc +encode faac flite fontconfig frei0r gnutls gsm
- +hardcoded-tables iec61883 ieee1394 jack jpeg2k libass libcaca libv4l
+ cpudetection debug doc +encode faac fdk flite fontconfig frei0r gnutls
+ gsm +hardcoded-tables iec61883 ieee1394 jack jpeg2k libass libcaca libv4l
modplug mp3 network openal openssl opus oss pic pulseaudio rtmp schroedinger
sdl speex static-libs test theora threads truetype twolame v4l vaapi vdpau
vorbis vpx X x264 xvid +zlib
@@ -63,6 +63,7 @@ RDEPEND="
aacplus? ( media-libs/libaacplus )
amr? ( media-libs/vo-amrwbenc )
faac? ( media-libs/faac )
+ fdk? ( media-libs/fdk-aac )
mp3? ( >=media-sound/lame-3.98.3 )
theora? ( >=media-libs/libtheora-1.1.1[encode] media-libs/libogg )
twolame? ( media-sound/twolame )
@@ -157,6 +158,7 @@ src_configure() {
done
use aacplus && myconf="${myconf} --enable-libaacplus --enable-nonfree"
use faac && myconf="${myconf} --enable-libfaac --enable-nonfree"
+ use fdk && myconf="${myconf} --enable-libfdk-aac --enable-nonfree"
else
myconf="${myconf} --disable-encoders"
fi
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index 61be2c61a3fd..a3f868e20b25 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -21,6 +21,7 @@
<flag name="cpudetection">Enables runtime CPU detection (useful for bindist, compatibility on other CPUs)</flag>
<flag name="dirac">Enable Dirac video support (an advanced royalty-free video compression format) via the reference library: dirac.</flag>
<flag name="faac">Use external faac library for AAC encoding</flag>
+ <flag name="fdk">Use external fdk-aac library for AAC encoding</flag>
<flag name="flite">Adds a text-to-speech filter based on <pkg>app-accessibility/flite</pkg>.</flag>
<flag name="frei0r">Enable frei0r wrapping in libavfilter</flag>
<flag name="hardcoded-tables">Use pre-calculated tables rather than calculating them on the fly.</flag>