summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2009-11-26 04:37:15 +0000
committerSteve Dibb <beandog@gentoo.org>2009-11-26 04:37:15 +0000
commite3530504b8fcef58832d948aca2afce75afe8d4d (patch)
treeefba79619bf92ad4fc464499501de93359c8870f /media-video/ffmpeg
parentFix x264 dep; add patch to build against libtheora-1.0; bug 294496 (diff)
downloadgentoo-2-e3530504b8fcef58832d948aca2afce75afe8d4d.tar.gz
gentoo-2-e3530504b8fcef58832d948aca2afce75afe8d4d.tar.bz2
gentoo-2-e3530504b8fcef58832d948aca2afce75afe8d4d.zip
Fix x264 compiling; libtheora patch for 1.0; bug 294469
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ChangeLog8
-rw-r--r--media-video/ffmpeg/ffmpeg-0.5_p20601-r1.ebuild (renamed from media-video/ffmpeg/ffmpeg-0.5_p20601.ebuild)8
-rw-r--r--media-video/ffmpeg/files/ffmpeg-0.5_p20601-r1-libtheora.patch39
3 files changed, 52 insertions, 3 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index 4b9497a20827..59abc92d2f44 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.329 2009/11/25 06:06:20 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.330 2009/11/26 04:37:15 beandog Exp $
+
+*ffmpeg-0.5_p20601-r1 (26 Nov 2009)
+
+ 26 Nov 2009; Steve Dibb <beandog@gentoo.org> -ffmpeg-0.5_p20601.ebuild,
+ +ffmpeg-0.5_p20601-r1.ebuild, +files/ffmpeg-0.5_p20601-r1-libtheora.patch:
+ Fix x264 compiling; libtheora patch for 1.0; bug 294469
25 Nov 2009; Steve Dibb <beandog@gentoo.org> ffmpeg-0.5_p20601.ebuild,
ffmpeg-9999-r1.ebuild:
diff --git a/media-video/ffmpeg/ffmpeg-0.5_p20601.ebuild b/media-video/ffmpeg/ffmpeg-0.5_p20601-r1.ebuild
index 6680701a570c..c23b571a219c 100644
--- a/media-video/ffmpeg/ffmpeg-0.5_p20601.ebuild
+++ b/media-video/ffmpeg/ffmpeg-0.5_p20601-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.5_p20601.ebuild,v 1.2 2009/11/25 06:06:20 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.5_p20601-r1.ebuild,v 1.1 2009/11/26 04:37:15 beandog Exp $
EAPI=2
SCM=""
@@ -43,7 +43,7 @@ RDEPEND="sdl? ( >=media-libs/libsdl-1.2.10 )
faac? ( media-libs/faac )
mp3? ( media-sound/lame )
vorbis? ( media-libs/libvorbis media-libs/libogg )
- theora? ( >=media-libs/libtheora-1.1.1[encode] media-libs/libogg )
+ theora? ( media-libs/libtheora[encode] media-libs/libogg )
x264? ( >=media-libs/x264-0.0.20091021 )
xvid? ( >=media-libs/xvid-1.1.0 ) )
faad? ( >=media-libs/faad2-2.6.1 )
@@ -78,6 +78,10 @@ src_prepare() {
elif [ "${PV%_p*}" != "${PV}" ] ; then # Snapshot
sed -i s/UNKNOWN/SVN-r${FFMPEG_REVISION}/ "${S}/version.sh"
fi
+
+ # This got added in right after this snapshot
+ # Small fix to build against libtheora-1.0
+ epatch "${FILESDIR}/${PF}-libtheora.patch"
}
src_configure() {
diff --git a/media-video/ffmpeg/files/ffmpeg-0.5_p20601-r1-libtheora.patch b/media-video/ffmpeg/files/ffmpeg-0.5_p20601-r1-libtheora.patch
new file mode 100644
index 000000000000..baec435eba9f
--- /dev/null
+++ b/media-video/ffmpeg/files/ffmpeg-0.5_p20601-r1-libtheora.patch
@@ -0,0 +1,39 @@
+--- libavcodec/libtheoraenc.c.orig 2009-11-25 20:55:18.000000000 -0700
++++ libavcodec/libtheoraenc.c 2009-11-25 20:55:21.000000000 -0700
+@@ -86,6 +86,7 @@
+
+ static int get_stats(AVCodecContext *avctx, int eos)
+ {
++#ifdef TH_ENCCTL_2PASS_OUT
+ TheoraContext *h = avctx->priv_data;
+ uint8_t *buf;
+ int bytes;
+@@ -108,12 +109,17 @@
+ av_base64_encode(avctx->stats_out, b64_size, h->stats, h->stats_offset);
+ }
+ return 0;
++#else
++ av_log(avctx, AV_LOG_ERROR, "libtheora too old to support 2pass\n");
++ return -1;
++#endif
+ }
+
+ // libtheora won't read the entire buffer we give it at once, so we have to
+ // repeatedly submit it...
+ static int submit_stats(AVCodecContext *avctx)
+ {
++#ifdef TH_ENCCTL_2PASS_IN
+ TheoraContext *h = avctx->priv_data;
+ int bytes;
+ if (!h->stats) {
+@@ -138,6 +144,10 @@
+ h->stats_offset += bytes;
+ }
+ return 0;
++#else
++ av_log(avctx, AV_LOG_ERROR, "libtheora too old to support 2pass\n");
++ return -1;
++#endif
+ }
+
+ static av_cold int encode_init(AVCodecContext* avc_context)