summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-06-27 11:50:55 +0000
committerSamuli Suominen <drac@gentoo.org>2007-06-27 11:50:55 +0000
commitada280a59d9136593c9d091e240f7646172fcc85 (patch)
tree74c34f2fd4b8c93cb28b8aaa0f1a4f8c63af2f53 /media-video/ffmpegthumbnailer
parentAdd ffmpegthumbnailer-1.1.2 to p.mask because required ffmpeg is there as well. (diff)
downloadgentoo-2-ada280a59d9136593c9d091e240f7646172fcc85.tar.gz
gentoo-2-ada280a59d9136593c9d091e240f7646172fcc85.tar.bz2
gentoo-2-ada280a59d9136593c9d091e240f7646172fcc85.zip
Version bump with swscale patch.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'media-video/ffmpegthumbnailer')
-rw-r--r--media-video/ffmpegthumbnailer/ChangeLog9
-rw-r--r--media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.1.2.ebuild29
-rw-r--r--media-video/ffmpegthumbnailer/files/digest-ffmpegthumbnailer-1.1.23
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-1.1.2-swscale.patch9
4 files changed, 49 insertions, 1 deletions
diff --git a/media-video/ffmpegthumbnailer/ChangeLog b/media-video/ffmpegthumbnailer/ChangeLog
index 7185f100be1b..d02f452d3cf0 100644
--- a/media-video/ffmpegthumbnailer/ChangeLog
+++ b/media-video/ffmpegthumbnailer/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/ffmpegthumbnailer
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.20 2007/06/14 11:21:58 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.21 2007/06/27 11:50:55 drac Exp $
+
+*ffmpegthumbnailer-1.1.2 (27 Jun 2007)
+
+ 27 Jun 2007; Samuli Suominen <drac@gentoo.org>
+ +files/ffmpegthumbnailer-1.1.2-swscale.patch,
+ +ffmpegthumbnailer-1.1.2.ebuild:
+ Version bump with swscale patch.
14 Jun 2007; Raúl Porcel <armin76@gentoo.org>
ffmpegthumbnailer-1.1.1.ebuild:
diff --git a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.1.2.ebuild b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.1.2.ebuild
new file mode 100644
index 000000000000..c65d2a9bc3de
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.1.2.ebuild,v 1.1 2007/06/27 11:50:55 drac Exp $
+
+inherit eutils
+
+DESCRIPTION="Lightweight video thumbnailer that can be used by file managers"
+HOMEPAGE="http://code.google.com/p/ffmpegthumbnailer"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libpng
+ >=media-video/ffmpeg-0.4.9_p20070616-r1"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-swscale.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog README TODO
+}
diff --git a/media-video/ffmpegthumbnailer/files/digest-ffmpegthumbnailer-1.1.2 b/media-video/ffmpegthumbnailer/files/digest-ffmpegthumbnailer-1.1.2
new file mode 100644
index 000000000000..5ab12c1934a0
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/digest-ffmpegthumbnailer-1.1.2
@@ -0,0 +1,3 @@
+MD5 8bb179c313dbf9ec6a8f7a8fe21a8789 ffmpegthumbnailer-1.1.2.tar.gz 80137
+RMD160 74b7b3817b0cd9db50ca664ab01ab5ecad944c3d ffmpegthumbnailer-1.1.2.tar.gz 80137
+SHA256 cbe626b3d39f887d34f823c862ad25783ab0fef823c933b7fa848197ca752c4c ffmpegthumbnailer-1.1.2.tar.gz 80137
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-1.1.2-swscale.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-1.1.2-swscale.patch
new file mode 100644
index 000000000000..a0a4c412cd37
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-1.1.2-swscale.patch
@@ -0,0 +1,9 @@
+diff -ur ffmpegthumbnailer-1.1.2.orig/src/Makefile.am ffmpegthumbnailer-1.1.2/src/Makefile.am
+--- ffmpegthumbnailer-1.1.2.orig/src/Makefile.am 2007-06-01 23:47:05.000000000 +0300
++++ ffmpegthumbnailer-1.1.2/src/Makefile.am 2007-06-27 14:26:54.000000000 +0300
+@@ -7,4 +7,4 @@
+ pngwriter.h pngwriter.cpp \
+ stringoperations.h stringoperations.cpp
+
+-ffmpegthumbnailer_LDADD = -lavutil -lavcodec -lavformat -lpng
++ffmpegthumbnailer_LDADD = -lavutil -lavcodec -lavformat -lswscale -lpng