summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2009-02-27 18:40:56 +0000
committerSteve Dibb <beandog@gentoo.org>2009-02-27 18:40:56 +0000
commit703ee4522f75eee77b44ac2e91ab892d00b85c47 (patch)
tree6956012f1ac039c3182b3677676f96b86f2c7a55 /media-video/ffprobe
parentMarked ~ppc for bug #239847. (diff)
downloadgentoo-2-703ee4522f75eee77b44ac2e91ab892d00b85c47.tar.gz
gentoo-2-703ee4522f75eee77b44ac2e91ab892d00b85c47.tar.bz2
gentoo-2-703ee4522f75eee77b44ac2e91ab892d00b85c47.zip
Initial commit
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'media-video/ffprobe')
-rw-r--r--media-video/ffprobe/ChangeLog10
-rw-r--r--media-video/ffprobe/ffprobe-79.ebuild53
-rw-r--r--media-video/ffprobe/metadata.xml8
3 files changed, 71 insertions, 0 deletions
diff --git a/media-video/ffprobe/ChangeLog b/media-video/ffprobe/ChangeLog
new file mode 100644
index 000000000000..6c9e092dd80f
--- /dev/null
+++ b/media-video/ffprobe/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-video/ffprobe
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffprobe/ChangeLog,v 1.1 2009/02/27 18:40:56 beandog Exp $
+
+*ffprobe-79 (27 Feb 2009)
+
+ 27 Feb 2009; Steve Dibb <beandog@gentoo.org> +metadata.xml,
+ +ffprobe-79.ebuild:
+ Initial commit
+
diff --git a/media-video/ffprobe/ffprobe-79.ebuild b/media-video/ffprobe/ffprobe-79.ebuild
new file mode 100644
index 000000000000..b588ee24dbd2
--- /dev/null
+++ b/media-video/ffprobe/ffprobe-79.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffprobe/ffprobe-79.ebuild,v 1.1 2009/02/27 18:40:56 beandog Exp $
+
+inherit autotools
+
+DESCRIPTION="Tool to probe audio / video using ffmpeg and print pretty output"
+HOMEPAGE="http://sourceforge.net/projects/ffprobe/"
+SRC_URI="mirrors://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="perl"
+
+DEPEND="media-video/ffmpeg"
+RDEPEND="${DEPEND}
+ perl? ( virtual/perl-Scalar-List-Utils
+ virtual/perl-Getopt-Long
+ virtual/perl-File-Spec
+ dev-perl/Statistics-Descriptive
+ sci-visualization/gnuplot )"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ einfo "Regenerating autotools files..."
+ eautoconf || die "eautoconf failed"
+
+}
+
+src_install() {
+
+ dobin src/ffprobe
+ if use perl; then
+ newbin tools/plot-vframes-bitrate.pl plot-vframes-bitrate
+ newbin tools/plot-vframes-sizes.pl plot-vframes-sizes
+ fi
+ doman doc/ffprobe.1
+ dohtml doc/ffprobe.html
+ dodoc AUTHORS README
+
+}
+
+pkg_postinst() {
+
+ einfo "ffprobe with no arguments doesn't produce anything interesting"
+ einfo "other than the same output you would get with ffmpeg -i"
+ einfo "See -h for output options."
+
+}
diff --git a/media-video/ffprobe/metadata.xml b/media-video/ffprobe/metadata.xml
new file mode 100644
index 000000000000..291bf48e8e73
--- /dev/null
+++ b/media-video/ffprobe/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-video</herd>
+ <use>
+ <flag name="perl">Installs tools written in perl to produce plots based on video frame bitrate and size</flag>
+ </use>
+</pkgmetadata>