summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2006-10-16 19:50:24 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2006-10-16 19:50:24 +0000
commit196bbebdf98d2b0f9d359b057545e34cd2cf0832 (patch)
tree2af995374b04ca196fee4cca07541afe5886061e /media-video/gephex/gephex-0.4.3.ebuild
parent~amd64 with multilib-strict patch, bug #117274 (diff)
downloadgentoo-2-196bbebdf98d2b0f9d359b057545e34cd2cf0832.tar.gz
gentoo-2-196bbebdf98d2b0f9d359b057545e34cd2cf0832.tar.bz2
gentoo-2-196bbebdf98d2b0f9d359b057545e34cd2cf0832.zip
fix gcc-4.x issues; thanks to Pascal Martineau on #131831
(Portage version: 2.1.1)
Diffstat (limited to 'media-video/gephex/gephex-0.4.3.ebuild')
-rw-r--r--media-video/gephex/gephex-0.4.3.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/media-video/gephex/gephex-0.4.3.ebuild b/media-video/gephex/gephex-0.4.3.ebuild
index ff659c3fe888..d43b5c915c82 100644
--- a/media-video/gephex/gephex-0.4.3.ebuild
+++ b/media-video/gephex/gephex-0.4.3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/gephex/gephex-0.4.3.ebuild,v 1.8 2005/12/28 20:53:58 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/gephex/gephex-0.4.3.ebuild,v 1.9 2006/10/16 19:50:24 hd_brummy Exp $
+
+inherit eutils
DESCRIPTION="GePhex is a modular video effect framework."
HOMEPAGE="http://www.gephex.org"
@@ -24,8 +26,14 @@ DEPEND="virtual/x11
RDEPEND=${DEPEND}
-src_compile() {
+src_unpack() {
+ unpack ${A} || die
cd ${S}
+
+ epatch ${FILESDIR}/${P}-gcc4.patch
+}
+
+src_compile() {
# qt wants to create lock files etc. in that directory
addwrite "${QTDIR}/etc/settings"