summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-06-16 16:19:50 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-06-16 16:19:50 +0000
commit7454a1edab7d1216b2c038273686472ed1768cc2 (patch)
treebb698ae6ac7b27a709cbdcef9bd97a00fb8d1bfe /media-video/kmplayer
parentNew USE flag called "postscript" to replace USE="ps" and USE="gs" (diff)
downloadgentoo-2-7454a1edab7d1216b2c038273686472ed1768cc2.tar.gz
gentoo-2-7454a1edab7d1216b2c038273686472ed1768cc2.tar.bz2
gentoo-2-7454a1edab7d1216b2c038273686472ed1768cc2.zip
Version bump.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'media-video/kmplayer')
-rw-r--r--media-video/kmplayer/ChangeLog8
-rw-r--r--media-video/kmplayer/kmplayer-0.11.3d.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/media-video/kmplayer/ChangeLog b/media-video/kmplayer/ChangeLog
index 6e5c9f9c483c..bdd1ae34c675 100644
--- a/media-video/kmplayer/ChangeLog
+++ b/media-video/kmplayer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/kmplayer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/kmplayer/ChangeLog,v 1.151 2012/05/21 09:18:36 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/kmplayer/ChangeLog,v 1.152 2012/06/16 16:19:50 kensington Exp $
+
+*kmplayer-0.11.3d (16 Jun 2012)
+
+ 16 Jun 2012; Michael Palimaka <kensington@gentoo.org>
+ +kmplayer-0.11.3d.ebuild:
+ Version bump.
21 May 2012; Johannes Huber <johu@gentoo.org> -kmplayer-0.11.2c.ebuild,
-kmplayer-0.11.3b.ebuild:
diff --git a/media-video/kmplayer/kmplayer-0.11.3d.ebuild b/media-video/kmplayer/kmplayer-0.11.3d.ebuild
new file mode 100644
index 000000000000..ba9d29b22e76
--- /dev/null
+++ b/media-video/kmplayer/kmplayer-0.11.3d.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/kmplayer/kmplayer-0.11.3d.ebuild,v 1.1 2012/06/16 16:19:50 kensington Exp $
+
+EAPI=4
+KDE_LINGUAS="bg bs ca ca@valencia cs da de el en_GB eo es et fr ga gl hr hu it
+ja km ku lt lv mai nb nds nl nn pl pt pt_BR ro ru sk sr sr@latin sv th tr ug uk
+zh_CN zh_TW"
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KMPlayer is a Video player plugin for Konqueror and basic MPlayer/Xine/ffmpeg/ffserver/VDR frontend."
+HOMEPAGE="http://kmplayer.kde.org/"
+SRC_URI="http://kmplayer.kde.org/pkgs/${P}.tar.bz2"
+
+LICENSE="GPL-2 FDL-1.2 LGPL-2.1"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="cairo debug expat handbook npp"
+
+DEPEND="media-libs/phonon
+ x11-libs/libX11
+ expat? ( >=dev-libs/expat-2.0.1 )
+ cairo? (
+ x11-libs/cairo
+ x11-libs/pango
+ )
+ npp? (
+ dev-libs/dbus-glib
+ >=x11-libs/gtk+-2.10.14:2
+ )"
+RDEPEND="${DEPEND}
+ media-video/mplayer"
+
+DOCS=( AUTHORS ChangeLog README TODO )
+
+src_prepare() {
+ sed -e '/add_subdirectory(icons)/d' \
+ -i CMakeLists.txt || die
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use cairo KMPLAYER_BUILT_WITH_CAIRO)
+ $(cmake-utils_use expat KMPLAYER_BUILT_WITH_EXPAT)
+ $(cmake-utils_use npp KMPLAYER_BUILT_WITH_NPP)
+ )
+
+ kde4-base_src_configure
+}