summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-10-14 17:20:33 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-10-14 17:20:33 +0000
commit17be9f3e47508499b52f54888a9fcbb1c8052433 (patch)
treee0652efaa87119760a5da5825bbf921717ee60f1 /media-video/motion
parentVersion bump. (diff)
downloadgentoo-2-17be9f3e47508499b52f54888a9fcbb1c8052433.tar.gz
gentoo-2-17be9f3e47508499b52f54888a9fcbb1c8052433.tar.bz2
gentoo-2-17be9f3e47508499b52f54888a9fcbb1c8052433.zip
version bump
(Portage version: 2.2_rc12/cvs/Linux 2.6.26.6 x86_64)
Diffstat (limited to 'media-video/motion')
-rw-r--r--media-video/motion/ChangeLog8
-rw-r--r--media-video/motion/files/motion-3.2.11-offsett.patch13
-rw-r--r--media-video/motion/motion-3.2.11.ebuild69
3 files changed, 89 insertions, 1 deletions
diff --git a/media-video/motion/ChangeLog b/media-video/motion/ChangeLog
index 1f0c59ed0ee0..6aa1703716c7 100644
--- a/media-video/motion/ChangeLog
+++ b/media-video/motion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/motion
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/motion/ChangeLog,v 1.20 2008/10/14 17:02:21 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/motion/ChangeLog,v 1.21 2008/10/14 17:20:33 aballier Exp $
+
+*motion-3.2.11 (14 Oct 2008)
+
+ 14 Oct 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/motion-3.2.11-offsett.patch, +motion-3.2.11.ebuild:
+ version bump
14 Oct 2008; Alexis Ballier <aballier@gentoo.org>
-files/motion-3.2.4-ffmpeg-compat.patch,
diff --git a/media-video/motion/files/motion-3.2.11-offsett.patch b/media-video/motion/files/motion-3.2.11-offsett.patch
new file mode 100644
index 000000000000..f3116abbc816
--- /dev/null
+++ b/media-video/motion/files/motion-3.2.11-offsett.patch
@@ -0,0 +1,13 @@
+Index: motion-3.2.11/ffmpeg.c
+===================================================================
+--- motion-3.2.11.orig/ffmpeg.c
++++ motion-3.2.11/ffmpeg.c
+@@ -164,7 +164,7 @@ static int file_write(URLContext *h, uns
+ return write(fd, buf, size);
+ }
+
+-static offset_t file_seek(URLContext *h, offset_t pos, int whence)
++static int64_t file_seek(URLContext *h, int64_t pos, int whence)
+ {
+ int fd = (size_t)h->priv_data;
+ return lseek(fd, pos, whence);
diff --git a/media-video/motion/motion-3.2.11.ebuild b/media-video/motion/motion-3.2.11.ebuild
new file mode 100644
index 000000000000..afb5449e9182
--- /dev/null
+++ b/media-video/motion/motion-3.2.11.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/motion/motion-3.2.11.ebuild,v 1.1 2008/10/14 17:20:33 aballier Exp $
+
+inherit eutils
+
+DESCRIPTION="Motion is a video motion detector with tracking-support for webcams."
+HOMEPAGE="http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="ffmpeg mysql postgres v4l"
+
+DEPEND="sys-libs/zlib
+ media-libs/jpeg
+ ffmpeg? ( media-video/ffmpeg )
+ mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql-server )"
+
+pkg_setup() {
+ enewuser motion -1 -1 -1 "video" || die "failed to create motion user"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-offsett.patch"
+}
+
+src_compile() {
+ econf --without-optimizecpu \
+ $(use_with v4l) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_with ffmpeg)
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+
+ # Install init script.
+ newinitd "${FILESDIR}"/motion.init-r1 motion
+ newconfd "${FILESDIR}"/motion.confd motion
+
+ # Create correct dir for motion.pid
+ dodir /var/run/motion
+ fowners motion:video /var/run/motion
+ fperms 750 /var/run/motion
+ keepdir /var/run/motion
+
+ # Rename configuration file.
+ mv "${D}"/etc/motion-dist.conf "${D}"/etc/motion.conf
+
+ # Remove dummy documentation and install it using ebuild functions.
+ rm -rf "${D}"/usr/share/doc/${P}
+ dodoc CHANGELOG CODE_STANDARD CREDITS FAQ README README.FreeBSD *.conf
+ dohtml *.html
+}
+
+pkg_postinst() {
+ elog "You need to setup /etc/motion.conf before running"
+ elog "motion for the first time. You can install motion"
+ elog "detection as a service, use:"
+ elog "rc-update add motion default"
+}