summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-02-15 10:22:48 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-02-15 10:22:48 +0000
commitde390c359f42184d41f076fa65c8fa6177d9c663 (patch)
tree64a2db57a7117c1b06bb2abbede88a9723ad8d76 /media-video/noad
parentVersion bump. (diff)
downloadgentoo-2-de390c359f42184d41f076fa65c8fa6177d9c663.tar.gz
gentoo-2-de390c359f42184d41f076fa65c8fa6177d9c663.tar.bz2
gentoo-2-de390c359f42184d41f076fa65c8fa6177d9c663.zip
fix build with ffmpeg 2.5, bug #540090
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-video/noad')
-rw-r--r--media-video/noad/ChangeLog6
-rw-r--r--media-video/noad/files/patches-0.8.x/noad-0.8.6-ffmpeg25.patch16
-rw-r--r--media-video/noad/noad-0.8.6-r1.ebuild5
3 files changed, 24 insertions, 3 deletions
diff --git a/media-video/noad/ChangeLog b/media-video/noad/ChangeLog
index a565c09380ef..4146ee6309f9 100644
--- a/media-video/noad/ChangeLog
+++ b/media-video/noad/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/noad
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/noad/ChangeLog,v 1.64 2015/02/04 19:36:16 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/noad/ChangeLog,v 1.65 2015/02/15 10:22:48 aballier Exp $
+
+ 15 Feb 2015; Alexis Ballier <aballier@gentoo.org> noad-0.8.6-r1.ebuild,
+ +files/patches-0.8.x/noad-0.8.6-ffmpeg25.patch:
+ fix build with ffmpeg 2.5, bug #540090
04 Feb 2015; Joerg Bornkessel <hd_brummy@gentoo.org> noad-0.8.6-r1.ebuild:
stable amd64 x86, wrt bug 538810
diff --git a/media-video/noad/files/patches-0.8.x/noad-0.8.6-ffmpeg25.patch b/media-video/noad/files/patches-0.8.x/noad-0.8.6-ffmpeg25.patch
new file mode 100644
index 000000000000..455252a74c8a
--- /dev/null
+++ b/media-video/noad/files/patches-0.8.x/noad-0.8.6-ffmpeg25.patch
@@ -0,0 +1,16 @@
+Index: noad-0.8.6/ffmpeg_decoder.cpp
+===================================================================
+--- noad-0.8.6.orig/ffmpeg_decoder.cpp
++++ noad-0.8.6/ffmpeg_decoder.cpp
+@@ -253,7 +253,11 @@ int FFMPegDecoder::decoder_exit()
+ // close the file
+ if( pFormatCtx )
+ {
++#if LIBAVFORMAT_VERSION_MAJOR < 54
+ av_close_input_file(pFormatCtx);
++#else
++ avformat_close_input(&pFormatCtx);
++#endif
+ pFormatCtx = NULL;
+ }
+ // Close the codec
diff --git a/media-video/noad/noad-0.8.6-r1.ebuild b/media-video/noad/noad-0.8.6-r1.ebuild
index 6ffb486c5aad..a44cc01d133f 100644
--- a/media-video/noad/noad-0.8.6-r1.ebuild
+++ b/media-video/noad/noad-0.8.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/noad/noad-0.8.6-r1.ebuild,v 1.3 2015/02/04 19:36:16 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/noad/noad-0.8.6-r1.ebuild,v 1.4 2015/02/15 10:22:48 aballier Exp $
EAPI=5
inherit autotools eutils toolchain-funcs confutils
@@ -28,7 +28,8 @@ src_prepare() {
sed -i -e 's:2001:6419:' svdrpc.cpp main.cpp
# tested libav-9, ffmepg-2.2.9
- epatch "${FILESDIR}/patches-0.8.x/${P}-libav9.diff"
+ epatch "${FILESDIR}/patches-0.8.x/${P}-libav9.diff" \
+ "${FILESDIR}/patches-0.8.x/${P}-ffmpeg25.patch"
eautoreconf
}