summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-02-05 13:53:42 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-02-05 13:53:42 +0000
commit5ae523a78d927b4dc3ef075bbe9138f01fba729e (patch)
tree27ced4870fd30a1d2b3f4cb261432dc3d337f8ce /media-video/ogle/ogle-0.9.2.ebuild
parentrenamed ifo_dump binary to ifo_dump_dvdread to avoid collision with the ogle ... (diff)
downloadgentoo-2-5ae523a78d927b4dc3ef075bbe9138f01fba729e.tar.gz
gentoo-2-5ae523a78d927b4dc3ef075bbe9138f01fba729e.tar.bz2
gentoo-2-5ae523a78d927b4dc3ef075bbe9138f01fba729e.zip
renamed ifo_dump binary to ifo_dump_ogle to avoid collision with the libdvdread one. see #80837
(Portage version: 2.0.51-r15)
Diffstat (limited to 'media-video/ogle/ogle-0.9.2.ebuild')
-rw-r--r--media-video/ogle/ogle-0.9.2.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/media-video/ogle/ogle-0.9.2.ebuild b/media-video/ogle/ogle-0.9.2.ebuild
index c80f7c93cad7..44c371af1770 100644
--- a/media-video/ogle/ogle-0.9.2.ebuild
+++ b/media-video/ogle/ogle-0.9.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ogle/ogle-0.9.2.ebuild,v 1.11 2005/01/27 19:25:24 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ogle/ogle-0.9.2.ebuild,v 1.12 2005/02/05 13:53:42 luckyduck Exp $
inherit eutils libtool
@@ -57,12 +57,16 @@ src_compile() {
# configure needs access to the updated CFLAGS
CFLAGS="${CFLAGS} -I/usr/include/libxml2/libxml -I/usr/include/libxml2"
- econf ${myconf} || die
- emake CFLAGS="${CFLAGS}" || die
+ econf ${myconf} || die "./configure failed"
+ emake CFLAGS="${CFLAGS}" || die "make failed"
}
src_install() {
- einstall || die
+ einstall || die "make install failed"
+
+ cd ${D}usr/bin/
+ mv ./ifo_dump ./ifo_dump_ogle
+
dodoc AUTHORS COPYING ChangeLog HISTORY INSTALL NEWS README TODO
dodoc doc/liba52.txt
}