summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-26 11:52:42 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-26 11:52:42 +0000
commitb26bfe19d65f2441ee4d9552e0cc52cd103c0847 (patch)
tree8a49e5f34c76414c2b7a9804b860d74443dbfb74 /media-video/parole
parentUse xfconf_use_debug instead of use_enable to control debug flags wrt #302835... (diff)
downloadgentoo-2-b26bfe19d65f2441ee4d9552e0cc52cd103c0847.tar.gz
gentoo-2-b26bfe19d65f2441ee4d9552e0cc52cd103c0847.tar.bz2
gentoo-2-b26bfe19d65f2441ee4d9552e0cc52cd103c0847.zip
Fix building with -Werror wrt #302835 by Jesús Guerrero.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-video/parole')
-rw-r--r--media-video/parole/ChangeLog6
-rw-r--r--media-video/parole/files/parole-0.2.0.2-64bit.patch22
-rw-r--r--media-video/parole/parole-0.2.0.2.ebuild3
3 files changed, 29 insertions, 2 deletions
diff --git a/media-video/parole/ChangeLog b/media-video/parole/ChangeLog
index 98c5a927bc9a..a3fff58a3a14 100644
--- a/media-video/parole/ChangeLog
+++ b/media-video/parole/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/parole
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/parole/ChangeLog,v 1.9 2010/03/26 11:44:05 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/parole/ChangeLog,v 1.10 2010/03/26 11:52:42 ssuominen Exp $
+
+ 26 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> parole-0.2.0.2.ebuild,
+ +files/parole-0.2.0.2-64bit.patch:
+ Fix building with -Werror wrt #302835 by Jesús Guerrero.
26 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> parole-0.2.0.2.ebuild:
Use xfconf_use_debug instead of use_enable to control debug flags wrt
diff --git a/media-video/parole/files/parole-0.2.0.2-64bit.patch b/media-video/parole/files/parole-0.2.0.2-64bit.patch
new file mode 100644
index 000000000000..0e87aa653745
--- /dev/null
+++ b/media-video/parole/files/parole-0.2.0.2-64bit.patch
@@ -0,0 +1,22 @@
+diff --git a/gst/parole-gst.c b/gst/parole-gst.c
+index 2a51a35..6676675 100644
+--- a/gst/parole-gst.c
++++ b/gst/parole-gst.c
+@@ -655,7 +655,7 @@ parole_gst_query_duration (ParoleGst *gst)
+ duration = absolute_duration / GST_SECOND;
+ live = ( absolute_duration == 0 );
+
+- TRACE ("Duration %lld is_live=%d", duration, live);
++ TRACE ("Duration %" G_GINT64_FORMAT "is_live=%d", duration, live);
+
+ g_object_set (G_OBJECT (gst->priv->stream),
+ "absolute-duration", absolute_duration,
+@@ -2169,7 +2169,7 @@ gint parole_gst_get_current_cdda_track (ParoleGst *gst)
+
+ if ( gst_element_query_position (gst->priv->playbin, &format, &pos) )
+ {
+- TRACE ("Pos %lld", pos);
++ TRACE ("Pos %" G_GINT64_FORMAT, pos);
+ ret_val = (gint) pos;
+ }
+
diff --git a/media-video/parole/parole-0.2.0.2.ebuild b/media-video/parole/parole-0.2.0.2.ebuild
index e018999de5e2..5ed0d0dd958b 100644
--- a/media-video/parole/parole-0.2.0.2.ebuild
+++ b/media-video/parole/parole-0.2.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/parole/parole-0.2.0.2.ebuild,v 1.2 2010/03/26 11:44:05 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/parole/parole-0.2.0.2.ebuild,v 1.3 2010/03/26 11:52:42 ssuominen Exp $
EAPI=2
inherit xfconf
@@ -37,4 +37,5 @@ pkg_setup() {
$(use_enable nsplugin browser-plugin)
$(xfconf_use_debug)"
DOCS="AUTHORS ChangeLog README THANKS TODO"
+ PATCHES=( "${FILESDIR}/${P}-64bit.patch" )
}