summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-12-14 22:58:55 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-12-14 22:58:55 +0000
commit5ee3ff2fc45f07e6b494616e3a8eeceeaa4ee9cc (patch)
treeb4bc2d8fe5768997295f1030077cd10b67a670ed /media-video/pitivi/pitivi-0.11.3.ebuild
parentBuild fix for gtk+-2.14. (diff)
downloadgentoo-2-5ee3ff2fc45f07e6b494616e3a8eeceeaa4ee9cc.tar.gz
gentoo-2-5ee3ff2fc45f07e6b494616e3a8eeceeaa4ee9cc.tar.bz2
gentoo-2-5ee3ff2fc45f07e6b494616e3a8eeceeaa4ee9cc.zip
Bump to 0.11.3
(Portage version: 2.2_rc17/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'media-video/pitivi/pitivi-0.11.3.ebuild')
-rw-r--r--media-video/pitivi/pitivi-0.11.3.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/media-video/pitivi/pitivi-0.11.3.ebuild b/media-video/pitivi/pitivi-0.11.3.ebuild
new file mode 100644
index 000000000000..1dc62f5d74c2
--- /dev/null
+++ b/media-video/pitivi/pitivi-0.11.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/pitivi/pitivi-0.11.3.ebuild,v 1.1 2008/12/14 22:58:55 eva Exp $
+
+inherit gnome2 python
+
+DESCRIPTION="A non-linear video editor using the GStreamer multimedia framework"
+HOMEPAGE="http://www.pitivi.org"
+SRC_URI="mirror://gnome/sources/${PN}/0.11/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/gstreamer-0.10.4
+ >=dev-lang/python-2.5
+ >=dev-python/pygtk-2.8.0
+ >=dev-python/gnome-python-2.12.0
+ >=dev-python/gst-python-0.10.0
+ >=media-libs/gnonlin-0.10.10
+ >=media-libs/gst-plugins-base-0.10.0
+ >=media-libs/gst-plugins-good-0.10.0
+ >=media-plugins/gst-plugins-ffmpeg-0.10.0
+ >=media-plugins/gst-plugins-xvideo-0.10.0
+ >=media-plugins/gst-plugins-libpng-0.10.0
+ net-zope/zopeinterface
+ dev-python/pygoocanvas"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.5"
+
+DOCS="AUTHORS ChangeLog NEWS RELEASE"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+src_compile() {
+ addpredict $(unset HOME; echo ~)/.gconf
+ addpredict $(unset HOME; echo ~)/.gconfd
+ addpredict $(unset HOME; echo ~)/.gstreamer-0.10
+ gnome2_src_compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize "/usr/$(get_libdir)/${PN}/python/${PN}"
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup "/usr/$(get_libdir)/${PN}/python/${PN}"
+}