summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2007-02-10 23:45:51 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2007-02-10 23:45:51 +0000
commit588b15dc46591ed7590a6bb46d047ad74e1834d1 (patch)
treee3c2179a9c2e0b948144abb226b90a43101f7ee0 /media-video/qdvdauthor
parentDie if skins are wanted but not wxwindows, dont install vlc.desktop if not us... (diff)
downloadgentoo-2-588b15dc46591ed7590a6bb46d047ad74e1834d1.tar.gz
gentoo-2-588b15dc46591ed7590a6bb46d047ad74e1834d1.tar.bz2
gentoo-2-588b15dc46591ed7590a6bb46d047ad74e1834d1.zip
ebuild cleanup, adding videotrans dependency (bug #154694), fixed install errors with non-standard PORTAGE_TMPDIR (bug #118697).
(Portage version: 2.1.2-r2)
Diffstat (limited to 'media-video/qdvdauthor')
-rw-r--r--media-video/qdvdauthor/ChangeLog9
-rw-r--r--media-video/qdvdauthor/files/digest-qdvdauthor-0.1.4-r13
-rw-r--r--media-video/qdvdauthor/qdvdauthor-0.1.4-r1.ebuild86
3 files changed, 97 insertions, 1 deletions
diff --git a/media-video/qdvdauthor/ChangeLog b/media-video/qdvdauthor/ChangeLog
index 08187d06d8ef..71fef61ec434 100644
--- a/media-video/qdvdauthor/ChangeLog
+++ b/media-video/qdvdauthor/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/qdvdauthor
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/ChangeLog,v 1.13 2007/01/06 21:31:47 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/ChangeLog,v 1.14 2007/02/10 23:45:51 sbriesen Exp $
+
+*qdvdauthor-0.1.4-r1 (10 Feb 2007)
+
+ 10 Feb 2007; Stefan Briesenick <sbriesen@gentoo.org>
+ +qdvdauthor-0.1.4-r1.ebuild:
+ ebuild cleanup, adding videotrans dependency (bug #154694), fixed install
+ errors with non-standard PORTAGE_TMPDIR (bug #118697).
*qdvdauthor-0.1.4 (06 Jan 2007)
diff --git a/media-video/qdvdauthor/files/digest-qdvdauthor-0.1.4-r1 b/media-video/qdvdauthor/files/digest-qdvdauthor-0.1.4-r1
new file mode 100644
index 000000000000..84b984be6e89
--- /dev/null
+++ b/media-video/qdvdauthor/files/digest-qdvdauthor-0.1.4-r1
@@ -0,0 +1,3 @@
+MD5 7f81f2f915a1a5709a584b839a750110 qdvdauthor-0.1.4.tar.gz 3405853
+RMD160 e38f21602abfc2aec09c782e376c6514be11d93a qdvdauthor-0.1.4.tar.gz 3405853
+SHA256 1ec3a9d2b609f5ee5da643b86beeb209bde43b2a03cb92fd7c6f660d941b4b54 qdvdauthor-0.1.4.tar.gz 3405853
diff --git a/media-video/qdvdauthor/qdvdauthor-0.1.4-r1.ebuild b/media-video/qdvdauthor/qdvdauthor-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..91be83d20403
--- /dev/null
+++ b/media-video/qdvdauthor/qdvdauthor-0.1.4-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/qdvdauthor-0.1.4-r1.ebuild,v 1.1 2007/02/10 23:45:51 sbriesen Exp $
+
+inherit eutils flag-o-matic qt3
+
+DESCRIPTION="'Q' DVD-Author is a GUI frontend for dvdauthor written in Qt"
+HOMEPAGE="http://qdvdauthor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qdvdauthor/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="xine mplayer"
+
+DEPEND=">=media-video/dvdauthor-0.6.11
+ >=media-gfx/imagemagick-6.1.8.8
+ >=media-video/mjpegtools-1.6.2
+ >=media-video/dvd-slideshow-0.7.2
+ xine? ( >=media-libs/xine-lib-1.1.0 )
+ mplayer? ( media-video/mplayer )
+ !xine? ( !mplayer? ( >=media-libs/xine-lib-1.1.0 ) )
+ $(qt_min_version 3.2)"
+
+RDEPEND="${DEPEND}
+ media-libs/netpbm
+ media-video/videotrans
+ media-sound/toolame
+ media-sound/lame
+ media-sound/sox"
+
+# TODO:
+# media-video/dvd-slideshow -> optional
+# installing further tools -> needs evaluation
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # do not over-optimize (see bug #147250)
+ replace-flags -O? -O2
+ filter-flags -finline-functions
+
+ # set our C(XX)FLAGS
+ for PRO in */*.pro */*/*.pro; do
+ echo "QMAKE_CFLAGS_RELEASE = ${CFLAGS}" >> "${PRO}"
+ echo "QMAKE_CXXFLAGS_RELEASE = ${CXXFLAGS}" >> "${PRO}"
+ done
+
+ # full-qualify qmake in configure and append -nocache (see bug #118697)
+ sed -i -e "s:make;:make ${MAKEOPTS};:g" \
+ -e "s:qmake:\${QTDIR}/bin/qmake -nocache QMAKE=\${QTDIR}/bin/qmake:g" configure
+
+ # fixing defaults from /usr/local/bin to gentoo default /usr/bin
+ sed -i "s:/usr/local/bin:/usr/bin:g" qdvdauthor/qdvdauthor.cpp \
+ qdvdauthor/dialog*.cpp qdvdauthor/qslideshow/dialog*.cpp doc/sound.txt
+}
+
+src_compile() {
+ local myconf="--prefix=/usr --build-qplayer --build-qslideshow"
+
+ # select backend (VLC is currently broken)
+ #use vlc && myconf="${myconf} --with-vlc-support"
+ use xine && myconf="${myconf} --with-xine-support"
+ use mplayer && myconf="${myconf} --with-mplayer-support"
+
+ # if no backend selected, use XINE as default
+ if ! use xine && ! use mplayer; then
+ myconf="${myconf} --with-xine-support"
+ fi
+
+ ./configure ${myconf} || die "configure failed"
+}
+
+src_install() {
+ make -C qdvdauthor INSTALL_ROOT="${D}" install || die "qdvdauthor install failed"
+ make -C qdvdauthor/qslideshow INSTALL_ROOT="${D}" install || die "qslideshow install failed"
+ make -C qdvdauthor/qplayer INSTALL_ROOT="${D}" install || die "qplayer install failed"
+
+ dobin bin/{qdvdauthor,qslideshow,qplayer}
+ dodoc CHANGELOG README TODO doc/{ISO_639,lookinto,render*,sound*,todo*}.txt
+ dohtml doc/html/en/*
+
+ domenu qdvdauthor.desktop
+ doicon qdvdauthor.png
+}