summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-06-17 16:05:48 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-06-17 16:05:48 +0000
commita46dc8e37c7f6c62afccc23c52e30510f37a5518 (patch)
tree6edfda92e7c65c4ece1480e265b73bad408bfbe3 /media-video/rtmpdump
parentVersion bump with some minor bugfixes, remove old testing. (diff)
downloadgentoo-2-a46dc8e37c7f6c62afccc23c52e30510f37a5518.tar.gz
gentoo-2-a46dc8e37c7f6c62afccc23c52e30510f37a5518.tar.bz2
gentoo-2-a46dc8e37c7f6c62afccc23c52e30510f37a5518.zip
Define CRYPTO on src_install. Fixes bug #324469
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'media-video/rtmpdump')
-rw-r--r--media-video/rtmpdump/ChangeLog8
-rw-r--r--media-video/rtmpdump/rtmpdump-2.2e-r2.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/media-video/rtmpdump/ChangeLog b/media-video/rtmpdump/ChangeLog
index c83c9fe042cb..dcd362bd7138 100644
--- a/media-video/rtmpdump/ChangeLog
+++ b/media-video/rtmpdump/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/rtmpdump
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/ChangeLog,v 1.4 2010/06/06 23:09:20 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/ChangeLog,v 1.5 2010/06/17 16:05:48 hwoarang Exp $
+
+*rtmpdump-2.2e-r2 (17 Jun 2010)
+
+ 17 Jun 2010; Markos Chandras <hwoarang@gentoo.org>
+ +rtmpdump-2.2e-r2.ebuild:
+ Define CRYPTO on src_install. Fixes bug #324469
06 Jun 2010; Luca Barbato <lu_zero@gentoo.org> rtmpdump-2.2e-r1.ebuild:
Make librtmp pic
diff --git a/media-video/rtmpdump/rtmpdump-2.2e-r2.ebuild b/media-video/rtmpdump/rtmpdump-2.2e-r2.ebuild
new file mode 100644
index 000000000000..106bbaf4f038
--- /dev/null
+++ b/media-video/rtmpdump/rtmpdump-2.2e-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/rtmpdump-2.2e-r2.ebuild,v 1.1 2010/06/17 16:05:48 hwoarang Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Open source command-line RTMP client intended to stream audio or video flash content"
+HOMEPAGE="http://rtmpdump.mplayerhq.hu/"
+SRC_URI="http://rtmpdump.mplayerhq.hu/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnutls polarssl ssl"
+
+DEPEND="ssl? (
+ gnutls? ( net-libs/gnutls )
+ polarssl? ( !gnutls? ( net-libs/polarssl ) )
+ !gnutls? ( !polarssl? ( dev-libs/openssl ) )
+ )
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! use ssl && ( use gnutls || use polarssl ) ; then
+ ewarn "USE='gnutls polarssl' are ignored without USE='ssl'."
+ ewarn "Please review the local USE flags for this package."
+ fi
+}
+
+src_prepare() {
+ # fix Makefile ( bug #298535 and bug #318353 )
+ sed -i 's/\$(MAKEFLAGS)//g' Makefile \
+ || die "failed to fix Makefile"
+ sed -i 's:OPT=:&-fPIC :' librtmp/Makefile \
+ || die "failed to fix Makefile"
+}
+
+src_compile() {
+ if use ssl ; then
+ if use gnutls ; then
+ crypto="GNUTLS"
+ elif use polarssl ; then
+ crypto="POLARSSL"
+ else
+ crypto="OPENSSL"
+ fi
+ fi
+
+ emake CC=$(tc-getCC) LD=$(tc-getLD) \
+ OPT="${CFLAGS}" XLDFLAGS="${LDFLAGS}" CRYPTO="${crypto}" SYS=posix || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${DESTTREE}" mandir="${DESTTREE}/share/man" \
+ CRYPTO="${crypto}" install || die "emake install failed"
+ dodoc README ChangeLog rtmpdump.1.html rtmpgw.8.html || die "dodoc failed"
+}