summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-19 11:28:21 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-19 11:28:21 +0000
commitcfb58c1e688facc8407391b2325d6ba060ef6100 (patch)
treed8ddacde3c8889d8f1f7d5622bd41895ea63ca7a /media-video/smpeg-xmms
parentadded NVIDIA license (diff)
downloadgentoo-2-cfb58c1e688facc8407391b2325d6ba060ef6100.tar.gz
gentoo-2-cfb58c1e688facc8407391b2325d6ba060ef6100.tar.bz2
gentoo-2-cfb58c1e688facc8407391b2325d6ba060ef6100.zip
repoman'd
Diffstat (limited to 'media-video/smpeg-xmms')
-rw-r--r--media-video/smpeg-xmms/smpeg-xmms-0.3.4-r1.ebuild30
1 files changed, 14 insertions, 16 deletions
diff --git a/media-video/smpeg-xmms/smpeg-xmms-0.3.4-r1.ebuild b/media-video/smpeg-xmms/smpeg-xmms-0.3.4-r1.ebuild
index b3d9d0155fe4..e3bc217f5d24 100644
--- a/media-video/smpeg-xmms/smpeg-xmms-0.3.4-r1.ebuild
+++ b/media-video/smpeg-xmms/smpeg-xmms-0.3.4-r1.ebuild
@@ -1,36 +1,34 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-video/smpeg-xmms/smpeg-xmms-0.3.4-r1.ebuild,v 1.2 2002/07/11 06:30:42 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/smpeg-xmms/smpeg-xmms-0.3.4-r1.ebuild,v 1.3 2002/07/19 11:28:21 seemant Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="A MPEG Plugin for XMMS"
-SRC_URI="ftp://ftp.xmms.org/xmms/plugins/smpeg-xmms/${A}"
+SRC_URI="ftp://ftp.xmms.org/xmms/plugins/smpeg-xmms/${P}.tar.gz"
HOMEPAGE="http://www.xmms.org/plugins_input.html"
DEPEND=">=media-sound/xmms-1.2.3
>=media-libs/smpeg-0.4.4-r1
sdl? ( >=media-libs/libsdl-1.2.2 )"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
src_compile() {
- cd ${S}
- local myopts
- if [ -z "`use sdl`" ];then
- myopts="${myopts} --disable-sdltest"
- fi
+ cd ${S}
+ local myconf
+ use sdl || myconf="${myconf} --disable-sdltest"
- try ./configure ${myopts} --prefix=/usr --host=${CHOST}
- try make
+ econf ${myconf} || die
+ make || die
}
src_install () {
- cd ${S}
- try make DESTDIR=${D} install
- dodoc AUTHORS COPYING README TODO ChangeLog
+ cd ${S}
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING README TODO ChangeLog
}
-
-
-