summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2004-07-23 15:27:54 +0000
committerMichael Imhof <tantive@gentoo.org>2004-07-23 15:27:54 +0000
commitea2a360744b4668d2f2cfe140591a152d39e7707 (patch)
treef0809ffffff6c15ff3a53dd3e75e869f97b2c299 /media-video/streamdvd/streamdvd-0.4-r1.ebuild
parentnew beta (Manifest recommit) (diff)
downloadgentoo-2-ea2a360744b4668d2f2cfe140591a152d39e7707.tar.gz
gentoo-2-ea2a360744b4668d2f2cfe140591a152d39e7707.tar.bz2
gentoo-2-ea2a360744b4668d2f2cfe140591a152d39e7707.zip
Version bumped. Closes #52452, #47807.
Diffstat (limited to 'media-video/streamdvd/streamdvd-0.4-r1.ebuild')
-rw-r--r--media-video/streamdvd/streamdvd-0.4-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-video/streamdvd/streamdvd-0.4-r1.ebuild b/media-video/streamdvd/streamdvd-0.4-r1.ebuild
new file mode 100644
index 000000000000..8d339b83a8ff
--- /dev/null
+++ b/media-video/streamdvd/streamdvd-0.4-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/streamdvd/streamdvd-0.4-r1.ebuild,v 1.1 2004/07/23 15:27:54 tantive Exp $
+
+DESCRIPTION="fast tool to backup Video DVDs 'on the fly'"
+HOMEPAGE="http://www.badabum.de/streamdvd.html"
+SRC_URI="http://www.badabum.de/down/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="gui"
+
+DEPEND="media-libs/libdvdread
+ gui? ( dev-perl/perl-tk
+ app-cdr/cdrtools
+ >=media-video/dvdauthor-0.6.5
+ >=app-cdr/dvd+rw-tools-5.13.4.7.4 )"
+
+S="${WORKDIR}/StreamDVD-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} || die
+ sed -i "s: -g -Wall : ${CFLAGS} :" Makefile
+ use gui && epatch "${FILESDIR}/${P}.patch"
+}
+
+src_compile() {
+ emake all addon || die # compile also optional packages
+}
+
+src_install() {
+ dobin streamdvd streamanalyze
+ newbin lsdvd lsdvd-streamdvd # patched lsdvd, rename to avoid conflict with media-video/lsdvd
+ dodoc COPYING README
+ newdoc contrib/lsdvd/AUTHORS AUTHORS.lsdvd
+ newdoc contrib/lsdvd/README README.lsdvd
+ newdoc contrib/StreamAnalyze/README README.streamanalyze
+ if [ `use gui` ]
+ then
+ eval `perl '-V:installvendorlib'`
+ insinto "$installvendorlib/StreamDVD"
+ doins Gui/StreamDVD/*.pm
+ dobin Gui/StreamDVD.pl
+ dosym StreamDVD.pl /usr/bin/streamdvd_gui # convinience symlink
+ newdoc Gui/README README.gui
+ fi
+}
+