summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-03-28 00:01:53 +0000
committerChris White <chriswhite@gentoo.org>2005-03-28 00:01:53 +0000
commitb1e8698c733b6c44b8e606e26f47f2dcae14c08a (patch)
tree7ecdb136f07336a1114c9dbc1f95617626439807 /media-video/vstrip
parentadded ~amd64 to KEYWORDS wrt #86882 (diff)
downloadgentoo-2-b1e8698c733b6c44b8e606e26f47f2dcae14c08a.tar.gz
gentoo-2-b1e8698c733b6c44b8e606e26f47f2dcae14c08a.tar.bz2
gentoo-2-b1e8698c733b6c44b8e606e26f47f2dcae14c08a.zip
Initial import into the tree. Closes bug #31519. Thanks to swegner for the ebuild!
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-video/vstrip')
-rw-r--r--media-video/vstrip/ChangeLog11
-rw-r--r--media-video/vstrip/Manifest3
-rw-r--r--media-video/vstrip/files/digest-vstrip-0.8f1
-rw-r--r--media-video/vstrip/files/vstrip-0.8f-gentoo.patch63
-rw-r--r--media-video/vstrip/metadata.xml12
-rw-r--r--media-video/vstrip/vstrip-0.8f.ebuild36
6 files changed, 126 insertions, 0 deletions
diff --git a/media-video/vstrip/ChangeLog b/media-video/vstrip/ChangeLog
new file mode 100644
index 000000000000..fa569d645842
--- /dev/null
+++ b/media-video/vstrip/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-video/vstrip
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/vstrip/ChangeLog,v 1.1 2005/03/28 00:01:53 chriswhite Exp $
+
+*vstrip-0.8f (28 Mar 2005)
+
+ 28 Mar 2005; Chris White <chriswhite@gentoo.org> +metadata.xml,
+ +files/vstrip-0.8f-gentoo.patch, +vstrip-0.8f.ebuild:
+ Initial import into the tree. Closes bug #31519. Thanks to swegner for the
+ ebuild!
+
diff --git a/media-video/vstrip/Manifest b/media-video/vstrip/Manifest
new file mode 100644
index 000000000000..78fb200f4a61
--- /dev/null
+++ b/media-video/vstrip/Manifest
@@ -0,0 +1,3 @@
+MD5 346564a9abe421cffeac776de0a50d21 vstrip-0.8f.ebuild 681
+MD5 e678826f20d61477c6f3387201a5668f files/vstrip-0.8f-gentoo.patch 2023
+MD5 1f3d4d7b3589e5de8e4bb357eb9a0f63 files/digest-vstrip-0.8f 59
diff --git a/media-video/vstrip/files/digest-vstrip-0.8f b/media-video/vstrip/files/digest-vstrip-0.8f
new file mode 100644
index 000000000000..efd53a2d0987
--- /dev/null
+++ b/media-video/vstrip/files/digest-vstrip-0.8f
@@ -0,0 +1 @@
+MD5 7bb1fd2cca6517d4d51e30456a58448d vStrip_08f.zip 409157
diff --git a/media-video/vstrip/files/vstrip-0.8f-gentoo.patch b/media-video/vstrip/files/vstrip-0.8f-gentoo.patch
new file mode 100644
index 000000000000..e6551b9dc1e3
--- /dev/null
+++ b/media-video/vstrip/files/vstrip-0.8f-gentoo.patch
@@ -0,0 +1,63 @@
+--- Makefile
++++ Makefile 2003-10-12 02:25:31.000000000 +0000
+@@ -4,7 +4,7 @@
+
+ ### Sources
+
+-SOURCE_FILES=file_io.h file_io.c in_buffer.h in_buffer.c parse_ifo.h parse_ifo.c s_types.h main.c vstrip.h vstrip.c
++SOURCE_FILES=file_io.h file_io.c in_buffer.h in_buffer.c parse_ifo.h parse_ifo.c s_types.h main.c vstrip.h vstrip.c dvd2avi_plugin.c
+
+ ### Objects and executables
+
+@@ -27,8 +27,8 @@
+
+ ### Details
+
+-vstrip : file_io.o in_buffer.o main.o parse_ifo.o vstrip.o
+- $(CC) -g file_io.o in_buffer.o main.o parse_ifo.o vstrip.o -o vstrip
++vstrip : file_io.o in_buffer.o main.o parse_ifo.o vstrip.o dvd2avi_plugin.o
++ $(CC) -g -lm file_io.o in_buffer.o main.o parse_ifo.o vstrip.o dvd2avi_plugin.o -o vstrip
+ file_io.o : s_types.h file_io.h file_io.c
+ in_buffer.o : s_types.h file_io.h in_buffer.h in_buffer.c
+ main.o : s_types.h file_io.h vstrip.h main.c
+--- dvd2avi_plugin.c
++++ dvd2avi_plugin.c 2003-10-12 02:29:23.000000000 +0000
+@@ -6,13 +6,17 @@
+
+ *************************************************************************/
+
++#include <string.h>
++#include <stdlib.h>
+ #include <stdio.h>
+-#include <io.h>
++#include <asm/io.h>
+ #include <fcntl.h>
+ #include "s_types.h"
+ #include "vstrip.h"
+ #include "dvd2avi_plugin.h"
+
++#define max(a,b) a < b ? b : a
++
+ bool dvd2avi_process(byte *data, tp_vs_streaminfo const si, void *user_data)
+ {
+ t_dvd2avi* d2v = (t_dvd2avi *)user_data;
+@@ -206,7 +210,7 @@
+ fp = _open(fname, _O_BINARY | _O_RDONLY); // check size
+ if (fp != -1)
+ {
+- __int64 fposition = _filelengthi64(fp);
++ __int64_t fposition = lseek64(fp, 0, SEEK_END);
+
+ lba = (dword)(fposition / fio_SECTOR_SIZE);
+ _close(fp);
+--- file_io.c
++++ file_io.c 2003-10-12 02:24:46.000000000 +0000
+@@ -32,7 +32,7 @@
+ fp = _open(name, _O_BINARY | _O_RDONLY); // check size
+ if (fp != -1)
+ {
+- __int64 fposition = _filelengthi64(fp);
++ __int64_t fposition = lseek64(fp, 0, SEEK_END);
+
+ f->written_to = fposition > 0;
+ if (fposition > 0)
diff --git a/media-video/vstrip/metadata.xml b/media-video/vstrip/metadata.xml
new file mode 100644
index 000000000000..58cae4f48bf3
--- /dev/null
+++ b/media-video/vstrip/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>video</herd>
+<maintainer>
+ <email>media-video@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+A program to divide a non encrypted vob by individiual chapters
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-video/vstrip/vstrip-0.8f.ebuild b/media-video/vstrip/vstrip-0.8f.ebuild
new file mode 100644
index 000000000000..ef210d82076e
--- /dev/null
+++ b/media-video/vstrip/vstrip-0.8f.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/vstrip/vstrip-0.8f.ebuild,v 1.1 2005/03/28 00:01:53 chriswhite Exp $
+
+inherit eutils
+
+DESCRIPTION="A program to split non-css dvd vobs into individual chapters"
+HOMEPAGE="http://www.maven.de/code"
+SRC_URI="http://files.digital-digest.com/downloads/files/encode/vStrip_${PV/./}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="app-text/dos2unix"
+RDEPEND="virtual/libc"
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/vstrip-0.8f-gentoo.patch
+ dos2unix -q -o *.c *.h
+
+ for file in *.c *.h ; do
+ echo >>$file
+ done
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dobin vstrip
+}