summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-06-06 10:37:56 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-06-06 10:37:56 +0000
commitc640e418d71c4732fe99e6fe9b75a78b8135dbbd (patch)
tree803610586f1a090122dd0afd1a3fd639b0e9efe0 /media-video/x264-encoder
parentbump a new snapshot (diff)
downloadgentoo-2-c640e418d71c4732fe99e6fe9b75a78b8135dbbd.tar.gz
gentoo-2-c640e418d71c4732fe99e6fe9b75a78b8135dbbd.tar.bz2
gentoo-2-c640e418d71c4732fe99e6fe9b75a78b8135dbbd.zip
bump a new snapshot
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-video/x264-encoder')
-rw-r--r--media-video/x264-encoder/ChangeLog9
-rw-r--r--media-video/x264-encoder/files/x264-encoder-nolib-20100605.patch37
-rw-r--r--media-video/x264-encoder/x264-encoder-0.0.20100605.ebuild59
3 files changed, 104 insertions, 1 deletions
diff --git a/media-video/x264-encoder/ChangeLog b/media-video/x264-encoder/ChangeLog
index fe84b0db1aba..fa54af4a0174 100644
--- a/media-video/x264-encoder/ChangeLog
+++ b/media-video/x264-encoder/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/x264-encoder
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/x264-encoder/ChangeLog,v 1.34 2010/04/24 15:47:25 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/x264-encoder/ChangeLog,v 1.35 2010/06/06 10:37:56 aballier Exp $
+
+*x264-encoder-0.0.20100605 (06 Jun 2010)
+
+ 06 Jun 2010; Alexis Ballier <aballier@gentoo.org>
+ +x264-encoder-0.0.20100605.ebuild,
+ +files/x264-encoder-nolib-20100605.patch:
+ bump a new snapshot
*x264-encoder-0.0.20100423 (24 Apr 2010)
diff --git a/media-video/x264-encoder/files/x264-encoder-nolib-20100605.patch b/media-video/x264-encoder/files/x264-encoder-nolib-20100605.patch
new file mode 100644
index 000000000000..eb7631ac526a
--- /dev/null
+++ b/media-video/x264-encoder/files/x264-encoder-nolib-20100605.patch
@@ -0,0 +1,37 @@
+Index: x264-snapshot-20100605-2245/Makefile
+===================================================================
+--- x264-snapshot-20100605-2245.orig/Makefile
++++ x264-snapshot-20100605-2245/Makefile
+@@ -127,8 +127,8 @@ libx264.a: .depend $(OBJS) $(OBJASM)
+ $(SONAME): .depend $(OBJS) $(OBJASM) $(OBJSO)
+ $(CC) -shared -o $@ $(OBJS) $(OBJASM) $(OBJSO) $(SOFLAGS) $(LDFLAGS)
+
+-x264$(EXE): $(OBJCLI) libx264.a
+- $(CC) -o $@ $+ $(LDFLAGS) $(LDFLAGSCLI)
++x264$(EXE): $(OBJCLI)
++ $(CC) -o $@ $+ $(LDFLAGS) $(LDFLAGSCLI) `pkg-config --libs x264`
+
+ checkasm: tools/checkasm.o libx264.a
+ $(CC) -o $@ $+ $(LDFLAGS)
+@@ -195,21 +195,7 @@ distclean: clean
+
+ install: x264$(EXE) $(SONAME)
+ install -d $(DESTDIR)$(bindir)
+- install -d $(DESTDIR)$(includedir)
+- install -d $(DESTDIR)$(libdir)
+- install -d $(DESTDIR)$(libdir)/pkgconfig
+- install -m 644 x264.h $(DESTDIR)$(includedir)
+- install -m 644 libx264.a $(DESTDIR)$(libdir)
+- install -m 644 x264.pc $(DESTDIR)$(libdir)/pkgconfig
+ install x264$(EXE) $(DESTDIR)$(bindir)
+- $(RANLIB) $(DESTDIR)$(libdir)/libx264.a
+-ifeq ($(SYS),MINGW)
+- $(if $(SONAME), install -m 755 $(SONAME) $(DESTDIR)$(bindir))
+-else
+- $(if $(SONAME), ln -f -s $(SONAME) $(DESTDIR)$(libdir)/libx264.$(SOSUFFIX))
+- $(if $(SONAME), install -m 755 $(SONAME) $(DESTDIR)$(libdir))
+-endif
+- $(if $(IMPLIBNAME), install -m 644 $(IMPLIBNAME) $(DESTDIR)$(libdir))
+
+ uninstall:
+ rm -f $(DESTDIR)$(includedir)/x264.h $(DESTDIR)$(libdir)/libx264.a
diff --git a/media-video/x264-encoder/x264-encoder-0.0.20100605.ebuild b/media-video/x264-encoder/x264-encoder-0.0.20100605.ebuild
new file mode 100644
index 000000000000..19b36acd0276
--- /dev/null
+++ b/media-video/x264-encoder/x264-encoder-0.0.20100605.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/x264-encoder/x264-encoder-0.0.20100605.ebuild,v 1.1 2010/06/06 10:37:56 aballier Exp $
+
+EAPI=2
+inherit eutils multilib toolchain-funcs versionator
+
+MY_P=x264-snapshot-$(get_version_component_range 3)-2245
+
+DESCRIPTION="A free commandline encoder for X264/AVC streams"
+HOMEPAGE="http://www.videolan.org/developers/x264.html"
+SRC_URI="ftp://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug ffmpeg +mp4 +threads"
+
+RDEPEND="mp4? ( >=media-video/gpac-0.4.1_pre20060122 )
+ ~media-libs/x264-${PV}
+ ffmpeg? ( media-video/ffmpeg )"
+DEPEND="${RDEPEND}
+ amd64? ( >=dev-lang/yasm-0.6.2 )
+ x86? ( || ( >=dev-lang/yasm-0.6.2 dev-lang/nasm )
+ !<dev-lang/yasm-0.6.2 )
+ x86-fbsd? ( >=dev-lang/yasm-0.6.2 )
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-nostrip.patch \
+ "${FILESDIR}"/${PN}-nolib-20100605.patch
+}
+
+src_configure() {
+ tc-export CC
+
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debug"
+
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --disable-avs-input \
+ $(use_enable ffmpeg lavf-input) \
+ $(use_enable mp4 mp4-output) \
+ $(use_enable threads pthread) \
+ --extra-asflags="${ASFLAGS}" \
+ --extra-cflags="${CFLAGS}" \
+ --extra-ldflags="${LDFLAGS}" \
+ --host="${CHOST}" \
+ ${myconf} \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}