summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-07-13 09:10:54 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-07-13 09:10:54 +0000
commit0c45a33fcf07e1eb36fb3a43300a7f1f28e85eff (patch)
tree677b44fb312ef51194fe9bc9001dd7064216e913 /media-video
parentBackport a patch to fix build of the XCB module on FreeBSD. (diff)
downloadgentoo-2-0c45a33fcf07e1eb36fb3a43300a7f1f28e85eff.tar.gz
gentoo-2-0c45a33fcf07e1eb36fb3a43300a7f1f28e85eff.tar.bz2
gentoo-2-0c45a33fcf07e1eb36fb3a43300a7f1f28e85eff.zip
add projectm useflag
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/vlc/ChangeLog6
-rw-r--r--media-video/vlc/metadata.xml1
-rw-r--r--media-video/vlc/vlc-9999.ebuild12
3 files changed, 13 insertions, 6 deletions
diff --git a/media-video/vlc/ChangeLog b/media-video/vlc/ChangeLog
index ef1642e7cb14..e68ea3f7ca64 100644
--- a/media-video/vlc/ChangeLog
+++ b/media-video/vlc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/vlc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.467 2009/07/13 09:05:29 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.468 2009/07/13 09:10:54 aballier Exp $
+
+ 13 Jul 2009; Alexis Ballier <aballier@gentoo.org> vlc-9999.ebuild,
+ metadata.xml:
+ add projectm useflag
13 Jul 2009; Alexis Ballier <aballier@gentoo.org> vlc-1.0.0.ebuild:
Backport a patch to fix build of the XCB module on FreeBSD.
diff --git a/media-video/vlc/metadata.xml b/media-video/vlc/metadata.xml
index b1dbf623ff72..027e5be40bec 100644
--- a/media-video/vlc/metadata.xml
+++ b/media-video/vlc/metadata.xml
@@ -29,6 +29,7 @@
<flag name="live">Enables LIVE.com support.</flag>
<flag name="optimisememory">Enable optimisation for memory rather than performance.</flag>
<flag name="pda">Builds a GTK+ interface suitable for PDA devices.</flag>
+ <flag name="projectm">Enables the projectM visualization plugin.</flag>
<flag name="pvr">Enables PVR cards access module.</flag>
<flag name="qt4" restrict="&gt;=media-video/vlc-0.9">Builds a <pkg>x11-libs/qt</pkg> based frontend. It is now the most up-to-date graphical interface available.</flag>
<flag name="remoteosd">Enables RemoteOSD plugin (VNC client as video filter).</flag>
diff --git a/media-video/vlc/vlc-9999.ebuild b/media-video/vlc/vlc-9999.ebuild
index 95f22f5e7603..dd23a912f7bb 100644
--- a/media-video/vlc/vlc-9999.ebuild
+++ b/media-video/vlc/vlc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.20 2009/07/08 08:41:53 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.21 2009/07/13 09:10:54 aballier Exp $
EAPI="1"
@@ -51,10 +51,10 @@ IUSE="a52 aac aalib alsa altivec atmo avahi bidi cdda cddax cddb cdio dbus dc139
+gcrypt ggi gnome gnutls hal httpd id3tag ieee1394 jack kate libass libcaca
libnotify libproxy libsysfs libtiger libv4l2 lirc live lua matroska mmx
modplug mp3 mpeg mtp musepack ncurses nsplugin ogg opengl optimisememory oss
- pda png pulseaudio pvr +qt4 remoteosd rtsp run-as-root samba schroedinger
- sdl sdl-image seamonkey shine shout skins speex sse stream svg svga taglib
- theora truetype twolame upnp v4l v4l2 vcdinfo vcdx vlm vorbis win32codecs
- wma-fixed X x264 xcb xinerama xml xosd xv zvbi"
+ pda png projectm pulseaudio pvr +qt4 remoteosd rtsp run-as-root samba
+ schroedinger sdl sdl-image seamonkey shine shout skins speex sse stream
+ svg svga taglib theora truetype twolame upnp v4l v4l2 vcdinfo vcdx vlm
+ vorbis win32codecs wma-fixed X x264 xcb xinerama xml xosd xv zvbi"
RDEPEND="
sys-libs/zlib
@@ -118,6 +118,7 @@ RDEPEND="
ogg? ( media-libs/libogg )
pda? ( x11-libs/gtk+:2 )
png? ( media-libs/libpng )
+ projectm? ( media-libs/libprojectm )
pulseaudio? ( >=media-sound/pulseaudio-0.9.11 )
qt4? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 )
remoteosd? ( >=dev-libs/libgcrypt-1.2.0 )
@@ -313,6 +314,7 @@ src_compile () {
$(use_enable pda) \
$(use_enable png) \
--disable-portaudio \
+ $(use_enable projectm) \
$(use_enable pulseaudio pulse) \
$(use_enable pvr) \
$(use_enable qt4) \