summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-01 17:41:09 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-01 17:41:09 +0000
commit118434e63bd011ee3ce5926dfcf6fce078315e00 (patch)
treec6908eef567436d8d6f2b346be83016f75798941 /media-video
parentnew snapshot with the accumulated fixes (diff)
downloadgentoo-2-118434e63bd011ee3ce5926dfcf6fce078315e00.tar.gz
gentoo-2-118434e63bd011ee3ce5926dfcf6fce078315e00.tar.bz2
gentoo-2-118434e63bd011ee3ce5926dfcf6fce078315e00.zip
new snapshot matching lib
(Portage version: 2.2.0_alpha191/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/x264-encoder/ChangeLog8
-rw-r--r--media-video/x264-encoder/x264-encoder-0.0.20130731.ebuild70
2 files changed, 77 insertions, 1 deletions
diff --git a/media-video/x264-encoder/ChangeLog b/media-video/x264-encoder/ChangeLog
index b53674882a8e..7be331a1176b 100644
--- a/media-video/x264-encoder/ChangeLog
+++ b/media-video/x264-encoder/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/x264-encoder
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/x264-encoder/ChangeLog,v 1.72 2013/06/26 04:40:11 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/x264-encoder/ChangeLog,v 1.73 2013/08/01 17:41:09 aballier Exp $
+
+*x264-encoder-0.0.20130731 (01 Aug 2013)
+
+ 01 Aug 2013; Alexis Ballier <aballier@gentoo.org>
+ +x264-encoder-0.0.20130731.ebuild:
+ new snapshot matching lib
26 Jun 2013; Patrick McLean <chutzpah@gentoo.org>
x264-encoder-0.0.20130506.ebuild, x264-encoder-9999.ebuild:
diff --git a/media-video/x264-encoder/x264-encoder-0.0.20130731.ebuild b/media-video/x264-encoder/x264-encoder-0.0.20130731.ebuild
new file mode 100644
index 000000000000..588501904c9a
--- /dev/null
+++ b/media-video/x264-encoder/x264-encoder-0.0.20130731.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/x264-encoder/x264-encoder-0.0.20130731.ebuild,v 1.1 2013/08/01 17:41:09 aballier Exp $
+
+EAPI=5
+
+inherit flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="A free commandline encoder for X264/AVC streams"
+HOMEPAGE="http://www.videolan.org/developers/x264.html"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://git.videolan.org/x264.git"
+ SRC_URI=""
+else
+ inherit versionator
+ MY_P="x264-snapshot-$(get_version_component_range 3)-2245"
+ SRC_URI="http://download.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="10bit avs custom-cflags ffmpeg ffmpegsource +interlaced mp4 +threads"
+
+REQUIRED_USE="ffmpegsource? ( ffmpeg )"
+
+RDEPEND="ffmpeg? ( virtual/ffmpeg )
+ ~media-libs/x264-${PV}[10bit=,interlaced=,threads=]
+ ffmpegsource? ( media-libs/ffmpegsource )
+ mp4? ( >=media-video/gpac-0.4.1_pre20060122 )"
+
+ASM_DEP=">=dev-lang/yasm-1.2.0"
+DEPEND="${RDEPEND}
+ amd64? ( ${ASM_DEP} )
+ x86? ( ${ASM_DEP} )
+ x86-fbsd? ( ${ASM_DEP} )
+ virtual/pkgconfig"
+
+src_configure() {
+ tc-export CC
+
+ # let upstream pick the optimization level by default
+ use custom-cflags || filter-flags -O?
+
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --system-libx264 \
+ --host="${CHOST}" \
+ $(usex 10bit "--bit-depth=10" "") \
+ $(usex avs "" "--disable-avs") \
+ $(usex ffmpeg "" "--disable-lavf --disable-swscale") \
+ $(usex ffmpegsource "" "--disable-ffms") \
+ $(usex interlaced "" "--disable-interlaced") \
+ $(usex mp4 "" "--disable-gpac") \
+ $(usex threads "" "--disable-thread") || die
+
+ # this is a nasty workaround for bug #376925 for x264 that also applies
+ # here, needed because as upstream doesn't like us fiddling with their CFLAGS
+ if use custom-cflags; then
+ local cflags
+ cflags="$(grep "^CFLAGS=" config.mak | sed 's/CFLAGS=//')"
+ cflags="${cflags//$(get-flag O)/}"
+ cflags="${cflags//-O? /$(get-flag O) }"
+ cflags="${cflags//-g /}"
+ sed -i "s:^CFLAGS=.*:CFLAGS=${cflags//:/\\:}:" config.mak
+ fi
+}