summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-06-10 07:43:45 +0000
committerDavid Holm <dholm@gentoo.org>2004-06-10 07:43:45 +0000
commit320f42ee9a4dd8b2fa4ce86a3418e1d57b8ac6a7 (patch)
tree60fbbb0523c6b78bf16205363bda753e048c299e /media-video
parentAdded media-video/tcvp (diff)
downloadgentoo-2-320f42ee9a4dd8b2fa4ce86a3418e1d57b8ac6a7.tar.gz
gentoo-2-320f42ee9a4dd8b2fa4ce86a3418e1d57b8ac6a7.tar.bz2
gentoo-2-320f42ee9a4dd8b2fa4ce86a3418e1d57b8ac6a7.zip
USE-flag bugfix
Diffstat (limited to 'media-video')
-rw-r--r--media-video/tcvp/tcvp-0.2.0.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/media-video/tcvp/tcvp-0.2.0.ebuild b/media-video/tcvp/tcvp-0.2.0.ebuild
index 7a3d5774c53f..5f72da655fed 100644
--- a/media-video/tcvp/tcvp-0.2.0.ebuild
+++ b/media-video/tcvp/tcvp-0.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/tcvp/tcvp-0.2.0.ebuild,v 1.4 2004/06/09 22:09:53 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/tcvp/tcvp-0.2.0.ebuild,v 1.5 2004/06/10 07:43:45 dholm Exp $
DESCRIPTION="A modular player and encoder/transcoder for music and video."
HOMEPAGE="http://tcvp.sourceforge.net/"
@@ -10,19 +10,19 @@ SLOT="0"
LICENSE="MIT"
KEYWORDS="~x86 ~ppc"
-IUSE="mpeg mad faad alsa cdr dvd encode ffmpeg oggvorbis oss"
+IUSE="faad mpeg mad alsa dvd encode ffmpeg oggvorbis oss"
DEPEND=">=dev-libs/libtc-1.1.0
>=dev-libs/tc2-0.6.0
>=dev-libs/tc2-modules-0.6.0
>=media-libs/a52dec-0.7.4
+ >=media-sound/cdparanoia-3.9.8-r1
>=sys-apps/file-4.0
+ faad? ( media-libs/faad2 )
alsa? ( >=media-libs/alsa-lib-1.0.3b-r2 )
- cdr? ( >=media-sound/cdparanoia-3.9.8-r1 )
dvd? ( >=media-libs/libdvdnav-0.1.9 )
encode? ( >=media-libs/faac-1.23.5
>=media-sound/lame-3.96 )
- faad? ( media-libs/faad2 )
ffmpeg? ( >=media-video/ffmpeg-0.4.8 )
mad? ( >=media-sound/madplay-0.15.2b )
mpeg? ( >=media-libs/libmpeg2-0.4.0b )
@@ -33,10 +33,8 @@ src_compile() {
local myconf
myconf="--with-gnu-ld"
use alsa || myconf="${myconf} --disable-alsa"
- use cdr || myconf="${myconf} --disable-cdda"
use dvd || myconf="${myconf} --disable-dvd"
use encode || myconf="${myconf} --disable-lame --disable-aac_enc"
- use faad || myconf="${myconf} --disable-aac_dec"
use ffmpeg || myconf="${myconf} --disable-avcodec --disable-avformat --disable-avimage --disable-scale"
use mad || myconf="${myconf} --disable-mad"
use mpeg || myconf="${myconf} --disable-mpeg2"
@@ -50,5 +48,3 @@ src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS ChangeLog COPYING
}
-
-