summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-02-24 13:26:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-02-24 13:26:29 +0000
commit3ba55a105dc6a5aa85dc3ca495ec93f06376d8c2 (patch)
tree257257f75ac5ec21728d774df7f890f8606714f4 /media-video
parentbump a new snapshot (diff)
downloadgentoo-2-3ba55a105dc6a5aa85dc3ca495ec93f06376d8c2.tar.gz
gentoo-2-3ba55a105dc6a5aa85dc3ca495ec93f06376d8c2.tar.bz2
gentoo-2-3ba55a105dc6a5aa85dc3ca495ec93f06376d8c2.zip
bump a new snapshot
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/x264-encoder/ChangeLog10
-rw-r--r--media-video/x264-encoder/files/x264-encoder-nolib-20110223.patch38
-rw-r--r--media-video/x264-encoder/x264-encoder-0.0.20110223.ebuild60
3 files changed, 106 insertions, 2 deletions
diff --git a/media-video/x264-encoder/ChangeLog b/media-video/x264-encoder/ChangeLog
index 3b25c848992c..ad2e2b419a2f 100644
--- a/media-video/x264-encoder/ChangeLog
+++ b/media-video/x264-encoder/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/x264-encoder
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/x264-encoder/ChangeLog,v 1.46 2010/12/22 02:10:03 aballier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/x264-encoder/ChangeLog,v 1.47 2011/02/24 13:26:29 aballier Exp $
+
+*x264-encoder-0.0.20110223 (24 Feb 2011)
+
+ 24 Feb 2011; Alexis Ballier <aballier@gentoo.org>
+ +x264-encoder-0.0.20110223.ebuild, +files/x264-encoder-nolib-20110223.patch:
+ bump a new snapshot
22 Dec 2010; Alexis Ballier <aballier@gentoo.org>
-x264-encoder-0.0.20091021.ebuild, -files/x264-encoder-nolib-20090408.patch:
diff --git a/media-video/x264-encoder/files/x264-encoder-nolib-20110223.patch b/media-video/x264-encoder/files/x264-encoder-nolib-20110223.patch
new file mode 100644
index 000000000000..b7838c6e5fcd
--- /dev/null
+++ b/media-video/x264-encoder/files/x264-encoder-nolib-20110223.patch
@@ -0,0 +1,38 @@
+Index: x264-snapshot-20110223-2245/Makefile
+===================================================================
+--- x264-snapshot-20110223-2245.orig/Makefile
++++ x264-snapshot-20110223-2245/Makefile
+@@ -146,8 +146,8 @@ libx264.a: .depend $(OBJS) $(OBJASM)
+ $(SONAME): .depend $(OBJS) $(OBJASM) $(OBJSO)
+ $(CC) -shared -o $@ $(OBJS) $(OBJASM) $(OBJSO) $(SOFLAGS) $(LDFLAGS)
+
+-x264$(EXE): $(OBJCLI) libx264.a
+- $(CC) -o $@ $+ $(LDFLAGSCLI) $(LDFLAGS)
++x264$(EXE): $(OBJCLI)
++ $(CC) -o $@ $+ $(LDFLAGSCLI) $(LDFLAGS) `pkg-config --libs x264`
+
+ checkasm: tools/checkasm.o libx264.a
+ $(CC) -o $@ $+ $(LDFLAGS)
+@@ -214,22 +214,7 @@ distclean: clean
+
+ install: x264$(EXE) $(SONAME)
+ install -d $(DESTDIR)$(bindir)
+- install -d $(DESTDIR)$(includedir)
+- install -d $(DESTDIR)$(libdir)
+- install -d $(DESTDIR)$(libdir)/pkgconfig
+- install -m 644 x264.h $(DESTDIR)$(includedir)
+- install -m 644 x264_config.h $(DESTDIR)$(includedir)
+- install -m 644 libx264.a $(DESTDIR)$(libdir)
+- install -m 644 x264.pc $(DESTDIR)$(libdir)/pkgconfig
+ install x264$(EXE) $(DESTDIR)$(bindir)
+- $(RANLIB) $(DESTDIR)$(libdir)/libx264.a
+-ifeq ($(SYS),MINGW)
+- $(if $(SONAME), install -m 755 $(SONAME) $(DESTDIR)$(bindir))
+-else
+- $(if $(SONAME), ln -f -s $(SONAME) $(DESTDIR)$(libdir)/libx264.$(SOSUFFIX))
+- $(if $(SONAME), install -m 755 $(SONAME) $(DESTDIR)$(libdir))
+-endif
+- $(if $(IMPLIBNAME), install -m 644 $(IMPLIBNAME) $(DESTDIR)$(libdir))
+
+ uninstall:
+ rm -f $(DESTDIR)$(includedir)/x264.h $(DESTDIR)$(includedir)/x264_config.h $(DESTDIR)$(libdir)/libx264.a
diff --git a/media-video/x264-encoder/x264-encoder-0.0.20110223.ebuild b/media-video/x264-encoder/x264-encoder-0.0.20110223.ebuild
new file mode 100644
index 000000000000..17d27c0ff07f
--- /dev/null
+++ b/media-video/x264-encoder/x264-encoder-0.0.20110223.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/x264-encoder/x264-encoder-0.0.20110223.ebuild,v 1.1 2011/02/24 13:26:29 aballier Exp $
+
+EAPI=2
+inherit eutils multilib toolchain-funcs versionator
+
+MY_P=x264-snapshot-$(get_version_component_range 3)-2245
+
+DESCRIPTION="A free commandline encoder for X264/AVC streams"
+HOMEPAGE="http://www.videolan.org/developers/x264.html"
+SRC_URI="http://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug ffmpeg +mp4 +threads"
+
+RDEPEND="mp4? ( >=media-video/gpac-0.4.1_pre20060122 )
+ ~media-libs/x264-${PV}
+ ffmpeg? ( media-video/ffmpeg )"
+DEPEND="${RDEPEND}
+ amd64? ( >=dev-lang/yasm-0.6.2 )
+ x86? ( || ( >=dev-lang/yasm-0.6.2 dev-lang/nasm )
+ !<dev-lang/yasm-0.6.2 )
+ x86-fbsd? ( >=dev-lang/yasm-0.6.2 )
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-nostrip.patch \
+ "${FILESDIR}"/${PN}-nolib-20110223.patch
+}
+
+src_configure() {
+ tc-export CC
+
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debug"
+
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --disable-avs \
+ $(use_enable ffmpeg lavf) \
+ $(use_enable ffmpeg swscale) \
+ $(use_enable mp4 gpac) \
+ $(use_enable threads thread) \
+ --extra-asflags="${ASFLAGS}" \
+ --extra-cflags="${CFLAGS}" \
+ --extra-ldflags="${LDFLAGS}" \
+ --host="${CHOST}" \
+ ${myconf} \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}