summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-03-12 07:59:36 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-03-12 07:59:36 +0000
commit43b09195becf4f7876514bbdde00984647e7847a (patch)
treef025171740907fe26cf933a46358643bb160fa8f /media-video
parentAdd missing app-arch/zip dependency for the source use flag. (diff)
downloadgentoo-2-43b09195becf4f7876514bbdde00984647e7847a.tar.gz
gentoo-2-43b09195becf4f7876514bbdde00984647e7847a.tar.bz2
gentoo-2-43b09195becf4f7876514bbdde00984647e7847a.zip
Fix build with scons dev-util/scons-0.96.94, thanks to Castagnola Roberto for porting this patch, bug #159373, add ~amd64, die if ffmpeg is not built with a52 useflag, bug #159212
(Portage version: 2.1.2.2)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/dvbcut/ChangeLog10
-rw-r--r--media-video/dvbcut/dvbcut-0.5.3-r1.ebuild15
-rw-r--r--media-video/dvbcut/files/dvbcut-0.5.3-sconstruct.patch34
3 files changed, 54 insertions, 5 deletions
diff --git a/media-video/dvbcut/ChangeLog b/media-video/dvbcut/ChangeLog
index 226b3eefabe3..78ed58b8a8e9 100644
--- a/media-video/dvbcut/ChangeLog
+++ b/media-video/dvbcut/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/dvbcut
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvbcut/ChangeLog,v 1.2 2006/11/29 09:14:22 zzam Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvbcut/ChangeLog,v 1.3 2007/03/12 07:59:36 aballier Exp $
+
+ 12 Mar 2007; Alexis Ballier <aballier@gentoo.org>
+ +files/dvbcut-0.5.3-sconstruct.patch, dvbcut-0.5.3-r1.ebuild:
+ Fix build with scons dev-util/scons-0.96.94, thanks to Castagnola Roberto
+ for porting this patch, bug #159373, add ~amd64, die if ffmpeg is not built
+ with a52 useflag, bug #159212
*dvbcut-0.5.3-r1 (29 Nov 2006)
diff --git a/media-video/dvbcut/dvbcut-0.5.3-r1.ebuild b/media-video/dvbcut/dvbcut-0.5.3-r1.ebuild
index 8c6f8e83d9ac..05d5f4658f03 100644
--- a/media-video/dvbcut/dvbcut-0.5.3-r1.ebuild
+++ b/media-video/dvbcut/dvbcut-0.5.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvbcut/dvbcut-0.5.3-r1.ebuild,v 1.1 2006/11/29 09:14:22 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvbcut/dvbcut-0.5.3-r1.ebuild,v 1.2 2007/03/12 07:59:36 aballier Exp $
inherit qt3 eutils
@@ -15,7 +15,7 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
RDEPEND="$(qt_min_version 3)
media-libs/libao
@@ -24,10 +24,19 @@ RDEPEND="$(qt_min_version 3)
DEPEND="${RDEPEND}
dev-util/scons"
+pkg_setup() {
+ if ! built_with_use media-video/ffmpeg a52; then
+ eerror "This package requires media-video/ffmpeg compiled with A/52 (a.k.a. AC-3) support."
+ eerror "Please reemerge media-video/ffmpeg with USE=\"a52\"."
+ die "Please reemerge media-video/ffmpeg with USE=\"a52\"."
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${P}-ac3-buffer.patch"
+ epatch "${FILESDIR}/${P}-sconstruct.patch"
}
src_compile() {
diff --git a/media-video/dvbcut/files/dvbcut-0.5.3-sconstruct.patch b/media-video/dvbcut/files/dvbcut-0.5.3-sconstruct.patch
new file mode 100644
index 000000000000..a4382ca08d2a
--- /dev/null
+++ b/media-video/dvbcut/files/dvbcut-0.5.3-sconstruct.patch
@@ -0,0 +1,34 @@
+--- trunk/SConstruct 2006/09/04 19:40:35 1
++++ trunk/SConstruct 2007/01/28 11:09:32 21
+@@ -48,7 +48,7 @@
+
+ env.Replace(CXXFILESUFFIX=".cpp")
+
+-env.Append(CPPDEFINES={"_FILE_OFFSET_BITS": "64", "_LARGEFILE_SOURCE": None})
++env.Append(CPPDEFINES=[("_FILE_OFFSET_BITS", "64"), "_LARGEFILE_SOURCE"])
+
+ for v in ("CXX","LINK"):
+ if (v in os.environ):
+@@ -62,11 +62,11 @@
+
+ if (not env.GetOption('clean')):
+ if (conf.TryAction('pkg-config --exists ao')[0]):
+- conf.env.Append(CPPDEFINES={"HAVE_LIB_AO":None})
++ conf.env.Append(CPPDEFINES="HAVE_LIB_AO")
+ conf.env.ParseConfig('pkg-config --cflags --libs ao')
+ print "Checking for libao... found"
+ elif (conf.CheckLibWithHeader('ao', 'ao/ao.h', 'C')):
+- conf.env.Append(CPPDEFINES={"HAVE_LIB_AO":None})
++ conf.env.Append(CPPDEFINES="HAVE_LIB_AO")
+ conf.env.Append(LIBS=['ao'])
+ print "Checking for libao... found"
+ else:
+@@ -85,7 +85,7 @@
+ env.Replace(QT_LIB=qtlib)
+
+ if (debug<=0):
+- env.Append(CPPDEFINES={"QT_NO_DEBUG": None})
++ env.Append(CPPDEFINES="QT_NO_DEBUG")
+
+ ### FFMPEG
+