summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-08-06 21:54:15 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-08-06 21:54:15 +0000
commit4f5b3f744188e20f0eb90e35c88b4810f3e7ee23 (patch)
tree77763897ba87bafbaf2bd18d5e3fc02ad8c3046c /media-video
parentmissing mask on libdvdnav (diff)
downloadgentoo-2-4f5b3f744188e20f0eb90e35c88b4810f3e7ee23.tar.gz
gentoo-2-4f5b3f744188e20f0eb90e35c88b4810f3e7ee23.tar.bz2
gentoo-2-4f5b3f744188e20f0eb90e35c88b4810f3e7ee23.zip
new version
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mplayer/ChangeLog7
-rw-r--r--media-video/mplayer/files/digest-mplayer-0.90_pre63
-rw-r--r--media-video/mplayer/files/mplayer-0.90_pre6-vidix-fail-install.patch11
-rw-r--r--media-video/mplayer/mplayer-0.90_pre6.ebuild268
4 files changed, 288 insertions, 1 deletions
diff --git a/media-video/mplayer/ChangeLog b/media-video/mplayer/ChangeLog
index 7a6bcab92532..fb797095c8ed 100644
--- a/media-video/mplayer/ChangeLog
+++ b/media-video/mplayer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/mplayer
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.23 2002/06/13 18:58:02 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.24 2002/08/06 21:54:15 azarah Exp $
+
+ 06 Aug 2002; Martin Schlemmer <azarah@gentoo.org> mplayer-0.90_pre6 :
+
+ New version. Patch vidix's Makefile not to fail if it cannot install
+ any drivers. This should resolve bug #5246.
*mplayer-0.90_pre5-r1 (13 Jun 2002)
diff --git a/media-video/mplayer/files/digest-mplayer-0.90_pre6 b/media-video/mplayer/files/digest-mplayer-0.90_pre6
new file mode 100644
index 000000000000..9358dd6ed906
--- /dev/null
+++ b/media-video/mplayer/files/digest-mplayer-0.90_pre6
@@ -0,0 +1,3 @@
+MD5 819b4db6133291886df34cadcc03e09d MPlayer-0.90pre6.tar.bz2 2599258
+MD5 ab23f8e01a860a97852b28a3b0b118da mp-arial-iso-8859-1.zip 272659
+MD5 5e12e283eeeec6125523a6f4a60d07cf default-skin-0.1.tar.bz2 167697
diff --git a/media-video/mplayer/files/mplayer-0.90_pre6-vidix-fail-install.patch b/media-video/mplayer/files/mplayer-0.90_pre6-vidix-fail-install.patch
new file mode 100644
index 000000000000..ac2f23dc736d
--- /dev/null
+++ b/media-video/mplayer/files/mplayer-0.90_pre6-vidix-fail-install.patch
@@ -0,0 +1,11 @@
+--- MPlayer-0.90pre6/vidix/drivers/Makefile.orig Tue Aug 6 23:08:46 2002
++++ MPlayer-0.90pre6/vidix/drivers/Makefile Tue Aug 6 23:10:51 2002
+@@ -109,7 +109,7 @@
+
+ install:
+ mkdir -p $(LIBDIR)/mplayer/vidix
+- install -m 755 -s -p *.so $(LIBDIR)/mplayer/vidix
++ install -m 755 -s -p *.so $(LIBDIR)/mplayer/vidix || :
+ uninstall:
+ rm -f $(LIBDIR)/mplayer/vidix/*.so
+ rmdir -p --ignore-fail-on-non-empty $(LIBDIR)/mplayer/vidix
diff --git a/media-video/mplayer/mplayer-0.90_pre6.ebuild b/media-video/mplayer/mplayer-0.90_pre6.ebuild
new file mode 100644
index 000000000000..6e53b992d79d
--- /dev/null
+++ b/media-video/mplayer/mplayer-0.90_pre6.ebuild
@@ -0,0 +1,268 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-0.90_pre6.ebuild,v 1.1 2002/08/06 21:54:15 azarah Exp $
+
+# Handle PREversions as well
+MY_PV=${PV/_/}
+S="${WORKDIR}/MPlayer-${MY_PV}"
+# Only install Skin if GUI should be build (gtk as USE flag)
+SRC_URI="ftp://mplayerhq.hu/MPlayer/releases/MPlayer-${MY_PV}.tar.bz2
+ ftp://mplayerhq.hu/MPlayer/releases/mp-arial-iso-8859-1.zip
+ gtk? ( http://www.ibiblio.org/gentoo/distfiles/default-skin-0.1.tar.bz2 )"
+# This is to get the digest problem fixed.
+# gtk? ( ftp://mplayerhq.hu/MPlayer/Skin/default.tar.bz2 )"
+DESCRIPTION="Media Player for Linux"
+HOMEPAGE="http://www.mplayerhq.hu/"
+
+# 'encode' in USE for MEncoder
+RDEPEND=">=media-libs/divx4linux-20020418
+ >=media-libs/win32codecs-0.60
+ dvd? ( media-libs/libdvdread
+ media-libs/libdvdcss )
+ gtk? ( =x11-libs/gtk+-1.2*
+ media-libs/libpng )
+ esd? ( media-sound/esound )
+ ggi? ( media-libs/libggi )
+ sdl? ( media-libs/libsdl )
+ alsa? ( media-libs/alsa-lib )
+ svga? ( media-libs/svgalib )
+ encode? ( media-sound/lame
+ >=media-libs/libdv-0.9.5 )
+ opengl? ( virtual/opengl )
+ directfb? ( dev-libs/DirectFB )
+ oggvorbis? ( media-libs/libvorbis )
+ >=sys-apps/portage-1.9.10"
+
+DEPEND="${RDEPEND}
+ dev-lang/nasm
+ app-arch/unzip"
+
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="x86"
+
+
+src_unpack() {
+
+ unpack MPlayer-${MY_PV}.tar.bz2 mp-arial-iso-8859-1.zip
+
+ # Fix bug with the default Skin
+ use gtk && ( \
+ unpack default-skin-0.1.tar.bz2
+ cd ${WORKDIR}/default
+ patch < ${FILESDIR}/default-skin.diff || die "gtk patch failed"
+ )
+
+ cd ${S}
+ # Fixes some compile problems, thanks to Gwenn Gueguen
+ patch -p0 < ${FILESDIR}/mplayer-0.90_pre5-widget.patch || die
+ # Fixes include problem - Azarah (10 Jun 2002)
+ patch -p1 < ${FILESDIR}/mplayer-0.90_pre5-stream-include.patch || die
+ # Fixes install location for vidix drivers, thanks to Mezei Zoltan.
+ patch -p1 < ${FILESDIR}/mplayer-0.90_pre5-vidix-destpath.patch || die
+ # Fix missing subtitles for some regions (4), bug #3679, thanks
+ # to Bernardo Silva
+ patch -p1 < ${FILESDIR}/mplayer-0.90_pre5-spudec.c.patch || die
+ # Fixes intermittant problems where vidix drivers do not get build,
+ # and causes the install to fail - Azarah (06 Aug 2002)
+ patch -p1 < ${FILESDIR}/${P}-vidix-fail-install.patch || die
+}
+
+src_compile() {
+
+ if use matrox; then
+ check_KV
+ fi
+
+ local myconf=""
+
+ use 3dnow \
+ || myconf="${myconf} --disable-3dnow --disable-3dnowex"
+
+ use sse \
+ || myconf="${myconf} --disable-sse --disable-sse2"
+
+ # Only disable MMX if 3DNOW or SSE is not in USE
+ use mmx || use 3dnow || use sse \
+ || myconf="${myconf} --disable-mmx --disable-mmx2"
+
+ # Only disable X if gtk is not in USE
+ use X || use gtk \
+ || myconf="${myconf} --disable-x11 --disable-xv --disable-xmga --disable-png"
+
+ use matrox && use X \
+ && myconf="${myconf} --enable-xmga"
+
+ use gtk \
+ && myconf="${myconf} --enable-gui --enable-x11 --enable-xv --enable-png"
+
+ use oss \
+ || myconf="${myconf} --disable-ossaudio"
+
+ use opengl \
+ || myconf="${myconf} --disable-gl"
+
+ use sdl \
+ || myconf="${myconf} --disable-sdl"
+
+ use ggi \
+ || myconf="${myconf} --disable-ggi"
+
+ use svga \
+ || myconf="${myconf} --disable-svga"
+
+ use directfb \
+ || myconf="${myconf} --disable-directfb"
+
+ use fbcon \
+ || myconf="${myconf} --disable-fbdev"
+
+ use alsa \
+ || myconf="${myconf} --disable-alsa"
+
+ use oggvorbis \
+ || myconf="${myconf} --disable-vorbis"
+
+ use encode \
+ && myconf="${myconf} --enable-mencoder --enable-tv" \
+ || myconf="${myconf} --disable-mencoder"
+
+ use dvd \
+ && myconf="${myconf} --enable-dvdread --enable-css" \
+ || myconf="${myconf} --disable-mpdvdkit --disable-dvdread --disable-css"
+
+ use matrox \
+ && myconf="${myconf} --enable-mga" \
+ || myconf="${myconf} --disable-mga"
+
+ use 3dfx \
+ && myconf="${myconf} --enable-3dfx --enable-tdfxfb"
+
+ # Crashes on start when compiled with most optimizations.
+ # The code have CPU detection code now, with CPU specific
+ # optimizations, so extra should not be needed and is not
+ # recommended by the authors
+ unset CFLAGS
+ unset CXXFLAGS
+ ./configure --prefix=/usr \
+ --disable-runtime-cpudetection \
+ --disable-mp1e \
+ --enable-largefiles \
+ --enable-linux-devfs \
+ ${myconf} || die
+
+ emake all || die
+
+ use matrox && ( \
+ cd drivers
+ emake all || die
+ )
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ BINDIR=${D}/usr/bin \
+ LIBDIR=${D}/usr/lib \
+ CONFDIR=${D}/usr/share/mplayer \
+ DATADIR=${D}/usr/share/mplayer \
+ MANDIR=${D}/usr/share/man \
+ install || die
+
+ # MAN pages are already installed ...
+ rm DOCS/*.1
+ # Install the rest of the documentation
+ dodir /usr/share/doc/${PF}
+ cp -a DOCS/* ${D}/usr/share/doc/${PF}
+ doalldocs
+
+ # Install the default Skin and Gnome menu entry
+ use gtk && ( \
+ insinto /usr/share/mplayer/Skin/default
+ doins ${WORKDIR}/default/*
+ # Permissions is fried by default
+ chmod a+rx ${D}/usr/share/mplayer/Skin/default/
+ chmod a+r ${D}/usr/share/mplayer/Skin/default/*
+
+ # Fix the symlink
+ rm -rf ${D}/usr/bin/gmplayer
+ dosym /usr/bin/mplayer /usr/bin/gmplayer
+ )
+
+ use gnome && ( \
+ insinto /usr/share/pixmaps
+ newins ${S}/Gui/mplayer/pixmaps/icon.xpm mplayer.xpm
+ insinto /usr/share/gnome/apps/Multimedia
+ doins ${FILESDIR}/mplayer.desktop
+ )
+
+ # Install the font used by OSD and the GUI
+ dodir /usr/share/mplayer/fonts
+ cp -a ${WORKDIR}/iso-8859-1/ ${D}/usr/share/mplayer/fonts
+ rm -rf ${D}/usr/share/mplayer/font
+ dosym /usr/share/mplayer/fonts/iso-8859-1/arial-14/ /usr/share/mplayer/font
+
+ # This tries setting up mplayer.conf automagically
+ local video="sdl" audio="sdl"
+ use X && (
+ use gtk && video="xv" \
+ || use sdl && video="sdl" \
+ || use xv && video="xv" \
+ || use opengl && video="gl" \
+ || use ggi && video="ggi" \
+ || use dga && video="dga" \
+ || video="x11"
+ ) || (
+ use fbcon && video="fbdev" \
+ || use svga && video="svga" \
+ || use aalib && video="aa"
+ )
+
+ use sdl && audio="sdl" \
+ || use alsa && (
+ [ -e /usr/lib/libasound.so.2 ] && audio="alsa9" \
+ || audio="alsa5"
+ ) || use oss audio="oss" \
+
+ # Note to myself: do not change " into '
+ sed -e "s/vo=xv/vo=${video}/" \
+ -e "s/ao=oss/ao=${audio}/" \
+ -e 's/include =/#include =/' \
+ ${S}/etc/example.conf > ${T}/mplayer.conf
+
+ insinto /etc
+ doins ${T}/mplayer.conf
+
+ insinto /usr/share/mplayer
+ doins ${S}/etc/codecs.conf
+
+ use matrox && ( \
+ dodir /lib/modules/${KV}/kernel/drivers/char
+ cp ${S}/drivers/mga_vid.o ${D}/lib/modules/${KV}/kernel/drivers/char
+ )
+}
+
+pkg_postinst() {
+
+ echo
+ echo '######################################################################'
+ echo '# MPlayer users that are going to use the GUI, please note the #'
+ echo '# following: #'
+ echo '# #'
+ echo '# The GUI works best with mplayer -vo xv -gui, but since there is #'
+ echo '# no USE flag for XVideo, or for using the GUI, the autodetection #'
+ echo '# process cannot detect this by default (SDL will be used rather). #'
+ echo '# So, if your setup supports XVideo (xvinfo should give output), #'
+ echo '# maybe do something like: #'
+ echo '# #'
+ echo '# echo "vo = xv" >~/.mplayer/config #'
+ echo '# echo "gui = 1" >>~/.mplayer/config #'
+ echo '# #'
+ echo '# after launching mplayer for the first time. #'
+ echo '# #'
+ use gtk &>/dev/null \
+ || echo '# NB: the GUI needs "gtk" as USE flag to build. #'
+ echo '######################################################################'
+ echo
+ depmod -a
+}