summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2015-04-10 09:27:52 +0000
committerJames Le Cuirot <chewi@gentoo.org>2015-04-10 09:27:52 +0000
commit5b42dce98babafe7ef95406f07d2799fe4a746b9 (patch)
treee7f55abbd5aa62a7e27fa216043b82d78d20f9f2 /media-video
parentversion bump (diff)
downloadgentoo-2-5b42dce98babafe7ef95406f07d2799fe4a746b9.tar.gz
gentoo-2-5b42dce98babafe7ef95406f07d2799fe4a746b9.tar.bz2
gentoo-2-5b42dce98babafe7ef95406f07d2799fe4a746b9.zip
Version bump. Closes bug #546002. Added noexecstack flag to Makefile
patch to avoid QA warning on makemkv binary. This cannot be fixed "correctly" because the problem lies in a binary blob. Upstream will be notified. Also removing old version because newer glibc versions are stable now. (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 9C6D7DE4)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/makemkv/ChangeLog12
-rw-r--r--media-video/makemkv/files/makemkv-1.8.10-makefile.linux.patch11
-rw-r--r--media-video/makemkv/files/makemkv-makefile.patch19
-rw-r--r--media-video/makemkv/makemkv-1.8.10.ebuild110
-rw-r--r--media-video/makemkv/makemkv-1.9.2.ebuild (renamed from media-video/makemkv/makemkv-1.9.1.ebuild)4
5 files changed, 32 insertions, 124 deletions
diff --git a/media-video/makemkv/ChangeLog b/media-video/makemkv/ChangeLog
index 17a52219da4a..3f4df2d85fd2 100644
--- a/media-video/makemkv/ChangeLog
+++ b/media-video/makemkv/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for media-video/makemkv
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/makemkv/ChangeLog,v 1.49 2015/03/08 10:55:49 chewi Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/makemkv/ChangeLog,v 1.50 2015/04/10 09:27:52 chewi Exp $
+
+*makemkv-1.9.2 (10 Apr 2015)
+
+ 10 Apr 2015; James Le Cuirot <chewi@gentoo.org> +files/makemkv-makefile.patch,
+ +makemkv-1.9.2.ebuild, -files/makemkv-1.8.10-makefile.linux.patch,
+ -makemkv-1.8.10.ebuild, -makemkv-1.9.1.ebuild:
+ Version bump. Closes bug #546002. Added noexecstack flag to Makefile patch to
+ avoid QA warning on makemkv binary. This cannot be fixed "correctly" because
+ the problem lies in a binary blob. Upstream will be notified. Also removing
+ old version because newer glibc versions are stable now.
*makemkv-1.9.1 (08 Mar 2015)
diff --git a/media-video/makemkv/files/makemkv-1.8.10-makefile.linux.patch b/media-video/makemkv/files/makemkv-1.8.10-makefile.linux.patch
deleted file mode 100644
index 0c7e41e97c4c..000000000000
--- a/media-video/makemkv/files/makemkv-1.8.10-makefile.linux.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- makemkv-oss-1.8.10/Makefile.in.orig 2014-04-25 09:25:24.558767575 -0600
-+++ makemkv-oss-1.8.10/Makefile.in 2014-04-25 09:25:44.930534931 -0600
-@@ -50,7 +50,7 @@
- endif
-
- out/%: out/%.full
-- $(OBJCOPY) --strip-all --strip-debug --strip-unneeded --discard-all $< $@
-+ $(OBJCOPY) --discard-all $< $@
-
- out/libdriveio.so.0.full:
- mkdir -p out
diff --git a/media-video/makemkv/files/makemkv-makefile.patch b/media-video/makemkv/files/makemkv-makefile.patch
new file mode 100644
index 000000000000..f3db0819c95d
--- /dev/null
+++ b/media-video/makemkv/files/makemkv-makefile.patch
@@ -0,0 +1,19 @@
+--- makemkv-oss-1.9.2/Makefile.in.orig 2015-04-07 14:28:32.000000000 +0100
++++ makemkv-oss-1.9.2/Makefile.in 2015-04-09 22:00:26.821163836 +0100
+@@ -50,7 +50,7 @@
+ endif
+
+ out/%: out/%.full
+- $(OBJCOPY) --strip-all --strip-debug --strip-unneeded --discard-all $< $@
++ $(OBJCOPY) --discard-all $< $@
+
+ out/libdriveio.so.0.full:
+ mkdir -p out
+@@ -94,6 +94,6 @@
+
+ tmp/image_data.o : makemkvgui/bin/image_data.bin
+ mkdir -p tmp
+- $(LD) -r -b binary -o $@.rw $<
++ $(LD) -r -b binary -z noexecstack -o $@.rw $<
+ $(OBJCOPY) --rename-section .data=.rodata2,readonly,alloc,load,data,contents $@.rw $@
+
diff --git a/media-video/makemkv/makemkv-1.8.10.ebuild b/media-video/makemkv/makemkv-1.8.10.ebuild
deleted file mode 100644
index 19694d3e51f0..000000000000
--- a/media-video/makemkv/makemkv-1.8.10.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/makemkv/makemkv-1.8.10.ebuild,v 1.3 2014/10/15 20:44:34 pacho Exp $
-
-EAPI=5
-inherit eutils gnome2-utils multilib flag-o-matic
-
-MY_P=makemkv-oss-${PV}
-MY_PB=makemkv-bin-${PV}
-
-DESCRIPTION="Tool for ripping Blu-Ray, HD-DVD and DVD discs and copying content to a Matroska container"
-HOMEPAGE="http://www.makemkv.com/"
-SRC_URI="http://www.makemkv.com/download/old/${MY_P}.tar.gz
- http://www.makemkv.com/download/old/${MY_PB}.tar.gz"
-
-LICENSE="LGPL-2.1 MPL-1.1 MakeMKV-EULA openssl"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="multilib"
-
-QA_PREBUILT="opt/bin/makemkvcon opt/bin/mmdtsdec"
-
-RDEPEND="
- sys-libs/glibc[multilib?]
- dev-libs/expat
- dev-libs/openssl:0
- sys-libs/zlib
- virtual/opengl
- dev-qt/qtcore:4
- dev-qt/qtdbus:4
- dev-qt/qtgui:4
- || ( >=media-video/ffmpeg-1.0.0 >=media-video/libav-0.8.9 )
-"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/makemkv-oss-${PV}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-makefile.linux.patch
-}
-
-src_configure() {
- replace-flags -O* -Os
- if [[ -x ${ECONF_SOURCE:-.}/configure ]] ; then
- econf
- fi
-}
-
-src_compile() {
- emake GCC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}" || die "Make failed!"
-}
-
-src_install() {
- # install oss package
- dolib.so out/libdriveio.so.0
- dolib.so out/libmakemkv.so.1
- dolib.so out/libmmbd.so.0
- dosym libdriveio.so.0 /usr/$(get_libdir)/libdriveio.so.0.${PV}
- dosym libdriveio.so.0 /usr/$(get_libdir)/libdriveio.so
- dosym libmakemkv.so.1 /usr/$(get_libdir)/libmakemkv.so.1.${PV}
- dosym libmakemkv.so.1 /usr/$(get_libdir)/libmakemkv.so
- dosym libmmbd.so.0 /usr/$(get_libdir)/libmmbd.so
- dosym libmmbd.so.0 /usr/$(get_libdir)/libmmbd.so.0.${PV}
- into /opt
- dobin out/makemkv
-
- local res
- for res in 16 22 32 64 128; do
- newicon -s ${res} makemkvgui/share/icons/${res}x${res}/makemkv.png ${PN}.png
- done
-
- make_desktop_entry ${PN} MakeMKV ${PN} 'Qt;AudioVideo;Video'
-
- # install bin package
- pushd "${WORKDIR}"/${MY_PB}/bin >/dev/null
- if use x86; then
- dobin i386/{makemkvcon,mmdtsdec}
- elif use amd64; then
- dobin amd64/makemkvcon
- use multilib && dobin i386/mmdtsdec
- fi
- popd >/dev/null
-
- # install license and default profile
- pushd "${WORKDIR}"/${MY_PB}/src/share >/dev/null
- insinto /usr/share/MakeMKV
- doins *.{gz,xml}
- popd >/dev/null
-}
-
-pkg_preinst() { gnome2_icon_savelist; }
-
-pkg_postinst() {
- gnome2_icon_cache_update
-
- elog "While MakeMKV is in beta mode, upstream has provided a license"
- elog "to use if you do not want to purchase one."
- elog ""
- elog "See this forum thread for more information, including the key:"
- elog "http://www.makemkv.com/forum2/viewtopic.php?f=5&t=1053"
- elog ""
- elog "Note that beta license may have an expiration date and you will"
- elog "need to check for newer licenses/releases. "
- elog ""
- elog "If this is a new install, remember to copy the default profile"
- elog "to the config directory:"
- elog "cp /usr/share/MakeMKV/default.mmcp.xml ~/.MakeMKV/"
-}
-
-pkg_postrm() { gnome2_icon_cache_update; }
diff --git a/media-video/makemkv/makemkv-1.9.1.ebuild b/media-video/makemkv/makemkv-1.9.2.ebuild
index fc971cc04b5f..bebb1408c82d 100644
--- a/media-video/makemkv/makemkv-1.9.1.ebuild
+++ b/media-video/makemkv/makemkv-1.9.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/makemkv/makemkv-1.9.1.ebuild,v 1.1 2015/03/08 10:55:49 chewi Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/makemkv/makemkv-1.9.2.ebuild,v 1.1 2015/04/10 09:27:52 chewi Exp $
EAPI=5
inherit eutils gnome2-utils multilib flag-o-matic
@@ -39,7 +39,7 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}/makemkv-oss-${PV}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-{1.8.10-makefile.linux,path}.patch
+ epatch "${FILESDIR}"/${PN}-{makefile,path}.patch
}
src_configure() {