summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2012-06-27 09:38:16 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2012-06-27 09:38:16 +0000
commit75f4f8beda77f9e367acbe63f1c2f179d19acd0e (patch)
tree1255ee955df0cf902bf69e434f9f348fafeed270 /media-video
parentVersion bump to latest. Cleanup older. (diff)
downloadgentoo-2-75f4f8beda77f9e367acbe63f1c2f179d19acd0e.tar.gz
gentoo-2-75f4f8beda77f9e367acbe63f1c2f179d19acd0e.tar.bz2
gentoo-2-75f4f8beda77f9e367acbe63f1c2f179d19acd0e.zip
Initial commit, ebuild by Armageddon
(Portage version: 2.2.0_alpha104/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/subdownloader/ChangeLog10
-rw-r--r--media-video/subdownloader/Manifest3
-rw-r--r--media-video/subdownloader/metadata.xml16
-rw-r--r--media-video/subdownloader/subdownloader-2.0.14.ebuild32
4 files changed, 61 insertions, 0 deletions
diff --git a/media-video/subdownloader/ChangeLog b/media-video/subdownloader/ChangeLog
new file mode 100644
index 000000000000..5e50670acd65
--- /dev/null
+++ b/media-video/subdownloader/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-video/subdownloader
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/subdownloader/ChangeLog,v 1.1 2012/06/27 09:38:16 tampakrap Exp $
+
+*subdownloader-2.0.14 (27 Jun 2012)
+
+ 27 Jun 2012; Theo Chatzimichos <tampakrap@gentoo.org> +metadata.xml,
+ +subdownloader-2.0.14.ebuild:
+ Initial commit, ebuild by Armageddon
+
diff --git a/media-video/subdownloader/Manifest b/media-video/subdownloader/Manifest
new file mode 100644
index 000000000000..aade906080b6
--- /dev/null
+++ b/media-video/subdownloader/Manifest
@@ -0,0 +1,3 @@
+DIST subdownloader-2.0.14.tar.gz 1012349 RMD160 34fbe315a45d177c82230176036e53e18b14eae5 SHA1 64ab7fd9e77726e9c271d0dda7de21eee90dc569 SHA256 b383729144178a42a15fff3d65d2daa5f23be6f1f35660dac9bced64ad91ae52
+EBUILD subdownloader-2.0.14.ebuild 851 RMD160 4c3bb11a70033229b2e84f7895b55eeb192f1bdc SHA1 1ff1c1937035821ee4693199e25d9c09cc4ef2b8 SHA256 b51a4f660050eabb3af36c836c1eb45602e6f5771842f1e2a93eb8e7187c1f8d
+MISC metadata.xml 537 RMD160 0cc4e966d86d33319133e6c66833186f78cbeeec SHA1 7f349bbc5c50543f6a5ce51bfe94df7b3738c4de SHA256 182e38de2821da4431169c3fcc34d8d61e052338b9a281c7df3c5ac74bf8fd8f
diff --git a/media-video/subdownloader/metadata.xml b/media-video/subdownloader/metadata.xml
new file mode 100644
index 000000000000..4395c777286f
--- /dev/null
+++ b/media-video/subdownloader/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ThyArmageddon+Gentoo@Gmail.com</email>
+ <name>Elijah El Lazkani</name>
+ </maintainer>
+ <maintainer>
+ <email>tampakrap@gentoo.org</email>
+ <name>Theo Chatzimichos</name>
+ </maintainer>
+ <longdescription lang="en">
+ SubDownloader is a program for automatic download/upload subtitles for
+ videofiles (DIVX,MPEG,AVI,VOB,etc) and DVD's using fast hashing
+ </longdescription>
+</pkgmetadata>
diff --git a/media-video/subdownloader/subdownloader-2.0.14.ebuild b/media-video/subdownloader/subdownloader-2.0.14.ebuild
new file mode 100644
index 000000000000..54371747e82f
--- /dev/null
+++ b/media-video/subdownloader/subdownloader-2.0.14.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/subdownloader/subdownloader-2.0.14.ebuild,v 1.1 2012/06/27 09:38:16 tampakrap Exp $
+
+EAPI=4
+
+inherit python eutils
+
+DESCRIPTION="GUI application for automatic downloading/uploading of subtitles for videofiles"
+HOMEPAGE="http://www.subdownloader.net/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/PyQt4
+ dev-python/kaa-metadata"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto /usr/$(get_libdir)/subdownloader
+ doins -r cli FileManagement gui languages locale modules run.py
+ fperms 755 /usr/$(get_libdir)/subdownloader/run.py
+ dosym /usr/$(get_libdir)/subdownloader/run.py /usr/bin/subdownloader
+ doman subdownloader.1
+ dodoc README ChangeLog
+ doicon gui/images/subdownloader.png
+ domenu subdownloader.desktop
+}