summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-06-16 08:52:08 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-06-16 08:52:08 +0000
commit794c1864a7cb2ad88cd7b804ab18b2fb8773ed5d (patch)
tree25efc2b6123ba15ce1e513ae26a501cd089ef6c2 /media-video
parentppc stable, bug #181639 (diff)
downloadgentoo-2-794c1864a7cb2ad88cd7b804ab18b2fb8773ed5d.tar.gz
gentoo-2-794c1864a7cb2ad88cd7b804ab18b2fb8773ed5d.tar.bz2
gentoo-2-794c1864a7cb2ad88cd7b804ab18b2fb8773ed5d.zip
Changed tmp-file-location to absolute path.
(Portage version: 2.1.3_rc1)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mplay-sh/ChangeLog8
-rw-r--r--media-video/mplay-sh/files/digest-mplay-sh-0.5.3-r13
-rw-r--r--media-video/mplay-sh/mplay-sh-0.5.3-r1.ebuild46
3 files changed, 56 insertions, 1 deletions
diff --git a/media-video/mplay-sh/ChangeLog b/media-video/mplay-sh/ChangeLog
index f14ea48b73d6..299ad17f58c4 100644
--- a/media-video/mplay-sh/ChangeLog
+++ b/media-video/mplay-sh/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/mplay-sh
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplay-sh/ChangeLog,v 1.1 2007/05/15 11:57:30 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplay-sh/ChangeLog,v 1.2 2007/06/16 08:52:08 zzam Exp $
+
+*mplay-sh-0.5.3-r1 (16 Jun 2007)
+
+ 16 Jun 2007; Matthias Schwarzott <zzam@gentoo.org>
+ +mplay-sh-0.5.3-r1.ebuild:
+ Changed tmp-file-location to absolute path.
*mplay-sh-0.5.3 (15 May 2007)
diff --git a/media-video/mplay-sh/files/digest-mplay-sh-0.5.3-r1 b/media-video/mplay-sh/files/digest-mplay-sh-0.5.3-r1
new file mode 100644
index 000000000000..173847ecf6e8
--- /dev/null
+++ b/media-video/mplay-sh/files/digest-mplay-sh-0.5.3-r1
@@ -0,0 +1,3 @@
+MD5 1b2cc3c48b56d3eb8b5ba976ee409e01 mplay-0.5.3.tgz 26829
+RMD160 ec9c069b043e0c5147880807d0e9256fceb25747 mplay-0.5.3.tgz 26829
+SHA256 2dee614796b97a1790ab58f0ee5f248d663376b2d2478061387535ddb6b5cc8e mplay-0.5.3.tgz 26829
diff --git a/media-video/mplay-sh/mplay-sh-0.5.3-r1.ebuild b/media-video/mplay-sh/mplay-sh-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..06fb79132371
--- /dev/null
+++ b/media-video/mplay-sh/mplay-sh-0.5.3-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplay-sh/mplay-sh-0.5.3-r1.ebuild,v 1.1 2007/06/16 08:52:08 zzam Exp $
+
+inherit eutils
+
+MY_P="mplay-${PV}"
+
+DESCRIPTION="mplayer wrapper script as backend for vdr-mplayer"
+HOMEPAGE="http://www.vdr-portal.de/board/thread.php?threadid=62306"
+SRC_URI="mirror://gentoo/${MY_P}.tgz
+ http://dev.gentoo.org/~zzam/distfiles/${MY_P}.tgz"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="media-tv/gentoo-vdr-scripts"
+RDEPEND=">=media-video/mplayer-0.90_rc4"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ sed -i mplay.sh \
+ -e 's#$CONFDIR/silence.wav#/usr/share/vdr/mplay-sh/silence.wav#'
+ sed -i conf.examples/mplayrc \
+ -e 's#^MPLAY_PLAY.*#MPLAY_PLAY="/var/vdr/tmp/mplay.play"#'
+}
+
+src_install() {
+ exeinto /usr/share/vdr/mplayer/bin
+ doexe mplay.sh
+
+ insinto /etc/vdr/plugins/mplay
+ doins conf.examples/*.conf conf.examples/mplayrc
+
+ insinto /usr/share/vdr/mplay-sh
+ doins conf.examples/silence.wav
+
+ dodoc README* HISTORY
+ keepdir /var/vdr/tmp
+ chown vdr:vdr -R "${D}/var/vdr"
+}