summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-11-14 17:31:37 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-11-14 17:31:37 +0000
commit91c0cd608e92911bb4ccd99a6acb26c81d4c016b (patch)
treee3c03ef631313e10009844f71d3b06dd9ec099f0 /media-video
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-91c0cd608e92911bb4ccd99a6acb26c81d4c016b.tar.gz
gentoo-2-91c0cd608e92911bb4ccd99a6acb26c81d4c016b.tar.bz2
gentoo-2-91c0cd608e92911bb4ccd99a6acb26c81d4c016b.zip
Fix a problem in the youtube plugin, When trying to play a video, bug #292839. Thanks to Ryan May.
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/totem/ChangeLog10
-rw-r--r--media-video/totem/files/totem-2.26.4-youtube-plug-play-vids.patch22
-rw-r--r--media-video/totem/totem-2.26.4-r1.ebuild165
3 files changed, 196 insertions, 1 deletions
diff --git a/media-video/totem/ChangeLog b/media-video/totem/ChangeLog
index c8458e91dbc8..ce653754e617 100644
--- a/media-video/totem/ChangeLog
+++ b/media-video/totem/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-video/totem
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/totem/ChangeLog,v 1.261 2009/11/05 20:38:06 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/totem/ChangeLog,v 1.262 2009/11/14 17:31:37 mrpouet Exp $
+
+*totem-2.26.4-r1 (14 Nov 2009)
+
+ 14 Nov 2009; Romain Perier <mrpouet@gentoo.org>
+ +totem-2.26.4-r1.ebuild,
+ +files/totem-2.26.4-youtube-plug-play-vids.patch:
+ Fix a problem in the youtube plugin, When trying to play a video, bug
+ #292839. Thanks to Ryan May.
05 Nov 2009; Markus Meier <maekke@gentoo.org> totem-2.26.3-r1.ebuild:
arm stable, bug #281427
diff --git a/media-video/totem/files/totem-2.26.4-youtube-plug-play-vids.patch b/media-video/totem/files/totem-2.26.4-youtube-plug-play-vids.patch
new file mode 100644
index 000000000000..5b9aa3fe955c
--- /dev/null
+++ b/media-video/totem/files/totem-2.26.4-youtube-plug-play-vids.patch
@@ -0,0 +1,22 @@
+Date: Sat, 14 Nov 2009 18:15:55 +0100
+Subject: Fix a problem in the youtube plugin when we try to play a video (in the search panel or by giving it a url).
+Bug: https://bugs.gentoo.org/show_bug.cgi?id=292839
+
+Mainly due to a malformed regexp.
+
+---
+ src/plugins/youtube/youtube.py | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+--- a/src/plugins/youtube/youtube.py
++++ b/src/plugins/youtube/youtube.py
+@@ -204,7 +204,7 @@ class YouTube (totem.Plugin):
+ def resolve_t_param (self, youtube_id):
+ """We have to get the t parameter from the actual video page, since Google changed how their URLs work"""
+ stream = urllib.urlopen ("http://youtube.com/watch?v=" + urllib.quote (youtube_id))
+- regexp1 = re.compile ("swfArgs.*\"t\": \"([^\"]+)\"")
++ regexp1 = re.compile ("'SWF_ARGS'.*\"t\": \"([^\"]+)\"")
+ regexp2 = re.compile ("</head>")
+
+ contents = stream.read ()
+
diff --git a/media-video/totem/totem-2.26.4-r1.ebuild b/media-video/totem/totem-2.26.4-r1.ebuild
new file mode 100644
index 000000000000..5763e3c3d414
--- /dev/null
+++ b/media-video/totem/totem-2.26.4-r1.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/totem/totem-2.26.4-r1.ebuild,v 1.1 2009/11/14 17:31:37 mrpouet Exp $
+
+EAPI="2"
+
+inherit autotools eutils gnome2 multilib python
+
+DESCRIPTION="Media player for GNOME"
+HOMEPAGE="http://gnome.org/projects/totem/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="bluetooth debug doc galago lirc nautilus nsplugin python tracker"
+
+# TODO:
+# easy-publish-and-consume is not in tree (epc)
+# Cone (VLC) plugin needs someone with the right setup (remi ?)
+# check gmyth requirement ? -> waiting for updates in tree
+# coherence plugin not enabled until we have deps in tree
+
+# youtube plugin depends on gst-plugins-soup
+RDEPEND=">=dev-libs/glib-2.15
+ >=x11-libs/gtk+-2.13.0
+ >=gnome-base/gconf-2.0
+ >=dev-libs/totem-pl-parser-2.23.91
+ >=x11-themes/gnome-icon-theme-2.16
+ x11-libs/cairo
+ app-text/iso-codes
+ >=dev-libs/libxml2-2.6
+ >=dev-libs/dbus-glib-0.71
+ >=media-libs/gstreamer-0.10.16
+ >=media-libs/gst-plugins-good-0.10
+ >=media-libs/gst-plugins-base-0.10.12
+ >=media-plugins/gst-plugins-gconf-0.10
+
+ >=media-plugins/gst-plugins-gio-0.10
+ >=media-plugins/gst-plugins-pango-0.10
+ >=media-plugins/gst-plugins-x-0.10
+ >=media-plugins/gst-plugins-meta-0.10-r2
+
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXtst
+ >=x11-libs/libXrandr-1.1.1
+ >=x11-libs/libXxf86vm-1.0.1
+
+ bluetooth? ( || (
+ net-wireless/bluez
+ net-wireless/bluez-libs ) )
+ galago? ( >=dev-libs/libgalago-0.5.2 )
+ lirc? ( app-misc/lirc )
+ nautilus? ( >=gnome-base/nautilus-2.10 )
+ python? (
+ dev-lang/python[threads]
+ >=dev-python/pygtk-2.12
+ dev-python/pyxdg
+ dev-python/gdata
+ dev-python/gst-python
+ dev-python/gconf-python
+ media-plugins/gst-plugins-soup )
+ tracker? ( >=app-misc/tracker-0.5.3 )"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto
+ app-text/scrollkeeper
+ gnome-base/gnome-common
+ app-text/gnome-doc-utils
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.20
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1.11 )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+# FIXME: tests broken with USE="-doc" upstream bug #577774
+RESTRICT="test"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ --disable-schemas-install
+ --disable-static
+ --disable-vala
+ --with-dbus
+ --with-smclient
+ --enable-easy-codec-installation
+ $(use_enable nsplugin browser-plugins)"
+
+ # Plugin configuration
+ G2CONF="${G2CONF}
+ BROWSER_PLUGIN_DIR=/usr/$(get_libdir)/nsbrowser/plugins
+ PLUGINDIR=/usr/$(get_libdir)/totem/plugins"
+
+ local plugins="properties,thumbnail,screensaver,ontop,gromit,media-player-keys,skipto,brasero-disc-recorder,screenshot"
+ use bluetooth && plugins="${plugins},bemused"
+ use galago && plugins="${plugins},galago"
+ use lirc && plugins="${plugins},lirc"
+ use python && plugins="${plugins},youtube,opensubtitles,jamendo,pythonconsole"
+ use tracker && plugins="${plugins},tracker"
+
+ G2CONF="${G2CONF} --with-plugins=${plugins}"
+
+ G2CONF="${G2CONF}
+ $(use_enable debug)
+ $(use_enable nautilus)
+ $(use_enable python)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix broken smclient option passing
+ epatch "${FILESDIR}/${PN}-2.26.1-smclient-target-detection.patch"
+ # YouTube plugin broken, when we try to load some videos, bug #292839
+ epatch "${FILESDIR}/${P}-youtube-plug-play-vids.patch"
+
+ # FIXME: tarball generated with broken gtk-doc, revisit me.
+ if use doc; then
+ sed "/^TARGET_DIR/i \GTKDOC_REBASE=/usr/bin/gtkdoc-rebase" \
+ -i gtk-doc.make || die "sed 1 failed"
+ else
+ sed "/^TARGET_DIR/i \GTKDOC_REBASE=$(type -P true)" \
+ -i gtk-doc.make || die "sed 2 failed"
+ fi
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+src_configure() {
+ # FIXME: why does it need write access here, probably need to set up a fake
+ # home in /var/tmp like other pkgs do
+
+ addpredict "$(unset HOME; echo ~)/.gconf"
+ addpredict "$(unset HOME; echo ~)/.gconfd"
+ addpredict "$(unset HOME; echo ~)/.gnome2"
+
+ gnome2_src_configure
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if use python; then
+ python_need_rebuild
+ python_mod_optimize /usr/$(get_libdir)/totem/plugins
+ fi
+
+ ewarn
+ ewarn "If totem doesn't play some video format, please check your"
+ ewarn "USE flags on media-plugins/gst-plugins-meta"
+ ewarn
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/totem/plugins
+}