summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2006-10-16 20:34:00 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2006-10-16 20:34:00 +0000
commit97c664e51140f388adc0b4f07e08b48fafe21225 (patch)
tree8cae12fe19ba517107c258e3c9e304424d45f27f /media-video
parentAdd menu entry. Bug #150362 (diff)
downloadgentoo-2-97c664e51140f388adc0b4f07e08b48fafe21225.tar.gz
gentoo-2-97c664e51140f388adc0b4f07e08b48fafe21225.tar.bz2
gentoo-2-97c664e51140f388adc0b4f07e08b48fafe21225.zip
add patch - Fixes problems with noad --OSD if vdr is not running
(Portage version: 2.1.1)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/noad/ChangeLog8
-rw-r--r--media-video/noad/files/digest-noad-0.6.0-r63
-rw-r--r--media-video/noad/files/noad-0.6.0-fix-osd.patch30
-rw-r--r--media-video/noad/noad-0.6.0-r6.ebuild84
4 files changed, 124 insertions, 1 deletions
diff --git a/media-video/noad/ChangeLog b/media-video/noad/ChangeLog
index 76cecdfdccce..994950d4e438 100644
--- a/media-video/noad/ChangeLog
+++ b/media-video/noad/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/noad
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/noad/ChangeLog,v 1.10 2006/10/07 11:19:01 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/noad/ChangeLog,v 1.11 2006/10/16 20:34:00 hd_brummy Exp $
+
+*noad-0.6.0-r6 (16 Oct 2006)
+
+ 16 Oct 2006; Joerg Bornkessel <hd_brummy@gentoo.org>
+ +files/noad-0.6.0-fix-osd.patch, +noad-0.6.0-r6.ebuild:
+ add patch - Fixes problems with noad --OSD if vdr is not running
*noad-0.6.0-r5 (07 Oct 2006)
diff --git a/media-video/noad/files/digest-noad-0.6.0-r6 b/media-video/noad/files/digest-noad-0.6.0-r6
new file mode 100644
index 000000000000..05e249e57c9d
--- /dev/null
+++ b/media-video/noad/files/digest-noad-0.6.0-r6
@@ -0,0 +1,3 @@
+MD5 62947d5afec56cdb9884535d9813530d noad-0.6.0.tar.bz2 151369
+RMD160 762c8efeb89d681a77d83d0df70668b62a7057dd noad-0.6.0.tar.bz2 151369
+SHA256 f473f0137fa9ba8f7a736d9ca019fe5491e1744b17b54a1bdbfc23a9c8001183 noad-0.6.0.tar.bz2 151369
diff --git a/media-video/noad/files/noad-0.6.0-fix-osd.patch b/media-video/noad/files/noad-0.6.0-fix-osd.patch
new file mode 100644
index 000000000000..d25eb0064e00
--- /dev/null
+++ b/media-video/noad/files/noad-0.6.0-fix-osd.patch
@@ -0,0 +1,30 @@
+http://www.e-tobi.net/cgi-bin/viewcvs.cgi/vdr-addon-noad/trunk/debian/patches/10_fix-osd.dpatch?rev=1946&root=vdr+subversion+repository&view=auto
+
+Fixes problems with "noad --OSD" if vdr is not running.
+
+Joerg Bornkessel <hd_brummy@gentoo.org> 16 Oct 2006
+
+--- old/svdrpc.cpp Tue Jun 22 00:41:57 2004
++++ new/svdrpc.cpp Sat Dec 18 19:54:44 2004
+@@ -189,6 +189,10 @@
+ {
+ select(1, &set, NULL, NULL, &timeout);
+ n = read(filedes, buf + rbytes, 1);
++ if(n<0) {
++ filedes=-1;
++ break;
++ }
+ rbytes += n;
+ if (rbytes == size)
+ break;
+@@ -214,7 +218,8 @@
+ while( i < 100 && outstandingReply > 0 )
+ {
+ usleep(10000);
+- ReadReply();
++ if( !ReadReply() )
++ break;
+ i++;
+ }
+ return( outstandingReply <= 0 );
+
diff --git a/media-video/noad/noad-0.6.0-r6.ebuild b/media-video/noad/noad-0.6.0-r6.ebuild
new file mode 100644
index 000000000000..4faeb5f804ce
--- /dev/null
+++ b/media-video/noad/noad-0.6.0-r6.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/noad/noad-0.6.0-r6.ebuild,v 1.1 2006/10/16 20:34:00 hd_brummy Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="Mark commercial Breaks in VDR records"
+HOMEPAGE="http://www.freepgs.com/noad/"
+SRC_URI="http://www.freepgs.com/${PN}/${P}.tar.bz2
+ mirror://vdrfiles/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="ffmpeg imagemagick"
+
+DEPEND="media-libs/libmpeg2
+ media-video/vdr
+ ffmpeg? ( >=media-video/ffmpeg-0.4.8 )
+ imagemagick? ( >=media-gfx/imagemagick-6.2.4.2-r1 )"
+RDEPEND=">=media-tv/gentoo-vdr-scripts-0.3.5"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-directoryfix.diff
+ epatch ${FILESDIR}/${P}-as-needed.diff
+ epatch ${FILESDIR}/${P}-cflags.diff
+ epatch ${FILESDIR}/${P}-framesize.diff
+ epatch ${FILESDIR}/${P}-delete-while-scanning.diff
+ epatch ${FILESDIR}/${P}-fix-osd.patch
+
+ rm configure
+ eautoreconf
+}
+
+src_compile() {
+
+ econf \
+ $(use_with ffmpeg) \
+ $(use_with imagemagick magick) \
+ --with-tools \
+ --with-mpeginclude=/usr/include/mpeg2dec
+
+ emake || die "emake faild"
+}
+
+src_install() {
+
+ dobin noad showindex
+ use imagemagick && dobin markpics
+
+ dodoc COPYING README INSTALL
+ # example scripts are installed as dokumentation
+ dodoc allnewnoad allnoad allnoadnice clearlogos noadifnew stat2html
+
+ CONF_SOURCE=${FILESDIR}/0.6.0-r5
+ insinto /etc/conf.d
+ newins ${CONF_SOURCE}/confd_vdraddon.noad vdraddon.noad
+
+ insinto /usr/share/vdr/record
+ doins ${CONF_SOURCE}/record-50-noad.sh
+
+ insinto /etc/vdr/reccmds
+ doins ${CONF_SOURCE}/reccmds.noad.conf
+
+ exeinto /usr/share/vdr/bin
+ doexe ${CONF_SOURCE}/noad-reccmd
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo "Congratulations, you have just installed noad!,"
+ einfo "To integrate noad in VDR you should do this:"
+ einfo
+ einfo "start and set Parameter in /etc/conf.d/vdraddon.noad"
+ einfo
+ einfo "Note: You can use here all pararmeters for noad,"
+ einfo "please look in the documentation of noad."
+ einfo
+}