summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-07-06 18:38:21 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-07-06 18:38:21 +0000
commitd082894650a45683de39c00e8c6761710910eebb (patch)
tree4439067253ce672a0062168f412f182974ee22e3 /media-video
parentcman is masked for removal (diff)
downloadgentoo-2-d082894650a45683de39c00e8c6761710910eebb.tar.gz
gentoo-2-d082894650a45683de39c00e8c6761710910eebb.tar.bz2
gentoo-2-d082894650a45683de39c00e8c6761710910eebb.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/xvideoservicethief/ChangeLog8
-rw-r--r--media-video/xvideoservicethief/xvideoservicethief-2.1.ebuild69
2 files changed, 76 insertions, 1 deletions
diff --git a/media-video/xvideoservicethief/ChangeLog b/media-video/xvideoservicethief/ChangeLog
index e6dc377f6eba..9dc77df95846 100644
--- a/media-video/xvideoservicethief/ChangeLog
+++ b/media-video/xvideoservicethief/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/xvideoservicethief
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/xvideoservicethief/ChangeLog,v 1.5 2009/06/30 22:37:45 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xvideoservicethief/ChangeLog,v 1.6 2009/07/06 18:38:21 hwoarang Exp $
+
+*xvideoservicethief-2.1 (06 Jul 2009)
+
+ 06 Jul 2009; Markos Chandras <hwoarang@gentoo.org>
+ +xvideoservicethief-2.1.ebuild:
+ Version bump
30 Jun 2009; Markos Chandras <hwoarang@gentoo.org>
-xvideoservicethief-1.8.2.ebuild, -xvideoservicethief-2.0.0.ebuild:
diff --git a/media-video/xvideoservicethief/xvideoservicethief-2.1.ebuild b/media-video/xvideoservicethief/xvideoservicethief-2.1.ebuild
new file mode 100644
index 000000000000..cebad88a45fe
--- /dev/null
+++ b/media-video/xvideoservicethief/xvideoservicethief-2.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/xvideoservicethief/xvideoservicethief-2.1.ebuild,v 1.1 2009/07/06 18:38:21 hwoarang Exp $
+
+EAPI=2
+inherit eutils qt4 versionator
+
+MY_PN=xVST
+MY_PV=$(replace_all_version_separators '_')
+MY_P=${MY_PN}_${MY_PV}_src
+
+DESCRIPTION="Download (and convert) videos from various Web Video Services"
+HOMEPAGE="http://xviservicethief.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xviservicethief/${MY_P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug linguas_br linguas_ca linguas_cs linguas_da linguas_de linguas_es
+linguas_fr linguas_gl linguas_hu linguas_it linguas_pl linguas_ro
+linguas_sv"
+
+DEPEND="app-arch/unzip
+ >=x11-libs/qt-gui-4.5.0:4"
+RDEPEND=">=x11-libs/qt-gui-4.5.0:4
+ media-video/ffmpeg"
+
+S="${WORKDIR}/${MY_PN}-src-1.2"
+
+LANGS="br ca cs da de es fr gl hu it pl ro sv"
+
+src_prepare() {
+ # fix czech translation
+ mv "${S}"/resources/translations/xVST_cz.ts "${S}"/resources/translations/xVST_cs.ts
+ # fix plugins, language path
+ sed -i -e "s/getApplicationPath()\ +\ \"/\"\/usr\/share\/${PN}/g" \
+ "${S}"/src/options.cpp || die "failed to fix paths"
+}
+
+src_configure() {
+ eqmake4 xVideoServiceThief.pro
+}
+
+src_compile() {
+ local lang=
+ emake || die "emake failed"
+ for lang in "${S}"/resources/translations/*.ts; do
+ lrelease ${lang}
+ done
+}
+
+src_install() {
+ dobin bin/xvst || die "dobin failed"
+ local dest=/usr/share/${PN}/plugins
+ dodir ${dest}
+ find resources/services -name '*.js' -exec cp -dpR {} "${D}"${dest} \;
+ dodoc changelog.txt
+ newicon resources/images/InformationLogo.png xvst.png
+ make_desktop_entry /usr/bin/xvst xVideoServiceThief xvst 'Qt;AudioVideo;Video'
+
+ #install translations
+ insinto /usr/share/${PN}/languages/
+ local lang= tlang=
+ for lang in ${LINGUAS}; do
+ for tlang in ${LANGS}; do
+ [[ ${lang} == ${tlang} ]] && doins "${S}"/resources/translations/xVST_${tlang}.qm
+ done
+ done
+}