summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-08-30 21:37:50 +0000
committerMichael Weber <xmw@gentoo.org>2010-08-30 21:37:50 +0000
commit6da31182e4463153e7ae7a2e151ea7db82b88411 (patch)
tree8314c5d934567e8c18ee5b2ca055e0f4c4b5cfb5 /net-analyzer/bing/bing-1.1.3-r1.ebuild
parenttaking maintainership of this package (diff)
downloadgentoo-2-6da31182e4463153e7ae7a2e151ea7db82b88411.tar.gz
gentoo-2-6da31182e4463153e7ae7a2e151ea7db82b88411.tar.bz2
gentoo-2-6da31182e4463153e7ae7a2e151ea7db82b88411.zip
Respect CC, EAPI-2 update
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/bing/bing-1.1.3-r1.ebuild')
-rw-r--r--net-analyzer/bing/bing-1.1.3-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/bing/bing-1.1.3-r1.ebuild b/net-analyzer/bing/bing-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..61e410a934f9
--- /dev/null
+++ b/net-analyzer/bing/bing-1.1.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bing/bing-1.1.3-r1.ebuild,v 1.1 2010/08/30 21:37:50 xmw Exp $
+
+EAPI=2
+
+inherit toolchain-funcs
+
+DESCRIPTION="A point-to-point bandwidth measurement tool."
+SRC_URI="mirror://debian/pool/main/b/bing/${PN}_${PV}.orig.tar.gz"
+HOMEPAGE="http://fgouget.free.fr/bing/index-en.shtml"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="as-is"
+IUSE=""
+
+RDEPEND=""
+DEPEND=">=sys-apps/sed-4"
+
+src_prepare() {
+ sed -i -e "s:#COPTIM = -g: COPTIM = ${CFLAGS}:" Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"|| die "emake failed"
+}
+
+src_install() {
+ dobin bing || die
+ doman unix/bing.8 || die
+ dodoc ChangeLog Readme.{1st,txt} || die
+}