summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2010-01-30 22:18:23 +0000
committerSven Wegener <swegener@gentoo.org>2010-01-30 22:18:23 +0000
commit7fda7eb00b7098342e80d234f4b290879f39a1e0 (patch)
treebc6fe30e429104ebd27b4c3caa7a2d6a36ee92a4 /net-analyzer/bmon
parentProperly split off src_configure for EAPI 3. (diff)
downloadgentoo-2-7fda7eb00b7098342e80d234f4b290879f39a1e0.tar.gz
gentoo-2-7fda7eb00b7098342e80d234f4b290879f39a1e0.tar.bz2
gentoo-2-7fda7eb00b7098342e80d234f4b290879f39a1e0.zip
Add a patch to make bmon work with newer sysfs that has symlinks for net devices.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/bmon')
-rw-r--r--net-analyzer/bmon/ChangeLog7
-rw-r--r--net-analyzer/bmon/bmon-2.1.0-r3.ebuild5
-rw-r--r--net-analyzer/bmon/bmon-2.1.1_pre1.ebuild5
-rw-r--r--net-analyzer/bmon/files/bmon-2.1.0-sysfs-symlink.patch11
4 files changed, 23 insertions, 5 deletions
diff --git a/net-analyzer/bmon/ChangeLog b/net-analyzer/bmon/ChangeLog
index ef8e57944e89..e9030e48c774 100644
--- a/net-analyzer/bmon/ChangeLog
+++ b/net-analyzer/bmon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/bmon
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bmon/ChangeLog,v 1.43 2010/01/25 12:54:23 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bmon/ChangeLog,v 1.44 2010/01/30 22:18:23 swegener Exp $
+
+ 30 Jan 2010; Sven Wegener <swegener@gentoo.org> bmon-2.1.0-r3.ebuild,
+ +files/bmon-2.1.0-sysfs-symlink.patch, bmon-2.1.1_pre1.ebuild:
+ Add a patch to make bmon work with newer sysfs that has symlinks for net
+ devices.
25 Jan 2010; Jeroen Roovers <jer@gentoo.org> bmon-2.1.0-r3.ebuild,
bmon-2.1.1_pre1.ebuild:
diff --git a/net-analyzer/bmon/bmon-2.1.0-r3.ebuild b/net-analyzer/bmon/bmon-2.1.0-r3.ebuild
index 20162a20e8b9..457c68b376fc 100644
--- a/net-analyzer/bmon/bmon-2.1.0-r3.ebuild
+++ b/net-analyzer/bmon/bmon-2.1.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bmon/bmon-2.1.0-r3.ebuild,v 1.9 2010/01/25 12:54:23 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bmon/bmon-2.1.0-r3.ebuild,v 1.10 2010/01/30 22:18:23 swegener Exp $
inherit eutils toolchain-funcs
@@ -27,7 +27,8 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-nostrip.patch
# libnl crap, bug 176378
epatch "${FILESDIR}"/${P}-libnl-1.0.patch
-
+ # newer sysfs has symlinks for net class
+ epatch "${FILESDIR}"/${P}-sysfs-symlink.patch
}
src_compile() {
diff --git a/net-analyzer/bmon/bmon-2.1.1_pre1.ebuild b/net-analyzer/bmon/bmon-2.1.1_pre1.ebuild
index cc28746387a4..fb595cd4e584 100644
--- a/net-analyzer/bmon/bmon-2.1.1_pre1.ebuild
+++ b/net-analyzer/bmon/bmon-2.1.1_pre1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bmon/bmon-2.1.1_pre1.ebuild,v 1.2 2010/01/25 12:54:23 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bmon/bmon-2.1.1_pre1.ebuild,v 1.3 2010/01/30 22:18:23 swegener Exp $
inherit eutils toolchain-funcs
@@ -30,7 +30,8 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-2.1.0-nostrip.patch
# libnl crap, bug 176378
epatch "${FILESDIR}"/${PN}-2.1.0-libnl-1.0.patch
-
+ # newer sysfs has symlinks for net class
+ epatch "${FILESDIR}"/${PN}-2.1.0-sysfs-symlink.patch
}
src_compile() {
diff --git a/net-analyzer/bmon/files/bmon-2.1.0-sysfs-symlink.patch b/net-analyzer/bmon/files/bmon-2.1.0-sysfs-symlink.patch
new file mode 100644
index 000000000000..08fd70dd60fe
--- /dev/null
+++ b/net-analyzer/bmon/files/bmon-2.1.0-sysfs-symlink.patch
@@ -0,0 +1,11 @@
+--- bmon/src/in_sysfs.c
++++ bmon/src/in_sysfs.c
+@@ -164,7 +164,7 @@
+ quit("Failed to open directory %s: %s\n", topdir, strerror(errno));
+
+ while ((de = readdir(d))) {
+- if (de->d_type == DT_DIR && de->d_name[0] != '.') {
++ if ((de->d_type == DT_DIR || de->d_type == DT_LNK) && de->d_name[0] != '.') {
+ char p[FILENAME_MAX];
+
+ snprintf(p, sizeof(p), "%s/%s/statistics",