summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-09-10 03:01:52 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-09-10 03:01:52 +0000
commit4ccdfba2c0fa5887e316e63724f88488a6bf78a6 (patch)
tree27971754e539e3343cafa1fa1aab75b2dd1e2dec /net-analyzer/ethloop/ethloop-10-r1.ebuild
parent2.12 release vbump (diff)
downloadgentoo-2-4ccdfba2c0fa5887e316e63724f88488a6bf78a6.tar.gz
gentoo-2-4ccdfba2c0fa5887e316e63724f88488a6bf78a6.tar.bz2
gentoo-2-4ccdfba2c0fa5887e316e63724f88488a6bf78a6.zip
different fixes
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-analyzer/ethloop/ethloop-10-r1.ebuild')
-rw-r--r--net-analyzer/ethloop/ethloop-10-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-analyzer/ethloop/ethloop-10-r1.ebuild b/net-analyzer/ethloop/ethloop-10-r1.ebuild
new file mode 100644
index 000000000000..ec972751ce8f
--- /dev/null
+++ b/net-analyzer/ethloop/ethloop-10-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethloop/ethloop-10-r1.ebuild,v 1.1 2005/09/10 03:01:52 vanquirius Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Local simulator for testing Linux QoS disciplines"
+HOMEPAGE="http://luxik.cdi.cz/~devik/qos/ethloop/"
+SRC_URI="http://luxik.cdi.cz/~devik/qos/ethloop/ethloop10.tgz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+DEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gcc4.diff
+}
+
+src_compile() {
+ export CC="$(tc-getCC)"
+ emake || die
+}
+
+src_install() {
+ dosbin ${S}/ethloop
+}