summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-06-15 09:21:26 +0000
committerZac Medico <zmedico@gentoo.org>2008-06-15 09:21:26 +0000
commit885ed09883644947b9868b5ddad1c54c41e797d9 (patch)
treece109c1b4535ceb171d16d3ca4e47738a322d3d0 /net-analyzer/fail2ban/fail2ban-0.8.0-r1.ebuild
parentVersion bump for #221197 (diff)
downloadgentoo-2-885ed09883644947b9868b5ddad1c54c41e797d9.tar.gz
gentoo-2-885ed09883644947b9868b5ddad1c54c41e797d9.tar.bz2
gentoo-2-885ed09883644947b9868b5ddad1c54c41e797d9.zip
Bug #226505 - For compatibility with phase execution order in
>=portage-2.1.5, call has_version inside pkg_preinst instead of pkg_postinst. (Portage version: 2.2_pre10652/cvs/Linux 2.6.25-0518-x86-64 i686)
Diffstat (limited to 'net-analyzer/fail2ban/fail2ban-0.8.0-r1.ebuild')
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.8.0-r1.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-analyzer/fail2ban/fail2ban-0.8.0-r1.ebuild b/net-analyzer/fail2ban/fail2ban-0.8.0-r1.ebuild
index c347f3239888..dbce3e8940ec 100644
--- a/net-analyzer/fail2ban/fail2ban-0.8.0-r1.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-0.8.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.0-r1.ebuild,v 1.6 2007/07/05 22:49:55 falco Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.0-r1.ebuild,v 1.7 2008/06/15 09:21:26 zmedico Exp $
inherit distutils
@@ -31,8 +31,13 @@ src_install() {
doman man/*.1 || die "doman failed"
}
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.7"
+ previous_less_than_0_7=$?
+}
+
pkg_postinst() {
- if has_version '<net-analyzer/fail2ban-0.7' ; then
+ if [[ $previous_less_than_0_7 = 0 ]] ; then
elog
elog "Configuration files are now in /etc/fail2ban/"
elog "You probably have to manually update your configuration"