summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-02-13 01:17:28 +0000
committerJeroen Roovers <jer@gentoo.org>2014-02-13 01:17:28 +0000
commita3678e369f37b3fc3410ba2215b2aa63c6872283 (patch)
tree2f9200cd83e8dd4007ce28d6409ff1414a1aa439 /net-analyzer/fail2ban
parentMask x11-plugins/desklet-sudoku. Unclear license, desklets dead. (bug #446776) (diff)
downloadgentoo-2-a3678e369f37b3fc3410ba2215b2aa63c6872283.tar.gz
gentoo-2-a3678e369f37b3fc3410ba2215b2aa63c6872283.tar.bz2
gentoo-2-a3678e369f37b3fc3410ba2215b2aa63c6872283.zip
Install jail.conf(5) (bug #501116 by Balint SZENTE).
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/fail2ban')
-rw-r--r--net-analyzer/fail2ban/ChangeLog7
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.8.12-r1.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/net-analyzer/fail2ban/ChangeLog b/net-analyzer/fail2ban/ChangeLog
index 1932354abbee..481827ba5ba5 100644
--- a/net-analyzer/fail2ban/ChangeLog
+++ b/net-analyzer/fail2ban/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/fail2ban
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.126 2014/02/09 10:49:07 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.127 2014/02/13 01:17:28 jer Exp $
+
+*fail2ban-0.8.12-r1 (13 Feb 2014)
+
+ 13 Feb 2014; Jeroen Roovers <jer@gentoo.org> +fail2ban-0.8.12-r1.ebuild:
+ Install jail.conf(5) (bug #501116 by Balint SZENTE).
09 Feb 2014; Jeroen Roovers <jer@gentoo.org> -fail2ban-0.8.10-r2.ebuild:
Old.
diff --git a/net-analyzer/fail2ban/fail2ban-0.8.12-r1.ebuild b/net-analyzer/fail2ban/fail2ban-0.8.12-r1.ebuild
new file mode 100644
index 000000000000..59633533bf4a
--- /dev/null
+++ b/net-analyzer/fail2ban/fail2ban-0.8.12-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.12-r1.ebuild,v 1.1 2014/02/13 01:17:28 jer Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_{6,7} )
+DISTUTILS_SINGLE_IMPL=yes
+
+inherit distutils-r1 systemd vcs-snapshot
+
+DESCRIPTION="scans log files and bans IPs that show malicious signs"
+HOMEPAGE="http://www.fail2ban.org/"
+SRC_URI="https://github.com/${PN}/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="selinux"
+
+DEPEND="selinux? ( sec-policy/selinux-fail2ban )"
+RDEPEND="net-misc/whois
+ virtual/mta
+ virtual/logger
+ net-firewall/iptables
+ selinux? ( sec-policy/selinux-fail2ban )"
+
+src_prepare() {
+ sed -i -e 's|/var\(/run/fail2ban\)|\1|g' $( find . -type f ) || die
+}
+
+src_test() {
+ ./${PN}-testcases-all
+}
+
+DOCS=( ChangeLog DEVELOP README.md THANKS TODO doc/run-rootless.txt )
+
+src_install() {
+ distutils-r1_src_install
+
+ rm -rf "${D}"/usr/share/doc/${PN}
+
+ # not FILESDIR
+ newconfd files/gentoo-confd ${PN}
+ newinitd files/gentoo-initd ${PN}
+ systemd_dounit files/${PN}.service
+ systemd_dotmpfilesd files/${PN}-tmpfiles.conf
+ doman man/*.{1,5}
+
+ # Use INSTALL_MASK if you do not want to touch /etc/logrotate.d.
+ # See http://thread.gmane.org/gmane.linux.gentoo.devel/35675
+ insinto /etc/logrotate.d
+ newins files/${PN}-logrotate ${PN}
+}
+
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.7"
+ previous_less_than_0_7=$?
+}
+
+pkg_postinst() {
+ if [[ $previous_less_than_0_7 = 0 ]] ; then
+ elog
+ elog "Configuration files are now in /etc/fail2ban/"
+ elog "You probably have to manually update your configuration"
+ elog "files before restarting Fail2ban!"
+ elog
+ elog "Fail2ban is not installed under /usr/lib anymore. The"
+ elog "new location is under /usr/share."
+ elog
+ elog "You are upgrading from version 0.6.x, please see:"
+ elog "http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
+ fi
+ if ! has_version ${CATEGORY}/${PN} && \
+ ! has_version dev-python/pyinotify && ! has_version app-admin/gamin; then
+ elog "For most jail.conf configurations, it is recommended you install either"
+ elog "dev-python/pyinotify or app-admin/gamin (in order of preference)"
+ elog "to control how log file modifications are detected"
+ fi
+}