summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-03-01 20:35:22 +0000
committerJeroen Roovers <jer@gentoo.org>2010-03-01 20:35:22 +0000
commit086e9ff888b3a21cb2c773574ded9de87cb4bfb7 (patch)
treeccf12f59da29021b64e97045d1def7e06077d851 /net-analyzer/flow-tools
parentalpha/arm/ia64/m68k/s390/sh/sparc stable wrt #306865 (diff)
downloadgentoo-2-086e9ff888b3a21cb2c773574ded9de87cb4bfb7.tar.gz
gentoo-2-086e9ff888b3a21cb2c773574ded9de87cb4bfb7.tar.bz2
gentoo-2-086e9ff888b3a21cb2c773574ded9de87cb4bfb7.zip
Version bump to forked flow-tools project thanks to Oleg Gawriloff (bug #307291).
(Portage version: 2.2_rc63/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/flow-tools')
-rw-r--r--net-analyzer/flow-tools/ChangeLog8
-rw-r--r--net-analyzer/flow-tools/flow-tools-0.68.5.ebuild67
2 files changed, 74 insertions, 1 deletions
diff --git a/net-analyzer/flow-tools/ChangeLog b/net-analyzer/flow-tools/ChangeLog
index a958280bc44c..8c6456dac434 100644
--- a/net-analyzer/flow-tools/ChangeLog
+++ b/net-analyzer/flow-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/flow-tools
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/flow-tools/ChangeLog,v 1.40 2010/02/12 15:43:28 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/flow-tools/ChangeLog,v 1.41 2010/03/01 20:35:22 jer Exp $
+
+*flow-tools-0.68.5 (01 Mar 2010)
+
+ 01 Mar 2010; Jeroen Roovers <jer@gentoo.org> +flow-tools-0.68.5.ebuild:
+ Version bump to forked flow-tools project thanks to Oleg Gawriloff (bug
+ #307291).
*flow-tools-0.68-r8 (12 Feb 2010)
diff --git a/net-analyzer/flow-tools/flow-tools-0.68.5.ebuild b/net-analyzer/flow-tools/flow-tools-0.68.5.ebuild
new file mode 100644
index 000000000000..8b0e2d5a3855
--- /dev/null
+++ b/net-analyzer/flow-tools/flow-tools-0.68.5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/flow-tools/flow-tools-0.68.5.ebuild,v 1.1 2010/03/01 20:35:22 jer Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="library and programs to collect, send, process, and generate reports from NetFlow data"
+HOMEPAGE="http://code.google.com/p/flow-tools/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE="mysql postgres debug ssl"
+
+RDEPEND="sys-apps/tcp-wrappers
+ sys-libs/zlib
+ sys-devel/flex
+ mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql-base )
+ ssl? ( dev-libs/openssl )"
+
+DEPEND="${RDEPEND}
+ sys-devel/bison"
+
+pkg_setup() {
+ enewgroup flows
+ enewuser flows -1 -1 /var/lib/flows flows
+}
+
+src_configure() {
+ local myconf="--localstatedir=/etc/flow-tools"
+ use mysql && myconf="${myconf} --with-mysql"
+ if use postgres; then
+ myconf="${myconf} --with-postgresql=yes"
+ else
+ myconf="${myconf} --with-postgresql=no"
+ fi
+ use ssl && myconf="${myconf} --with-openssl"
+ econf ${myconf} || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README SECURITY TODO
+
+ keepdir /var/lib/flows
+ keepdir /var/lib/flows/bin
+ exeinto /var/lib/flows/bin
+ doexe "${FILESDIR}"/linkme
+ keepdir /var/run/flows
+
+ newinitd "${FILESDIR}/flowcapture.initd" flowcapture
+ newconfd "${FILESDIR}/flowcapture.confd" flowcapture
+
+}
+
+pkg_postinst() {
+ chown flows:flows /var/run/flows
+ chown flows:flows /var/lib/flows
+ chown flows:flows /var/lib/flows/bin
+ chmod 0755 /var/run/flows
+ chmod 0755 /var/lib/flows
+ chmod 0755 /var/lib/flows/bin
+}