summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-07-12 18:39:32 +0000
committerJeroen Roovers <jer@gentoo.org>2010-07-12 18:39:32 +0000
commit7e10150a776bef41f02564be351a962b03f61bb1 (patch)
tree135a3e65d1ee365e1df891f22e2f9bd72ed4d830 /net-analyzer/fping
parentStable for HPPA (bug #294214). (diff)
downloadgentoo-2-7e10150a776bef41f02564be351a962b03f61bb1.tar.gz
gentoo-2-7e10150a776bef41f02564be351a962b03f61bb1.tar.bz2
gentoo-2-7e10150a776bef41f02564be351a962b03f61bb1.zip
Version bump of sorts using Debian patches. Add USE=ipv6 thanks to Bruno Redondi (bug #319413).
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/fping')
-rw-r--r--net-analyzer/fping/ChangeLog8
-rw-r--r--net-analyzer/fping/fping-2.4_beta2_p161.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/net-analyzer/fping/ChangeLog b/net-analyzer/fping/ChangeLog
index b26cb79378c5..92e8e9a03f9c 100644
--- a/net-analyzer/fping/ChangeLog
+++ b/net-analyzer/fping/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/fping
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fping/ChangeLog,v 1.28 2010/06/03 04:28:33 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fping/ChangeLog,v 1.29 2010/07/12 18:39:32 jer Exp $
+
+*fping-2.4_beta2_p161 (12 Jul 2010)
+
+ 12 Jul 2010; Jeroen Roovers <jer@gentoo.org> +fping-2.4_beta2_p161.ebuild:
+ Version bump of sorts using Debian patches. Add USE=ipv6 thanks to Bruno
+ Redondi (bug #319413).
03 Jun 2010; Jeroen Roovers <jer@gentoo.org> fping-2.4_beta2-r2.ebuild:
Fix SRC_URI thanks to Jeff Sweeney (bug #321715).
diff --git a/net-analyzer/fping/fping-2.4_beta2_p161.ebuild b/net-analyzer/fping/fping-2.4_beta2_p161.ebuild
new file mode 100644
index 000000000000..a40dddc2942f
--- /dev/null
+++ b/net-analyzer/fping/fping-2.4_beta2_p161.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fping/fping-2.4_beta2_p161.ebuild,v 1.1 2010/07/12 18:39:32 jer Exp $
+
+EAPI="2"
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="A utility to ping multiple hosts at once"
+SRC_URI="
+ mirror://debian/pool/main/f/${PN}/${PN}_2.4b2-to-ipv6.orig.tar.gz
+ mirror://debian/pool/main/f/${PN}/${PN}_2.4b2-to-ipv6-16.1.diff.gz
+ "
+HOMEPAGE="http://www.fping.com/"
+
+SLOT="0"
+LICENSE="fping"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="ipv6"
+
+S="${WORKDIR}/fping-2.4b2_to-ipv6"
+
+src_prepare() {
+ epatch \
+ "${WORKDIR}/fping_2.4b2-to-ipv6-16.1.diff"
+ eautoreconf
+
+ if use ipv6; then
+ cp -a "${S}" "${S}-6"
+ fi
+}
+
+src_configure() {
+ econf || die "econf failed"
+ if use ipv6; then
+ cd "${S}-6"
+ append-flags -DIPV6
+ econf || die "econf failed"
+ fi
+}
+
+src_compile() {
+ emake || die "econf failed"
+ if use ipv6; then
+ cd "${S}-6"
+ emake || die "econf failed"
+ fi
+}
+
+src_install () {
+ dosbin "${S}"/${PN} || die "Failed to install fping."
+ if use ipv6; then
+ newsbin "${S}"-6/fping fping6 || die "Failed to install fping."
+ fi
+ fperms 4555 /usr/sbin/fping /usr/sbin/fping6 #241930
+ doman fping.8
+ dodoc ChangeLog README
+}