summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-05-22 19:36:40 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-05-22 19:36:40 +0000
commitdf3e47535702229fc335c5b23d6f04e4e397058d (patch)
tree9f99ffca14b1915ff72ea61e81f2244f66833b5e /net-analyzer/gnu-netcat
parentPython, pyxce using panel plugin client for NetworkManager. (diff)
downloadgentoo-2-df3e47535702229fc335c5b23d6f04e4e397058d.tar.gz
gentoo-2-df3e47535702229fc335c5b23d6f04e4e397058d.tar.bz2
gentoo-2-df3e47535702229fc335c5b23d6f04e4e397058d.zip
Add flag patch from bug #169320
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-analyzer/gnu-netcat')
-rw-r--r--net-analyzer/gnu-netcat/ChangeLog10
-rw-r--r--net-analyzer/gnu-netcat/files/digest-gnu-netcat-0.7.1-r13
-rw-r--r--net-analyzer/gnu-netcat/files/gnu-netcat-flagcount.patch22
-rw-r--r--net-analyzer/gnu-netcat/gnu-netcat-0.7.1-r1.ebuild38
4 files changed, 71 insertions, 2 deletions
diff --git a/net-analyzer/gnu-netcat/ChangeLog b/net-analyzer/gnu-netcat/ChangeLog
index 081bd77d6c09..178fb895e032 100644
--- a/net-analyzer/gnu-netcat/ChangeLog
+++ b/net-analyzer/gnu-netcat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/gnu-netcat
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/gnu-netcat/ChangeLog,v 1.13 2006/10/09 19:24:44 drizzt Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/gnu-netcat/ChangeLog,v 1.14 2007/05/22 19:36:40 jokey Exp $
+
+*gnu-netcat-0.7.1-r1 (22 May 2007)
+
+ 22 May 2007; Markus Ullmann <jokey@gentoo.org>
+ +files/gnu-netcat-flagcount.patch, +gnu-netcat-0.7.1-r1.ebuild:
+ Add flag patch from bug #169320
09 Oct 2006; Timothy Redaelli <drizzt@gentoo.org> gnu-netcat-0.7.1.ebuild:
Added ~x86-fbsd keyword.
diff --git a/net-analyzer/gnu-netcat/files/digest-gnu-netcat-0.7.1-r1 b/net-analyzer/gnu-netcat/files/digest-gnu-netcat-0.7.1-r1
new file mode 100644
index 000000000000..0c3cab207645
--- /dev/null
+++ b/net-analyzer/gnu-netcat/files/digest-gnu-netcat-0.7.1-r1
@@ -0,0 +1,3 @@
+MD5 0a29eff1736ddb5effd0b1ec1f6fe0ef netcat-0.7.1.tar.bz2 325687
+RMD160 fd5343b11849ea8b12f7c0b02b6fe3c093475ec0 netcat-0.7.1.tar.bz2 325687
+SHA256 b55af0bbdf5acc02d1eb6ab18da2acd77a400bafd074489003f3df09676332bb netcat-0.7.1.tar.bz2 325687
diff --git a/net-analyzer/gnu-netcat/files/gnu-netcat-flagcount.patch b/net-analyzer/gnu-netcat/files/gnu-netcat-flagcount.patch
new file mode 100644
index 000000000000..df029a6f15d6
--- /dev/null
+++ b/net-analyzer/gnu-netcat/files/gnu-netcat-flagcount.patch
@@ -0,0 +1,22 @@
+--- bad/netcat-0.7.1/src/flagset.c 2003-12-10 17:18:07.000000000 +0100
++++ good/netcat-0.7.1/src/flagset.c 2007-03-04 17:38:10.000000000 +0100
+@@ -134,7 +134,7 @@
+
+ int netcat_flag_count(void)
+ {
+- register char c;
++ register unsigned char c;
+ register int i;
+ int ret = 0;
+
+@@ -154,8 +154,8 @@
+ Assumed that the bit number 1 is the sign, and that we will shift the
+ bit 1 (or the bit that takes its place later) until the the most right,
+ WHY it has to keep the wrong sign? */
+- ret -= (c >> 7);
+- c <<= 1;
++ ret += (c & 1);
++ c >>= 1;
+ }
+ }
+
diff --git a/net-analyzer/gnu-netcat/gnu-netcat-0.7.1-r1.ebuild b/net-analyzer/gnu-netcat/gnu-netcat-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..fac976cc6dbd
--- /dev/null
+++ b/net-analyzer/gnu-netcat/gnu-netcat-0.7.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/gnu-netcat/gnu-netcat-0.7.1-r1.ebuild,v 1.1 2007/05/22 19:36:40 jokey Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="the GNU network swiss army knife"
+HOMEPAGE="http://netcat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/netcat/netcat-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="nls debug"
+
+DEPEND="virtual/libc"
+
+S=${WORKDIR}/netcat-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-flagcount.patch
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "emake install failed"
+ rm "${D}"/usr/bin/nc
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}