summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-03-20 17:06:56 +0000
committerJeroen Roovers <jer@gentoo.org>2013-03-20 17:06:56 +0000
commit18e937f64523e7ee3884e6553268d54aa4c5efb2 (patch)
tree8abee2701fe2b591a83518da03601cae834ab002 /net-analyzer/httping
parentVersion bump. (diff)
downloadgentoo-2-18e937f64523e7ee3884e6553268d54aa4c5efb2.tar.gz
gentoo-2-18e937f64523e7ee3884e6553268d54aa4c5efb2.tar.bz2
gentoo-2-18e937f64523e7ee3884e6553268d54aa4c5efb2.zip
Version bump.
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/httping')
-rw-r--r--net-analyzer/httping/ChangeLog9
-rw-r--r--net-analyzer/httping/httping-1.6.ebuild43
-rw-r--r--net-analyzer/httping/httping-2.0.ebuild43
3 files changed, 94 insertions, 1 deletions
diff --git a/net-analyzer/httping/ChangeLog b/net-analyzer/httping/ChangeLog
index 70ea56074f26..a3ba309114eb 100644
--- a/net-analyzer/httping/ChangeLog
+++ b/net-analyzer/httping/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/httping
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.92 2013/02/20 17:29:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.93 2013/03/20 17:06:56 jer Exp $
+
+*httping-2.0 (20 Mar 2013)
+*httping-1.6 (20 Mar 2013)
+
+ 20 Mar 2013; Jeroen Roovers <jer@gentoo.org> +httping-1.6.ebuild,
+ +httping-2.0.ebuild:
+ Version bump.
20 Feb 2013; Jeroen Roovers <jer@gentoo.org> httping-1.5.8.ebuild,
metadata.xml:
diff --git a/net-analyzer/httping/httping-1.6.ebuild b/net-analyzer/httping/httping-1.6.ebuild
new file mode 100644
index 000000000000..61d7f6b10a5e
--- /dev/null
+++ b/net-analyzer/httping/httping-1.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-1.6.ebuild,v 1.1 2013/03/20 17:06:56 jer Exp $
+
+EAPI=5
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="http protocol ping-like program"
+HOMEPAGE="http://www.vanheusden.com/httping/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug ssl tfo"
+
+RDEPEND="
+ >=sys-libs/ncurses-5
+ ssl? ( dev-libs/openssl )
+"
+DEPEND="${RDEPEND}"
+
+# This would bring in test? ( dev-util/cppcheck ) but unlike
+# upstream we should only care about compile/run time testing
+RESTRICT="test"
+
+src_prepare() {
+ sed -i "/^OFLAGS/d" Makefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ SSL=$(usex ssl) \
+ TFO=$(usex tfo) \
+ DEBUG=$(usex debug)
+}
+
+src_install() {
+ dobin httping
+ doman httping.1
+ dodoc readme.txt
+}
diff --git a/net-analyzer/httping/httping-2.0.ebuild b/net-analyzer/httping/httping-2.0.ebuild
new file mode 100644
index 000000000000..8fd55e028f99
--- /dev/null
+++ b/net-analyzer/httping/httping-2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-2.0.ebuild,v 1.1 2013/03/20 17:06:56 jer Exp $
+
+EAPI=5
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="http protocol ping-like program"
+HOMEPAGE="http://www.vanheusden.com/httping/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug ssl tfo"
+
+RDEPEND="
+ >=sys-libs/ncurses-5
+ ssl? ( dev-libs/openssl )
+"
+DEPEND="${RDEPEND}"
+
+# This would bring in test? ( dev-util/cppcheck ) but unlike
+# upstream we should only care about compile/run time testing
+RESTRICT="test"
+
+src_prepare() {
+ sed -i "/^OFLAGS/d" Makefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ SSL=$(usex ssl) \
+ TFO=$(usex tfo) \
+ DEBUG=$(usex debug)
+}
+
+src_install() {
+ dobin httping
+ doman httping.1
+ dodoc readme.txt
+}