summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-04-05 16:32:00 +0000
committerJeroen Roovers <jer@gentoo.org>2013-04-05 16:32:00 +0000
commitb475826e7ffda40070535c7fe27c0b5725a489f2 (patch)
tree9bce31e2b58a7dbe631424a15ef759272592951c /net-analyzer/httping
parent0.9.26 version bump. (diff)
downloadgentoo-2-b475826e7ffda40070535c7fe27c0b5725a489f2.tar.gz
gentoo-2-b475826e7ffda40070535c7fe27c0b5725a489f2.tar.bz2
gentoo-2-b475826e7ffda40070535c7fe27c0b5725a489f2.zip
Version bump.
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/httping')
-rw-r--r--net-analyzer/httping/ChangeLog7
-rw-r--r--net-analyzer/httping/httping-2.2.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/net-analyzer/httping/ChangeLog b/net-analyzer/httping/ChangeLog
index 4fac75bf35c2..f34ebb8105dd 100644
--- a/net-analyzer/httping/ChangeLog
+++ b/net-analyzer/httping/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/httping
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.97 2013/03/23 16:26:58 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.98 2013/04/05 16:32:00 jer Exp $
+
+*httping-2.2 (05 Apr 2013)
+
+ 05 Apr 2013; Jeroen Roovers <jer@gentoo.org> +httping-2.2.ebuild:
+ Version bump.
*httping-2.1 (23 Mar 2013)
diff --git a/net-analyzer/httping/httping-2.2.ebuild b/net-analyzer/httping/httping-2.2.ebuild
new file mode 100644
index 000000000000..8d3126e12b33
--- /dev/null
+++ b/net-analyzer/httping/httping-2.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-2.2.ebuild,v 1.1 2013/04/05 16:32:00 jer Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="http protocol ping-like program"
+HOMEPAGE="http://www.vanheusden.com/httping/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug fftw ncurses ssl tfo"
+
+RDEPEND="
+ fftw? ( sci-libs/fftw:3.0 )
+ ncurses? ( >=sys-libs/ncurses-5 )
+ ssl? ( dev-libs/openssl )
+"
+DEPEND="${RDEPEND}"
+
+# This would bring in test? ( dev-util/cppcheck ) but unlike
+# upstream we should only care about compile/run time testing
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0-flags.patch
+}
+
+src_configure() {
+ # not an autotools script
+ echo > makefile.inc || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ FW=$(usex fftw) \
+ DEBUG=$(usex debug) \
+ NC=$(usex ncurses) \
+ SSL=$(usex ssl) \
+ TFO=$(usex tfo)
+}
+
+src_install() {
+ dobin httping
+ doman httping.1
+ dodoc readme.txt
+}