summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-01-15 05:38:51 +0000
committerJeroen Roovers <jer@gentoo.org>2009-01-15 05:38:51 +0000
commit7a3d7e226d454ced9e0451019073d38177f5fc2c (patch)
tree8199cc67590aaa98d3041a531a9b33d44c141060 /net-analyzer/ipband/ipband-0.8.1.ebuild
parentDo not strip (bug #251977). (diff)
downloadgentoo-2-7a3d7e226d454ced9e0451019073d38177f5fc2c.tar.gz
gentoo-2-7a3d7e226d454ced9e0451019073d38177f5fc2c.tar.bz2
gentoo-2-7a3d7e226d454ced9e0451019073d38177f5fc2c.zip
Do not strip (bug #251978). Use toolchain. Use dobin.
(Portage version: 2.2_rc22/cvs/Linux 2.6.25-gentoo-r7-JeR i686)
Diffstat (limited to 'net-analyzer/ipband/ipband-0.8.1.ebuild')
-rw-r--r--net-analyzer/ipband/ipband-0.8.1.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/net-analyzer/ipband/ipband-0.8.1.ebuild b/net-analyzer/ipband/ipband-0.8.1.ebuild
index 9ff92e24921f..bc3bbf005352 100644
--- a/net-analyzer/ipband/ipband-0.8.1.ebuild
+++ b/net-analyzer/ipband/ipband-0.8.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ipband/ipband-0.8.1.ebuild,v 1.1 2008/12/06 19:48:18 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ipband/ipband-0.8.1.ebuild,v 1.2 2009/01/15 05:38:51 jer Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="A pcap based IP traffic and bandwidth monitor with configurable reporting and alarm abilities"
HOMEPAGE="http://ipband.sourceforge.net/"
@@ -21,16 +21,20 @@ src_unpack() {
# Provide a postfix MTA string in the author's ipband.conf example
sed -rie 's:(#mtastring.*):# Sendmail\n\1\n# Postfix\n#mtastring "/usr/sbin/sendmail -t":g' \
"${S}"/ipband.sample.conf
+
+ # Do not strip and do use toolchain
+ epatch "${FILESDIR}"/${P}-gentoo.patch
}
src_compile() {
+ tc-export CC
emake || die "Compile problem"
}
src_install() {
doman ipband.8
dodoc CHANGELOG README
- exeinto /usr/bin ; doexe ipband
+ dobin ipband
newinitd "${FILESDIR}"/ipband-init ipband
insinto /etc/ ; newins ipband.sample.conf ipband.conf
}